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New Features in This Guide

This update of the Desktop User’s Guide supports the 6.5.11 release of IRIX.

Documentation Changes

007-1342-170

The “Please Register Your System” section in Chapter 1 contains a new link.

The “Working With Shells” section in Chapter 12 contains a change in the description of
the Send pop-up menu.

The “Opening a Shell Window” section in Appendix A contains a change in the
description of what happens when you choose “Open UNIX shell” from the desktop

toolchest.

Appendix B now describes NEdit, the default editor, as well as the jot editor.






Record of Revision

Version Description

170 January 2001.
This guide documents the IRIX desktop environment.
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About This Guide

This publication is a guide to the standard graphical software environment of the
desktop. It also serves as a reference for answers to general questions about the IRIX
desktop environment.

Obtaining Publications

To obtain SGI documentation, go to the SGI Technical Publications Library at
http://techpubs. sgi.com

Conventions

The following conventions are used throughout this document:

Convention

conmand

variable

user i nput

manpage(x)
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Meaning

This fixed-space font denotes literal items such as commands, files,
routines, path names, signals, messages, and programming language
structures.

Italic typeface denotes variable entries and words or concepts being
defined.

This bold, fixed-space font denotes literal items that the user enters
in interactive sessions. Output is shown in nonbold, fixed-space font.

Brackets enclose optional portions of a command or directive line.
Ellipses indicate that a preceding element can be repeated.

Man page section identifiers appear in parentheses after man page
names.
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About This Guide

Reader Comments

If you have comments about the technical accuracy, content, or organization of this
document, please tell us. Be sure to include the title and document number of the manual
with your comments. (Online, the document number is located in the front matter of the
manual. In printed manuals, the document number is located at the bottom of each

page.)

You can contact us in any of the following ways:

Send e-mail to the following address:
t echpubs@gi . com

Use the Feedback option on the Technical Publications Library World Wide Web
page:
http://techpubs. sgi.com

Contact your customer service representative and ask that an incident be filed in the
SGI incident tracking system.

Send mail to the following address:

Technical Publications

SGI

1600 Amphitheatre Pkwy., M/S 535
Mountain View, California 94043-1351

Send a fax to the attention of “Technical Publications” at +1 650 932 0801.

We value your comments and will respond to them promptly.

XXXii
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Getting Started

Once your workstation is up and running, you can use the Desktop User’s Guide to begin
learning about the software environment in which you will be working. This is a guide
to your system’s standard graphical software environment, which includes the
Toolchest— a starting point for almost anything you need to do. Turn to this guide to:

*  Get step-by-step instructions for completing essential tasks, such as finding files
and managing windows.

¢ Learn techniques and shortcuts that will make you a more efficient workstation

user.

This guide also serves as a reference—a place to look for answers to general questions
about your desktop environment.

Getting Started introduces you to the basics, supplies summaries of fundamental tasks,
and often links to more details. It includes the following sections:
¢ “Logging In and Out”

¢ “Identifying What Is on the Screen When You First Log In”

¢ “Using the Mouse”

¢ “Manipulating Windows”

¢ “Finding Software and Applications”

¢ “Adjusting Volume”

* “Using Online Documentation”

* “Getting Application Help”

¢ “Turning Off Your Workstation”

®  “Online Document Conventions”

¢ “Please Register Your System”

e “Where to Go From Here”
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Logging In and Out

Logging In

Two or more people can be using the same system at the same time. Although only one
person can be physically seated in front of the system, others can use it via the network
that connects many computers in an office environment.

To keep this situation manageable, each person who uses the system has to “log in” to it
under a special identity, called their “user” or “login” name. Once this identity is created,
you have your own user account.

Your workstation is like a shared house with personal rooms. If you think of the
workstation as a home, your login name is your own personal door into the home, and
your user account is the room you enter through that door.

Logging in is the first step you take to begin using your workstation. Initially, you can log
in using one of the default user accounts (such as Guest). See “Using Existing Login
Accounts” to learn why you should limit your use of these accounts; see “Why Create a
Login Account?” to learn about the benefits of having your own login account.

To create your own user account, see “Setting Up Your System” in the Personal System
Administration Guide to learn how to create your account.

When your workstation is turned on, the first static screen you see is the login screen,
which has icons representing any user accounts on the system.

To log in, select an icon, then click the Log In button. If the account has a password, you
will be prompted to type in the account password.

Tip: You can also log in to your system from other systems on your network, and you
can log in to other systems on your network from your own system. See “Logging In to
Another System.”
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Identifying What Is on the Screen When You First Log In

Logging Out

To log out of an account, choose Desktop > Log Out from the Toolchest.

Shortcut: Position the cursor over the deskfop background and press the right mouse
button to display a menu. Choose Log Out.

Identifying What Is on the Screen When You First Log In

When you log into your system for the first time, you see the following things:
* The desktop background and the icons that appear on it

* The Toolchest menu

® The Icon Catalog

e The console window

Each of these items is described in the following subsections.

The Desktop Background

007-1342-170

The screen background is also called the desktop, although the term desktop is also used
to refer to all of the standard graphical software that comes with your system. The
desktop background is a place for you to set frequently used icons so you have quick and
easy access to them. In this way, the background is similar to an actual office desk. For
example, sitting on your desk, you might have a telephone, a container of pens and
pencils, and a stack of folders or notebooks related to the projects on which you are
currently working. Other, less frequently used items are stashed away in desk drawers.

By default, several icons are placed on the desktop: a folder icon representing your home
directory, a dumpster icon, several application icons, and an icon for each peripheral you
have installed.
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The Toolchest Menu

Icon Catalog

Console Window

The Toolchest menu contains a stack of “toolchests” organized into categories for easy
access to virtually all system functions and programs. Move the cursor over a label on a
toolchest; then hold down the left or right mouse button to pop up a menu.

The Icon Catalog has a blue background and a row of tabs along the bottom edge of the
window. It shows collections of applications and tools that are available on your system.
From this window, you can:

* Browse through the icons to see what applications are available.
¢ Run applications by double-clicking their icons.

¢ Find icons you want to use; then drag them onto the desktop or onto a shelf so they
are easily accessible.

¢ Create your own collection of icons.

For example, suppose you use a combination of programs to create and edit movies.
You can create a new page; then place icons for these tools onto that page.

Each collection is stored on a separate page. If you want to create your own collection of
icons, you can add pages to the Icon Catalog.

The square icon next to the Toolchest is the console window. (It looks like a square icon
because it has been minimized.) Many of the error messages that the system generates
appear in this window. Open it to its full size by clicking on it with the left mouse button.
You can type IRIX commands in this window. You should always have a console running
because the console is the primary display area for status and error messages generated
by your system. If your system or a specific application you are running behaves
unexpectedly, check the console for any possible error messages. Though you may not be
able to make any sense of the error messages at first, they will be useful clues to any
system administrator trying to resolve a problem with your system.
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Using the Mouse

Using the Mouse
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To get started, you need to know a few basic techniques for using the mouse and working
with icons.

To select an icon, place the cursor over the icon, then click the left mouse button.
Icons turn yellow when they are selected.

To select several icons, press the Shi f t key while selecting the icons or press the left
mouse button and drag the mouse.

All icons touched by the box you create are selected.

To open an icon, place the cursor over the icon, then double-click the left mouse
button.

When you open an application icon, you run the application; when you open a
folder icon, you open a window that shows the contents of that directory.

To drag and drop icons, place the cursor on an icon, then press the left mouse button
and move the mouse.

Release the mouse button to drop the icon. Application and folder icons turn blue
when they are ready to accept an icon. A drop pocket also turns blue when it is ready
to accept an icon. This drag-and-drop technique lets you move icons from one
directory to another, launch applications with a particular file, and place icons in
drop pockets.

To display a pop-up menu that contains commands from the Selected menu, place the
cursor over a window or on the desktop background, then press the right mouse
button.
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Manipulating Windows

Most of the windows that appear on your screen have standard fixtures. Below is picture
of an Icon View window. You open an Icon View whenever you open a directory—for
example, when you double-click a folder icon.

mﬂﬂw Path Pathname m?‘i(r‘r(l)i\zve
Button Bar Field Button

haximize
Window
Button
T | o |
Pocket Eﬁa)g:r!e
Border
g
S
Figure 1-1 An Icon View Window with Common Fixtures Labeled

You can use the fixtures labeled in Figure 1-1 to manipulate windows in a variety of
ways.

Note: Occasionally, you see a window that is missing the border and title bar. Such a
window is called a borderless window.
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Manipulating Windows

The Title Bar

The title bar allows you to move, raise, and lower windows.

e Place the cursor in the title bar; then press the left mouse button and drag to move
the window.

e Place the cursor in the title bar; then click the left mouse button to raise the window
to the top of the stack of windows.

e Place the cursor in the title bar; then press the Ct r | key and left mouse button
simultaneously to lower the window to the bottom of the stack of windows.

The Window Menu Button

The Minimize Button

The Maximize Button
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The Window menu button lets you access the Window menu and provides a shortcut for
closing windows.

* Place the cursor over the button and press the left mouse button to see the Window
menu.

e Double-click the button with the left mouse button to close the window.

Click the Minimize button with the left mouse button to turn the window into a small,
square icon. This does not close the window or stop any of the programs that are running.
It turns it into an icon that takes up less screen space.

Click the Maximize button with the left mouse button to make the window as large as it
can be. Some windows become as large as the screen; others change only slightly. If a
window does not change or becomes smaller when you click the Maximize button, the
window was already at its largest size. To restore a maximized window to its original
size, click the Maximize button again.
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The Border

The Scroll Bars

The Drop Pocket

You can use the border in conjunction with the mouse buttons and keyboard keys to
manipulate the window in a variety of ways:

Place the cursor on the border; then press the right mouse button to open the
Window menu.

Place the cursor on the border. When you see a resize cursor, drag the mouse to
resize the window.

Place the cursor on the border; then press the middle mouse button and drag to
move the window.

Place the cursor on the border; then press the left mouse button to raise the window.

Place the cursor on the border; then press the Ct r | key and left mouse button
simultaneously to lower the window.

You will see windows with scroll bars along the left or right and top or bottom edge.
These indicate that the window is too small to display all of its contents. Use the scroll
bar to view hidden portions of the window.

A drop pocket is the small square into which you can drop icons. Here are several ways in
which you can use drop pockets:

Drag a folder icon and place it into the drop pocket on an Icon View window.
The window displays the contents of that folder.

Drag a file or application icon and place it in the drop pocket on an Icon View
window.

The window displays the contents of the directory in which that icon is stored. For
example, suppose you drag the IRIS Showcase icon into the drop pocket. The
window displays the contents of the / usr/ sbi n directory.
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Manipulating Windows

The Pathname Field

The Path Bar

The Recycle Button
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® Drag an IRIS Showcase icon and drop it into a drop pocket on the Search tool to
specify the type of files you want to find—in this case, IRIS Showcase files.

You can also drag icons out of the drop pocket and place them onto the desktop, onto a
shelf, or into the Icon Catalog.

The pathname field shows the full pathname of the directory whose icon or contents are
displayed in the window. You can type a new name in this field to display the contents
of a different directory.

The path bar lets you move from one directory to another, without typing. It contains a
small button representing each directory in the pathname. See Figure 1-2.

Click here to display the / directory.
— Click here to display the A directory.

Figure 1-2 Using the Path Bar

The Recycle button keeps a list of names you have specified in a type-in field. For
example, place the cursor over the Recycle button on an Icon View window; then press
the left mouse button to see a list of directories whose contents you have previously
displayed in the window. Choose an item from this list and the window changes to
display the contents of that directory.



1: Getting Started

Finding Software and Applications

Your workstation includes many bundled software tools. Most of these tools have icons
that appear on the desktop or on a page in the Icon Catalog. Open the Icon Catalog by
selecting Find > Icon Catalog from the Toolchest. See also Chapter 6, “Finding Things.”

Here are a few examples of the tools and their capabilities. Click red text to launch the
tool that it names.
* Create and edit text files using NEdit or IRIS Showcase.

* Create interactive presentations that include 3D models, audio, video, and 2D
graphics using IRIS Showcase.

* Browse the Web using Netscape; create HTML files using WebMagic; publish files
on the Web using OutBox.

* Touch up images using the ImageVision tools.

¢ Keep track of the time and date using a clock and calendar program.

* Listen to compact discs or DAT tapes using CD Manager and DAT Manager.
* Create and edit audio files using Sound Editor or Sound Track.

* Create and watch movies using Movie Player and Movie Maker.

Adjusting Volume

The Audio Panel lets you adjust the audio parameters such as the volume and sampling
rates of audio coming into your system. Use it to set up and control microphones, CD
players, and other audio devices connected to your workstation. See the Help in the
Audio Panel for information on using the panel. You can open the Audio Panel from the
Toolchest by choosing Desktop > Control Audio.

Note: You can use the Sounds panel to control system sounds. To open this panel, choose
Desktop > Customize > Sounds from the Toolchest. See “Controlling System Sounds.”
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Using Online Documentation

Using Online Documentation

Access online documentation from the Help toolchest.

Choose “Info Search” and the documentation search tool appears. This lets you
access and search all documentation on the system, including online books, help,
man pages, and release notes.

Choose “Quick Answers” for quick answers to questions related to the tasks and
tools that are a part of your system’s end user software environment. Choose this
command when you need to perform a task but are uncertain which tool to use or
how to begin.

Choose “Hints and Shortcuts” to discover useful desktop features for working
smarter and faster.

Choose “Online Books” and the IRIS InSight Document Library appears.

Once IRIS InSight is open, you can type in a word or phrase and quickly find and
open the books that contain the information you need. See the Help in IRIS InSight
for instructions.

See also “Getting Application Help.”

Getting Application Help
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Each application provides a Help button or menu so that you can get help on that

particular application.

If you need to perform a task but are uncertain which tool to use or how to begin, choose
Help > Quick Answers from the Toolchest.

You can also open an overview description of some applications by selecting the

application icon and choosing “What Is This?” from the Selected menu in an Icon View,
Icon Catalog, or the Toolchest.

Still have questions? Open Info Search by choosing Help > Info Search from the
Toolchest. Use it to search for information on a specific word or phrase, and browse or
search Online Books.
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1: Getting Started

Turning Off Your Workstation

Before turning off your workstation, you need to shut down the operating system.
Shutting down the operating system safely closes all of the files and logs you out. If you
turn off the workstation without shutting it down properly, files may be lost or damaged.

To shut down the system, choose System > Shut Down System from the Toolchest.

Online Document Conventions

Some online style conventions make the information in this guide easy to access and
understand. This list tells you what they are.

e Links to term definitions are in blue italics.
e Links to other documents are red.

¢  When application names appear in red text, it indicates that clicking on the red text
launches the named application.

e Links to other chapters and sections within this guide are in quotation marks.

¢ Numbered sentences are sequential steps you follow to complete a task. Sentences
that follow a step and are preceded with a square bullet are substeps; they describe
in detail how to accomplish the step.

Please Register Your System
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To qualify for great prizes in our quarterly registration raffle, fill out and return your
On-Line Registration form by double clicking the Register_To_Win icon on your desktop.
For additional registration information, see the Customer Registration Web site:

http:/ /support.sgi.com/custreg

Note: The information you provide will be used only by SGI and/or the reseller who
sold you your system.
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Where to Go From Here

When you purchase a Silicon Graphics system, we want you to know that you are our
customer not just for today but tomorrow and beyond. It is important that we have
accurate information about you in our customer database. Your feedback about our
products and services is very valuable for us. And, we would like to understand how you
are using our technology so that we can continue to engineer system configurations that
work best for you.

Where to Go From Here
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To learn about the concept of accounts and multiple users, see Chapter 2, “Login
Basics: Understanding Accounts.”

To learn how to find, start, and install applications, see Chapter 3, “Using
Applications.”

To learn how to work with files and directories, see Chapter 4, “Managing Your
Work: Working with Files and Directories.”

To learn how to print files and customize printer settings, see Chapter 5, “Printing.”
Looking for something on your system? See Chapter 6, “Finding Things.”

To learn how you can create and use multiple desktops, see Chapter 7, “Using
Multiple Desks.”

To learn how to move, resize, and close windows, see Chapter 8, “Managing
Windows.”

To learn how to copy files between systems on a network, or to tape, and to set and
change permission settings, see Chapter 9, “Sharing and Protecting Files, Media
Devices, and Printers.”

For information on making your desktop environment fit your own tastes and work
style, see Chapter 11, “Customizing the Desktop Environment.”

To learn about utilities such as a clock or calendar, see Chapter 12, “Using System
Utilities.”

For information on a particular menu, command, or button, see Chapter 13,
“Anatomy of the Desktop.”

For information on using the text editor jot, see Appendix B, “NEdit and jot”.
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1: Getting Started

* To learn how to manage your workstation, see the Personal System Administration
Guide. It describes how to use the System Manager to maintain your workstation.

¢ For information on your workstation hardware, see the owner’s guide that came
with your workstation. Owners guides can be accessed on the Web at:

http://techpubs. sgi.conl
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Chapter 2

Login Basics: Understanding Accounts

Your workstation requires that you log in to identify yourself as a user, and log out to
signal that you are finished using the workstation.

This chapter contains the following sections:

¢ “Overview of Login Accounts”

¢ “Why Create a Login Account?”

¢ “Using Existing Login Accounts”

Overview of Login Accounts

Identifying yourself as a user—logging in—is the first step you take to begin using your
workstation. Creating your own login account is the second step. Initially, you can log in
using one of the default login accounts, such as guest. See “Using Existing Login
Accounts” to learn why you should limit your use of these accounts; see “Why Create a
Login Account?” to learn about the benefits of having your own login account.

See “Setting Up Your System” in the Personal System Administration Guide to learn how to
create your account.

Related Topics:
¢ “Logging In and Out”
¢ “Logging In to Another System”
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2: Login Basics: Understanding Accounts

Why Create a Login Account?

Creating a login account provides:

¢ Security. You can set a password that prevents other people from logging in with
your name.

® Privacy. The system uses your login name to label files and directories that belong to
you. You can read, change, and delete files and directories that belong to you, and
you can protect your work from other users via permissions. See “Understanding
and Changing Permissions.”

¢ Personal Preferences. You can modify your working environment in a variety of
ways. For instance, you can place the icons you use frequently onto the desktop.
When you log in, the desktop displays these icons. You can also customize the
background and color schemes.

See “Setting Up Your System” in the Personal System Administration Guide to learn how to
create your account.

Using Existing Login Accounts

16

When you first turn on the system, you see icons for several existing accounts. Here is a
brief description of four existing login accounts and their use:

guest account The guest account lets you log in when you do not yet have your own
account. It also allows other people to log in to your workstation and
copy and view certain files.

OutOfBox account
If you have an Indy or O2 workstation, you are automatically logged in
to the OutOfBox account when you turn on your system for the first
time. It takes you on a visual journey, during which movies, audio, and
graphics help you explore the capabilities of your system. If you do not
have an Indy or O2 workstation, you do not see this login account.

root account  The root account is for the administrator of the workstation. The root
account gives the administrator special permissions and access to
utilities that are not available to ordinary users. For example, when you
are logged in as root, you can delete any file, regardless of who owns the
file. Unless you are responsible for system administration on your
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Using Existing Login Accounts
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workstation, you should log in as root infrequently. For an explanation
of system administration, see “Performing System Administration
Tasks” in the Personal System Administration Guide.

EZsetup account
The EZsetup account lets you add an account for the primary user of the

system and enable networking. Once you add a password to the
Administrator account (root) you will need to know the root password
to use the tool again.

17






Chapter 3

Using Applications

This chapter contains information on:

¢ “Installing Applications”

® “Accessing Available Applications”

* “Starting Applications”

¢ “Removing Applications”

* “Creating a Collection of Application Icons”

¢ “Copying and Pasting Between Applications”

Installing Applications

To install applications that came from your system’s manufacturer, use the Software
Manager. Refer to the Software Manager Help button for details on using Software
Manager. To install software from other vendors, see the instructions that came with the
software.

Accessing Available Applications

See “Finding Applications” on page 77 for information on accessing applications on your
system and see “Accessing Applications On Remote Systems” on page 22 for
information on accessing applications on other systems on your network.
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3: Using Applications

Starting Applications

This section lists three techniques for running applications: double-clicking icons, using
the selected menu, and dragging and dropping icons. Also see “Saving Your Desktop
Layout.” It describes how to make applications start up automatically when you log in.

Starting Applications by Double-Clicking

The easiest way to start an application is to place the cursor over the application icon and
double-click with the left mouse button.

Tip: If you use an application frequently, drag the icon onto the desktop so it is easily
accessible. See also “Giving Yourself Easy Access to Icons.”

Starting Applications From the Selected Menu

You can start an application by using the “Open” command on the Selected menu.

1. Place the cursor over the icon, then click the left mouse button to select the icon. The
icon turns yellow when it is selected.

2. Do one of the following:

e If theicon is in a window, such as an Icon View, choose Open from the Selected

menu on the window that contains the icon.

e If the icon is on the desktop, choose Open from the Selected toolchest.

Shortcut: Use the right mouse button to select the Selected menu. Select the icon, then
hold down the right mouse menu button.

Starting Applications by Dragging and Dropping Icons

Dragging and dropping icons allows you to simultaneously launch both the file and the
application that you want to open.
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Starting Applications

1. Place the cursor over the icon of the file you want to view or edit. The icon brightens
slightly when the cursor is above it.

2. Press and hold down the left mouse button. The icon turns yellow.

3. Drag the cursor and icon until they are over the application icon. The icon travels
with the cursor, leaving behind a gray outline.

4. When the application icon turns blue, release the mouse button.

The icon you dragged returns to its original location. The application runs and the
file opens.

Note: If the application icon does not turn blue when you drag an icon on top of it, click
once on the application icon, then try dragging and dropping again. If the icon still does
not turn blue, the system cannot perform the operation. For example, a folder icon will

not turn blue if you drag a file onto it but do not have permission to alter to that directory.

Starting Applications with Command Line Options
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Some applications let you specify the mode in which you want them to run. You do so
by specifying a command line option. You usually type command line options into a shell
window. This section describes how you can specify a command line option without
using a shell window.

For example, to run IRIS Showcase, the drawing and presentation package that came
with your system, in view-only mode:

1. Select the IRIS Showcase icon, press the Al t key, and double-click the left mouse
button.

A form appears. The text that appears is the IRIX command required to run the
application.

2. Type the command line option after the text, then press Ent er. In this example, you
add - v to the end of the line, so the complete command line would be:

[ usr/ sbin/showase -v fl

Many applications offer command line options. Refer to the man pages (in InfoSearch) to
find out available command line options for a particular command.
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3: Using Applications

Accessing Applications On Remote Systems

If your workstation is part of a network, you can use applications that are installed on
another workstation. To do this, use the Access Desktop form or use a shell window, as
described in:

“Using the Access Desktop Panel to Access Applications on Another System”

“Using the rlogin Command to Access Applications on Another System”

Using the Access Desktop Panel to Access Applications on Another System

22

You can use the Access Desktop panel to access an application on another host and
display it on your screen.

To open the Access Desktop tool from the Toolchest, choose Desktop > Access Files > By
Remote Login.

1.
2.

Type in the name of the remote workstation.
Type in the login name and password.

You can type in the login name of a user who has a login account on the remote
system. Or, if you do not have an account on the remote system, or do not know an
account name on the system, try guest.

Do one of the following:

e If you do not know what directory the application is in, click Toolchest, then
Apply, and then choose Find > Icon Catalog from the remote Toolchest that
appears.

* If you know the directory that the application is in, click “Directory” to open an
Icon View of that directory. Then, type in the pathname for the directory that
contains the application. Click Apply.

Use the newly launched remote Icon Catalog or Icon View to locate the application
icon.

Double-click the application icon to open the application.

The application window appears on your desktop.
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Starting Applications

Using the rlogin Command to Access Applications on Another System
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If your workstation is part of a network, you can use applications that are stored on
another workstation. To do this, you can log in to the other workstation, then tell the
application to display its windows on your workstation screen.

Before using r | ogi n to log into the remote system, make sure that Enable Remote
Display is turned on. This ensures that you can display remote applications on your
screen. To do this, open the Desktop Settings control panel by selecting “Desktop” from
the Customize menu in the Desktop toolchest. A checkmark should appear in the box
next to “Enable Remote Display.” If a checkmark does not appear, click the box to enable
remote display.

To use r 1 0gi n to access applications on another system:

1.
2.

Open a shell window by selecting Desktop > Open Unix Shell from the Toolchest.
Place the cursor in the shell window, then type:

rl ogi n workstationname -1 guest

Then press Ent er.

After a few seconds, you see a message in the shell window that tells you the name
of the workstation you logged in to, the version of software it is running, and some
copyright information.

Note: If the workstation you are logging in to is in a different domain, you need to
specify the domain name. For example, if you are logging in to a workstation named
ambrosia, and it is part of a domain named bldg2, you need to type anbr osi a. bl dg2.

Set the DISPLAY environment variable by typing:
setenv DI SPLAY yourworkstationname: 0. 0

The DISPLAY environment variable specifies which workstation screen will display
the program.

Type pri nt env to make sure DISPLAY is set properly.
You should see a line similar to this:

DISPLAY=yourworkstationame:0.0
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3: Using Applications

5. Type the program name into the shell window, then press Ent er.

Note: The command you type may be different from the full program name. For
example, to run IRIS Showcase you type: showcase

The program should appear on your screen.

When you are finished working with the application and want to log out of the
other workstation, type exi t in the same shell window, then press Ent er.

Note that Enable Remote Display makes your own desktop remote display open to all
remote hosts, so you may want to turn it off when you are not using it.

Removing Applications

When your system starts getting low on disk space, you may want to review the list of

software products that are currently installed. You may no longer need certain products,
or you may discover that some products include large, optional subsystems that you can
remove without removing the core product. Use the Software Manager to do this. From
the Toolchest, choose System > Software Manager. Refer to the Software Manager Help
menu for details on using Software Manager.

Creating a Collection of Application Icons

The Icon Catalog shows collections of applications and tools that are available on your
system. You can also use the Icon Catalog to create your own collection of icons. For
example, suppose you use a suite of tools to create 3D models. You can place them all on
a page in the Icon Catalog so they are easily accessible.

To open the Icon Catalog, click the words Icon Catalog now, or select the Find menu from

the Toolchest and choose an item from the Icon Catalog menu. See the Help menu on the
Icon Catalog for details on creating a new catalog page.
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Copying and Pasting Between Applications

Copying and Pasting Between Applications
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Some applications support a global copy and paste mechanism. This means you can copy
and paste text, sound, images, and more from one application to another. For example,
suppose you want to copy an image from an IRIS Showcase page and place it onto the
InPerson whiteboard. You can do so using the “Copy” and “Paste” commands on the
Edit menu or the middle mouse button.
To use the “Copy” and “Paste” commands on the Edit menu:
1. Select the image on the IRIS Showcase page.

The image is surrounded by green selection boxes when it is selected.
2. Choose “Copy” from the Edit menu in IRIS Showcase.

3. Choose “Paste” from the Edit menu in the InPerson window.

The image appears on the whiteboard.

To copy the image using the middle mouse button:
1. Select the image on the IRIS Showcase page.

The image is surrounded by green selection boxes when it is selected. This object is
called the primary selection because it is the most recent selection.

2. Before clicking the left mouse button or making another selection, place the cursor
over the InPerson whiteboard, then click the middle mouse button.

The image appears on the whiteboard.
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Chapter 4

Managing Your Work: Working with Files and
Directories

This chapter includes instruction on how to manage and work with files and directories.
The sections are:

* “Giving Yourself Easy Access to Icons”

e “Managing Icons”

e “Moving and Copying Files and Directories”
e “Making a Referenced Copy of an Icon”

¢ “Renaming Files and Directories”

¢ “Removing Files and Reference Icons”

* “Creating and Opening Directories”

* “Opening and Saving Files”

* “Creating Files Using Select and Paste”

¢ “Naming Icons: A Few Guidelines”

Related Topics:

¢ Part of managing your work is managing your multiple-window environment—see
Chapter 8, “Managing Windows.”

¢ Another technique you can use for managing your work is to use multiple
desktops—see Chapter 7, “Using Multiple Desks.”
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4: Managing Your Work: Working with Files and Directories

Giving Yourself Easy Access to Icons

For quick access to your most-used icons, you can drag and drop them on one of three
places: on the desktop, on a shelf, or in the Icon Catalog. Dropping an icon on any of these
places automatically creates a copy of the icon, called a reference icon.

Related Topic: “Removing Files and Reference Icons.”

Using a Shelf for Convenient Icon Access

28

A shelf is a feature of the Icon View, a place for you to put icons that you need to use
frequently while working in a particular directory. For example, if the directory contains
many files, you might want to place the files you use most frequently on the shelf. Or, if
the directory contains many color Showcase slides, you might want to place the icon for
a color printer onto the shelf.

Figure 4-1 shows an Icon View window with a shelf (the cursor is inside of the shelf area).
Notice that the shelf is blue; the rest of the window is light green. A blue background in
a window (such as the Icon Catalog) or panel (such as the Shelf on an Icon View)
indicates that it is a reference icon holder. If an icon is dropped on the blue background,
a reference icon is automatically created.

Click, type, or sweep to select icons

Figure 4-1 Icon View Window with Shelf
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Giving Yourself Easy Access to Icons

To place an icon on the shelf:

1. Display the shelf by choosing Options > Show Shelf, or by clicking the Shelf button
in the toolbar on the left side of the Icon View window.

Figure 4-2 The Shelf Button

2. Drag the icon onto the shelf.

Note: Placing an icon on a shelf gives you a reference to the icon so you can access it more
easily. It does not move or copy the file.

If you no longer need to use an icon frequently, you can remove it from the shelf by
selecting it and choosing “Remove” from the Selected menu. This removes the reference
icon, not the original file or application.

Placing Reference Icons on the Desktop Background

The screen background is a place for you to set frequently used icons so you have quick
and easy access to them. By default, several icons are placed on the desktop background:
a folder icon representing your home directory, a dumpster icon, several application icons,
and an icon for each peripheral you have installed. To place additional icons on the
desktop:

1. Place the cursor over the icon that you want to place on the desktop; then press the
left mouse button and drag the icon onto the desktop.

2. Release the mouse button. The icon appears on the desktop.
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4: Managing Your Work: Working with Files and Directories

Note: Placing an icon on the desktop background gives you a reference to the icon so you
can access it more easily. It does not move or copy the file.

If you no longer need to use an icon frequently, you can remove it from the desktop by
selecting it and choosing Selected > Remove from the Toolchest. This removes the
reference icon, not the original file.

Placing Reference Icons in the Icon Catalog

The Icon Catalog shows collections of applications and tools that are available on your
system. You can add icons to a page in the Icon Catalog, and you can create new pages.
See “Adding Icons to an Icon Catalog Page” and “Adding Your Own Pages in the Icon
Catalog.”

Adding Icons to an Icon Catalog Page
Each page in the Icon Catalog shows a collection of icons. To add an icon to an existing
page, do the following:

1. Place the cursor over the icon that you want to add to the page; then press the left
mouse button and drag the icon into the Icon Catalog window.

Tip: If you need help finding the icon, use File QuickFind or the Search tool: from
the Toolchest, choose Find > File QuickFind or Search For Files.

2. When the icon is over the blue portion of the window, release the mouse button. The
icon appears on the page.

Note: Placing an icon in the Icon Catalog gives you a reference to the icon so you can
access it more easily. It does not move or copy the file.

If you no longer need to use an icon frequently, you can remove it from the Icon Catalog
by selecting it and choosing “Remove” from the Selected menu. This removes the
reference icon, not the original file.
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Giving Yourself Easy Access to Icons

Adding Your Own Pages in the Icon Catalog

By default, the Icon Catalog contains several pages. You can create a new page, with a
name of your choice, on which to store your own collection of icons.

1. Choose “New” from the Page menu.
Enter the name of the new page in the dialog that appears.
2. Place icons on the page.

Place the cursor over the icon that you want to add to the page; then press the left
mouse button and drag the icon into the Icon Catalog window.

Note that placing an icon in the Icon Catalog gives you a more convenient place
from which to access the icon—it does not move the actual file or application.

Note: Choose “Rename” from the Page menu to specify a different name for the page.
See “Renaming an Icon Catalog Page” for step-by-step instructions.

Renaming an Icon Catalog Page

To rename an Icon Catalog page:
1. Display the page that you want to rename.
If necessary, refer to “Navigating Pages in the Icon Catalog.”

2. Choose Page > Rename and enter a new name in the dialog that appears.

Note: You cannot rename the system’s default Icon Catalog pages, you can only rename
pages that have been added.

Removing a Page From the Icon Catalog
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If you decide that you do not need a page that you have added to the Icon Catalog, you
can remove it. To do so, turn to the page you want to remove; then choose “Remove”
from the Page menu.

You cannot remove the default pages. If you turn to a default page and choose the
“Remove” command, you make any icons that you had added to the page disappear.
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4: Managing Your Work: Working with Files and Directories

When you remove a page, you do not delete the actual items that icons on that page
referenced. To find the items again, choose “File QuickFind” from the Find menu, or
open the Search tool by choosing “Search for Files” from the Find menu.

Navigating Pages in the Icon Catalog

Managing lcons

Sorting Icons

32

To go from one Icon Catalog page to another, click the tab of the page you want to go to.

Some of the tabs might not fit in the space provided. When this happens, a stack of
unnumbered tabs appears at the left or right edge of the tab display area. To turn to a
page whose tab is hidden:

1. Place the cursor over the stack of unnumbered tabs; then press the left mouse
button.

2. Choose a page from the menu that appears.

Tip: You can also navigate from page to page by pressing the Page Up and Page Down
keys on your keyboard.

You can change the way that icons are arranged and displayed in Icon View windows and
on pages in the Icon Catalog and Search tool. This section contains some information that
is common to all three windows and some that is specific to Icon View windows.

The Sort menu lets you change the way in which icons are sorted.
e Choose “by Name” to list the icons alphabetically.

e Choose “by Date” to list the files according to the date on which they were last
modified.

e Choose “by Size” to list the files according to their size, starting with the largest.

e Choose “by Type” to list the icons by type (directory, file, or application, for
example).
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Managing Icons

Resizing Icons

Windows contain a thumbwheel that you can use to change the size of the icons in that
window. Place the cursor over the thumbwheel; then drag the mouse up to make the
icons smaller and down to make the icons larger. To return to the original icon size, click
the small box below the thumbwheel.

If you are enlarging the icons in order to see a specific icon, select that icon first so that it
stays within the current view as you are resizing.

If you do not see the thumbwheel, drag the bottom border of the window down to resize
it until the thumbwheel appears.

Note: To change the size of icons on the desktop, use the Desktop Settings panel. Choose
Desktop > Customize > Desktop from the Toolchest.

Viewing File Information (Viewing “as List”)
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When you open a directory icon, the contents of the directory appear as icons scattered
throughout the window. Choose “as List” from the View menu to arrange the icons in a
sorted list. When you view the icons in a list, you can see:

¢ Theicon name

® The size of a file icon in bytes

e The date and time at which the file was modified
e Permissions information

¢ The file type (for example, “plain text file”)

Additionally, in Icon View windows, you see an arrow next to folder icons. Click the
arrow to display the contents of that folder.

When icons are displayed in a list, you can also view directory sizes by choosing
“Directory Sizes” from the View menu.

33



4: Managing Your Work: Working with Files and Directories

Note: Directory sizes are not dynamically updated. For example, if you added another
file to a directory, you would need to choose View > Directory Sizes again to see the
increased directory size.

Displaying Icons in Columns

Choose “as Columns” from the View menu to organize icons into columns. To change the
view again, use the View menu.

Figure 4-3 Icons Organized into Columns

Displaying “Thumbnails” of Image Files in an Icon View

If you are looking for a particular image, but cannot remember what you named it, you
can display mini-views of image files in the Icon View window. Click the Thumbnail
Images button in the toolbar (shown in Figure 4-4) or choose View > as Thumbnail
Images from the Icon Catalog.

Figure 4-4 The Thumbnail Images Button
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Viewing Hidden (“Dot”) Files

Many IRIX configuration files are hidden by default. You do not see them in an Icon View

7

window. These files are commonly called dot files because a “.” appears as the first
character in the filename. The . | ogi n and . cshr c files in your home directory are
examples of hidden files. You can choose to view or hide these files using the “Hidden
Files” command on the View menu. A checkmark next to the command indicates that the
files are displayed in that Icon View window.

Displaying a Quick View of the Contents of a File

You can quickly view the contents of a file —without opening the file—by using the
Content Viewer. The Content Viewer displays a read-only version of the file in a viewer
window at the bottom of the Icon View window.

Figure 4-5 The Content Viewer Button

To preview the contents of a file:

1. Click the Content Viewer button in the toolbar (shown in Figure 4-5) or choose
“Show Content Viewer” from the Options menu.

The Content Viewer window appears at the bottom of the Icon View window.
2. Click once on the file you want to view.

The file appears in the Content Viewer.

Searching for Icons by Name or Content

Use the Actions > Search/Filter Files menu item to open a panel that lets you choose to
display only those icons whose name or content matches a certain string of characters.

1. From the Icon View window, choose Actions > Search /Filter Files

2. Fill in the fields, as needed:
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¢ Type a string of characters in the “Show files that match name” field. For
example, to find files that begin with the letter “d,” type: d. To find files that end
with the extension “.rgb,” type *. r gb.

¢ Type astring of characters in the “Show files containing text” field. The window
immediately changes to display only those text files that contain the string you

typed.

These two fields work together. For example, if you type d in the “Show files that
match name” field and “schedule” in the “Show files containing text” field, you
only see icons for files that contain the word “schedule” and whose names begin
with the letter “d.”

3. Click Show All to display all the icons and ignore the text in the both fields.

Moving and Copying Files and Directories

This section includes:

*  “A Quick Summary of How to Move Files or Directories”
¢ “Detailed Instructions on Moving Files or Directories”

¢ “Copying Files or Directories”

¢ “Copying Files to and From a Tape”

¢ “Copying Files to and From a Floppy Disk”

A Quick Summary of How to Move Files or Directories

You can move files or directories into a different directory. To do so, drag the file or
directory icon from one Icon View window into another Icon View window or onto a
folder (directory) icon. (If you have placed an icon on the desktop and want to move it off
of the desktop, see “Removing Files and Reference Icons” on page 42).
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Detailed Instructions on Moving Files or Directories
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To move files or directories:

1. Place the cursor over the file or directory icon, then press and hold down the left
mouse button. The icon turns yellow.

2. Continue pressing the mouse button, then drag the cursor into a different Icon View
window or on top of a folder icon. The icon travels with the cursor, leaving behind a
gray outline.

3. Release the mouse button.

e If you have an Icon View window open, release the mouse button when the
cursor is inside the window.

e If you are dragging the icon onto a folder icon, release the mouse button when
the folder icon turns blue.

The icon moves. It disappears from the original directory and appears in the new
directory.

Note: You need to have write permission on a directory in order to move a file into or
from that directory. You also need write permission on a file in order to move it. To
change the permissions on file or directory, select the icon in an Icon View window and
choose “Change Permissions” from the Selected menu. Refer to the help for Change
Permissions for details.

When you move an icon from one folder to another, you actually change its location in
the file system. For example, if you move an icon from a directory called reports to a
directory called memos, the file disappears from the reports directory and appears in the
memos directory. If your computer is on a network, you can open a directory on another
computer, and drag icons in and out of that directory. In this case, the files are actually
moved between computers, but only if permissions allow.

When you move an icon onto the desktop or onto a shelf, you do not change its location
in the file system. The file is still stored in its original directory, even if the directory is on
a remote system; the icon appears on the desktop or shelf so it is easier for you to access.
This is called a reference (reference icon are distinguished by italicized labels). The same
is true with the Icon Catalog. Dragging an icon onto a page in the Icon Catalog makes it
easier to access. It does not move the file.
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Copying Files or Directories

You can copy a file or directory in one of two ways:

®  Quick Copy: press the Ct r | key, then select an icon. Continue pressing the Ct r| key
and drag the icon to a new location. Release the mouse button and Ct r| key: a copy
of the file appears. It is labeled copy_of _fi | enare.

e If the file or directory icon is in an Icon View window, select the icon of the file or
directory that you want to copy, then choose “Make Copy” from the right mouse
button menu. If the icon is on the desktop, choose “Make Copy” from the Selected
toolchest. A copy of the selected file or directory appears. It is labeled
copy_of fil enane.

See “Renaming Files and Directories” to learn how to change the name of the file you
copied. For instructions on exchanging copies of files or directories with another system,
see “Accessing Remote Files and Directories With the Access Desktop Tool.”

Note: Youneed to have read permission on a directory or file in order to copy it. You also
need to have write permission on a directory in order to copy files into the directory. To
change the permissions on file or directory, select the icon in an Icon View window and
choose “Change Permissions” from the Selected menu. Refer to the Change Permissions
tool Help for details.

Note: If you copy an icon that is on a page in the Icon Catalog or on the desktop, the
copied icon appears next to the original icon and in the Desktop directory in your home
directory. If you copy an icon on a shelf, the copied icon appears next to the original icon.

Copying Files to and From a Tape
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If you have a tape drive connected to your system, or have a system on your network that
has a shared tape drive, you can use the Back Up Files guide to copy files to and from a
tape.
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1. Double-click the tape drive icon on your desktop.

If the icon is not on your desktop, choose System Manager from the Toolchest. In the
System Manager window, click Hardware and Devices, then Removable Media
Manager. When the window appears, double-click the tape drive icon.

2. Double-click the “Backup Files” task icon in the lower half of the Removable Media
Panel window.

The Back Up Files guide appears.

3. Follow the instructions in the Back Up Files guide to copy files to or from a tape.

Copying Files to and From a Floppy Disk

If you have a floppy disk drive attached to your system, you can copy files to and from
a floppy disk. You can also copy Macintosh and DOS PC files onto your system.

If you do not have a floppy drive attached to your system, you can copy files to and from
a drive on a remote system by placing the remote floppy drive icon onto your desktop.
For information on accessing a remote floppy drive, see “Accessing Another System’s
Media Devices or Printers.”

If you are copying files from a Macintosh or DOS PC disk, make sure the application
software is compatible with application software available on your system. Depending
on the application, some files may need to be run through a translator before you can use
them.

Note: Always use the IRIX Interactive Desktop software when copying Macintosh files,
(not the IRIX cp or r cp utilities). The Desktop software copies all the necessary
components of the file, including the data fork, the resource fork, and the Finder
information.

Copying Files Onto a Floppy Disk

To copy files onto a floppy disk:
1. Insert a floppy disk into the drive.

The floppy icon on your desktop changes to show that a floppy is present in the
drive.
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Open an Icon View window of the directory that contains the files you want to copy.

Double-click the floppy drive icon to open an Icon View of the contents of the
floppy disk; then hold down the Ct r| key and drag the files you want to copy into
this window.

Note: If you do not hold down the Ctrl key, dragging the files will move them from
the system to the floppy disk, if permissions allow.

Close the Icon View of the floppy disk by double-clicking the button in the upper
left corner of the window border.

Eject the floppy disk by selecting the floppy drive icon and choosing Selected > Eject
Media from the Toolchest.

Note: When copying Macintosh files, do not use the command line IRIX cp orr cp
utilities. The procedure described above copies all the necessary components of the file,
such as the data fork, the resource fork, and the Finder information.

Copying Files From a Floppy Disk
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You can copy files from a floppy disk by opening up an Icon View of the files on the
floppy and dragging them into an Icon View on your system.

If you are copying files from a Macintosh or DOS PC, make sure the application software
is compatible with application software available on your system. Depending on the
application, some files may need to be run through a translator before you can use them.

To copy files from a floppy disk onto your system:

1.

Insert the floppy disk into the drive.
A floppy disk icon appears on your screen.
Double-click the icon to open an Icon View of the files on the floppy disk.

Open an Icon View window of a directory on your machine to which you want to
copy the files.

Hold down the Gt r | key and drag the files from the floppy disk Icon View into the
Icon View you opened on your system.
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Close the Icon View of the floppy disk by double-clicking the button in the upper
left corner of the window border.

Eject the floppy disk by selecting the floppy drive icon and choosing “Eject Floppy”
from the Selected toolchest.

Note: When copying Macintosh files, do not the use the command line IRIX cp or r cp
utilities. The procedure described above copies all the necessary components of the file,
such as the data fork, the resource fork, and the Finder information.

Making a Referenced Copy of an Icon
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A reference icon is like a copy of an icon: it lets you access the same file, application, or
directory icon from different places. You can also give it a unique name in each place. You
make a reference to an icon by dragging it onto the desktop background, to a shelf, or to
a page in the Icon Catalog. You can also use the “Make Reference” command. Reference
icons are distinguished by an italicized icon name.

To make a reference icon:

1.
2.

Select the icon that you want to reference. The icon turns yellow when it is selected.

Choose “Make Reference” from the right mouse button menu.

Note: You can also choose “Make Reference” from Selected menus, such as the
Selected menu on the Toolchest.

A reference to the icon appears next to the original. It looks like the original icon,
but the icon name appears in italicized text and begins withref _to_.

Move the reference icon to the desired location, such as another directory.

Rename the icon by clicking on the name and typing. Press the Ent er key to change
the name.

For advice on choosing a name, see “Naming Icons: A Few Guidelines.”

For details on removing a reference icon, see “Removing Files and Reference Icons.”
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To find the original icon that the reference points to, select the reference icon, then choose
“Find Original” from the Selected menu. An Icon View of the directory that contains the
original icon appears.

Note: When you change the original file, all references are changed as well. The same is
true if you change the contents of a reference file or directory: the original and all other
references are changed. If you delete, move, or rename the original file, the referenced
copy no longer has a place to point and the icon changes into a ring to indicate that it is
an empty file.

Removing Files and Reference Icons
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Deleting a file, directory, or reference is a two-step process. You place the icon in the
dumpster, then you empty the dumpster. When you delete a reference icon (indicated by
an italicized label), you do not delete the original file, only the reference icon.

To place an icon in the dumpster, you can drag the icon and drop it onto the dumpster
icon, or you can use the “Remove” command. The dumpster icon is stored in your home
directory and is placed on the desktop so you can easily access it.

To use the “Remove” command:

1. Select the icon that you want to remove. The icon turns yellow when it is selected.

2. Choose “Remove” from the Selected menu on the window that contains the icon. If
the icon is on the desktop background, choose “Remove” from the Selected
toolchest.

The icon disappears from the window and is placed in the dumpster. This behavior
applies to all icons that you have permission to remove, no matter where they are
located— in an Icon View window, on a page in the Icon Catalog, or on the desktop.

3. Choose “Empty Dumpster” from the Desktop toolchest.
This permanently deletes the file from the system’s disk.
You need to have write permission on a directory in order to remove it or to remove files

in that directory. You also need to have write permission on the files in order to remove
them.
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To change the permissions on file or directory, select the icon in an Icon View window
and choose “Change Permissions” from the Selected menu. Refer to the Change
Permissions tool Help for details. Remember that to remove a file, you must have write
permissions on the directory that contains the file.

The / usr/tnp and/ t nmp directories are unique. Anyone can view, copy from, or move
files into these directories, but you must be the owner of a file in order to remove it. If you
want to remove a file or directory from your / usr/tnmp or /t np, and do not have
permission to, you can change the permissions and ownership of the file with the Change
Permissions tool, as mentioned above.

Note: You can change the behavior of the “Remove” command so that it automatically
deletes files from the system’s disk. For information, see “Making “Remove” Delete
Instantly.”

Shortcut: Select the icon you want to remove hold down the right mouse button. A menu
appears. Choose Remove.

Creating and Opening Directories

This section includes:

¢ “Basic Instructions for Opening a Directory”

* “Summary of Different Methods for Opening Directories”
* “Opening a Directory Using the Path Finder”

* “Creating a Directory”

Basic Instructions for Opening a Directory
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You can open a directory in several ways:

e If the folder icon is visible, place the cursor over the folder icon, then double-click
the left mouse button. A new Icon View window appears.
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If an arrow appears next to the folder icon, place the cursor over the arrow then
click the left mouse button. The contents of that directory are listed underneath the
folder icon. This arrow appears only when you are viewing icons in an Icon View window
as a list. See “Viewing File Information (Viewing “as List”).”

If you have an Icon View open, but the directory you want to see is not there, enter a
new directory pathname into the path finder at the top of the window. Figure 4-6
shows the path finder.

The path finder displays the pathname of the current directory. You can type in a
new directory name, or you can use the bar above the field to select a new directory.
See “Opening a Directory Using the Path Finder” for details.

Figure 4-6 The Path Finder

For information on alternate methods, see “Summary of Different Methods for Opening
Directories.”

Summary of Different Methods for Opening Directories
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A quick summary of the possible methods for opening a directory:

Place the cursor over a folder icon, then double-click the left mouse button.

Select a folder icon, then choose “Open” from the Selected menu on the window
that contains the icon. If the icon is on the desktop, choose “Open” from the Selected
toolchest or the right mouse button menu.

Place the cursor over the arrow that appears next to the folder icon, then click the
left mouse button. The contents of that directory are listed underneath the folder
icon. This arrow appears only when you are viewing icons in an Icon View window
as a list. See “Viewing File Information (Viewing “as List”).”

Drag and drop a folder icon into the drop pocket on an Icon View window. The
window changes to display the contents of the directory whose folder icon you
dropped. See “Opening a Directory Using the Path Finder” for details.

Type a new pathname into the path finder at the top of the Icon View window. See
“Opening a Directory Using the Path Finder” for details.
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* Move the mouse cursor to the background of the Icon View window that contains
the directory you want to open. Begin typing the name of the directory. When the
name is recognized, the directory icon is selected. After it is selected, press the
Ent er key to open the directory.

¢ From the Toolchest, choose Desktop > Access Files > In my Home Directory. This
opens an Icon View window that displays the contents of your home directory.

e Choose “File QuickFind” from a Selected menu or “File QuickFind” from the Find
toolchest. This opens a dialog into which you can type the name of the directory
you want to open. After you type the name, press Ent er to open the directory.

Opening a Directory Using the Path Finder

The path finder appears at the top of each Icon View window. You can open a new
directory in one of three ways: type a directory name in the type in-field, drop a folder
icon into the drop pocket, or use the pathbar above the type-in field to select a directory
name.

Typing a New Name Into the Path Finder
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The path finder shows the pathname of the directory that is displayed. See Figure 4-7.

)

Figure 4-7 The Path Finder

You can edit the name, as follows:

* To replace the existing directory name, place the cursor in the type-in field, then
double-click to select the existing text. Begin typing. The existing name disappears,
and the new name appears as you type.

e To edit a portion of the directory name, place the cursor within the name. Press the
left mouse button and drag the cursor to highlight the section you want to change,
or press the Backspace key to delete characters to the left of the cursor.

Note: If your system is on a network, you can open directories on other systems. See
“The Path Finder Field” for more information.
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Placing an Icon Into the Drop Pocket

The drop pocket is the small square to the left of the type-in field. See Figure 4-8.

7

Figure 4-8 A Drop Pocket

When you place an icon in the drop pocket, the Icon View window changes.

* Drag a folder icon and place it in the drop pocket. The window displays the
contents of that folder.

* Drag a file or application icon and place it in the drop pocket. The window displays
the contents of the directory in which that icon is stored. For example, suppose you
drag the IRIS Showcase icon into the drop pocket. The window displays the
contents of the / usr/ sbi n directory.

Using the Path Bar in the Path Finder

The path bar is the gray bar above the type-in field. It lets you move from one directory
to another, without typing. It contains a small button representing each directory in the
pathname. Click a button to display the contents of that directory. See Figure 4-9.

Click here to display the / directory.
— Click here to display the A directory.

Figure 4-9 Using the Path Bar

Using the Recycle Button

The recycle button appears to the right of the path finder. Press this button to display a
listing of directories whose contents you have previously displayed in the window since
the window has been opened. Choose an item from the list to display that directory
again.
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Creating a Directory

To create a new directory, choose “Add New Directory” from an Icon View Actions menu.
The new directory appears as a folder icon in the window.
Detailed instructions:

1. Place the cursor over the Icon View window or desktop area in which you want the
new directory to appear.

2. Choose “Add New Directory” from the Actions menu. A folder icon appears in the
window. It is labeled enpty. di r.If you create another new directory, it is named
enptyl.dir.

See “Renaming Files and Directories” for instructions on renaming a directory.

Shortcut: Use the right mouse button menu: position the cursor over the Icon View
window (make sure no icons are currently selected), then hold down the right mouse
button and choose “Add New Directory.”

Note: If you want the folder icon to automatically appear on the desktop, choose “New
Directory” from the Selected toolchest. The folder icon appears on the desktop; the
directory is stored in the Desktop directory in your home directory. For example, suppose
your user name is dor ot hy and you create a directory named 0z on the desktop. The
pathname for the directory is / usr/ peopl e/ dor ot hy/ Deskt op/ oz.

Renaming Files and Directories
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To rename a file or directory, click on the filename, edit the name, and then press the
Ent er key or click the left mouse button in the window. Detailed instructions follow.

1. Locate and select the icon of the file or directory you want to rename.
2. Select the icon’s name. It highlights when selected.
3. Edit the name.

* To replace the existing name, begin typing. The existing name disappears, and
the new name appears as you type.
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* To edit a portion of the name, place the cursor within the name, then click the
left mouse button to place a marker. Begin typing to add characters after the
marker; press the Backspace key to delete characters preceding the marker.

* Toreplace or delete several characters, press the left mouse button and drag the
cursor over the characters. Release the mouse button when the characters you
want to delete or replace are selected. The characters are selected.To delete the
characters, press the Backspace key; to replace the characters, begin typing.

* To cancel renaming and leave the name unchanged, press Esc.

Note: For advice on choosing a name, see also “Naming Icons: A Few Guidelines.”

4. To apply the name, press Ent er or click the left mouse button in the window.

Note: If you do not press Enter or click the mouse button, the original name returns.

Opening and Saving Files
This section includes “Opening Files by Double-Clicking Icons,” “Opening Files Using
the “Open” Command,” “Opening Files by Dragging and Dropping,” “Opening Files by
Typing in the Background,” and “Saving Files.”

Opening Files by Double-Clicking Icons
The easiest way to open a file is to place the cursor over the file icon, then double-click
with the left mouse button. If you use a file frequently, place the icon on a shelf, or drag

the icon onto the desktop so it is easily accessible. See also “Giving Yourself Easy Access
to Icons.”

Opening Files Using the “Open” Command

You can open a file by using the “Open” command on the Selected menu.
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1. Place the cursor over the icon, then click the left mouse button to select the icon. The
icon turns yellow when it is selected.

2. Choose “Open” from the Selected menu on the window that contains the icon. If the
icon is on the desktop, choose “Open” from the Selected toolchest.

Opening Files by Dragging and Dropping

You can open a file by dragging its icon onto an application icon and then dropping it.
For detailed instructions, see “Starting Applications by Dragging and Dropping Icons.”

Opening Files by Typing in the Background

If you have a large list of files and do nt want to scroll through them to find the one you
want, you can move the mouse cursor to the background of an Icon View window and

begin typing the name of the file. As soon as the file is recognized, it is selected. Once the
file is selected, press the Ent er key to open the file.

Saving Files

Most applications display a File Browser when you choose the “Save” or “Save As...”
command. The File Browser makes it easy for you to save a file in a particular directory.
If you do not specify a directory, the system places files in a default location, depending
on the place from which you run the application.

¢ If you launch an application from the desktop, the file is saved in your home
directory.

¢ If you launch an application from an Icon View window, the file is saved in that Icon
View window.

¢ If you launch an application from a page in the Icon Catalog or Search tool, the file
is saved in your home directory.

007-1342-170 49



4: Managing Your Work: Working with Files and Directories

Creating Files Using Select and Paste

You can create a text file by selecting text in a window, then moving the mouse cursor
onto the desktop background or onto the background of an Icon View window, and
clicking the middle mouse button. A file named Past edText is created. It contains the
text that you selected.

To rename the file, click on the filename and begin typing. Press the Ent er key to change
the name.

You can also create a WebJumper icon by selecting a URL address with the mouse,
moving the mouse cursor to the desktop background or to the background of an Icon
View window, and clicking the middle mouse button. A WebJumper icon is created for
the Web site.

Naming Ilcons: A Few Guidelines

When naming icons, follow these guidelines:
* You can use letters, characters, and blank spaces in your file or directory name.
e Take note of capitalization. f i | e and Fi | e are two different names.

e If you need to access a file using an IRIX command, and the filename has blank
spaces in it, put quotes around the filename when you type it. This preserves the
space.

e Each file, directory, and application in a directory must have a unique name. If you
try to name a file Test and a file named Test already exists in that directory, one of
two things happens: you get a notifier warning you that you are about to overwrite
an existing file, or the existing file is replaced with another of the same name. You
can specify which behavior you want. See “Turning File Overwrite Messages On
and Off.”
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Chapter 5

Printing

Once the Administrator or a Privileged User has used the Printer Manager to set up a
printer for your system (choose System > Printer Manager from the Toolchest, use the
Printer Manager Help menu for instructions), you can print files from your desktop.
These are the methods you can use:

¢ Dragging them onto a printer icon,

* Dragging them onto the Print Panel icon to customize the job

* Selecting the file or directory, then choosing “Print” from the Selected toolchest or
Icon View menu

This chapter contains these sections:

* “Summary of the Printing Environment and Tools”

¢ “Placing Available Printers on Your Desktop”

¢ “Printing Files”

*  “Customizing Print Jobs With Print Panel”

* “Using Print Status to Monitor Print Jobs and Printers”

¢ “Designating a Default Printer”

¢ “Troubleshooting Printing”

Summary of the Printing Environment and Tools
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The graphical printing environment provides all the tools you need to set up printing
software, and to print files and monitor print jobs. Click a topic for summary
information.

e “About the Printer Manager”
e “About Desktop Printer Icons”
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e “About Print Status”
e “About Print Panel”
e “About File Format Filters”

e “About Impressario”

About the Printer Manager

The Printer Manager lets a Privileged User access printers that are connected to either the
user’s own system or another system on the network. Once a printer is set up, you can
drag its icon from the Printer Manager onto your desktop for use (see “Placing Available
Printers on Your Desktop” and “About Desktop Printer Icons”).

You can start the Printer Manager in two ways:

e Choose “Printer Manager” from the System toolchest.

e Choose “Printer Manager” from the Other Tools menu in Print Status (see “About

Print Status”).

For detailed information on using the Printer Manager, use the Printer Manager Help
menu.

About Desktop Printer Icons
Once you place a printer icon on your desktop (see “Placing Available Printers on Your
Desktop”), you can:

¢ Drag a file onto the printer to print a document (see also “About File Format
Filters”)

e Double-click the printer to start Print Status, a tool that shows detailed status of the
printer and its queue and lets you manage the queue (see “About Print Status”)
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If the printer is an Impressario printer (see “About Impressario”), you can also visually
monitor the icon; it changes when the printer has jobs in its queue or when it is
experiencing any problems.

Idle printer The printer icon has no paper emerging from it. The printer may be
printing jobs that belong to other users, but it is not printing any jobs for
you.

Busy printer The printer icon has paper emerging from it. It is printing one or more
jobs for you.

Broken printer The printer icon has smoke emerging from it, and appears to be
squashed. The printer cannot print for some reason (for example, it is
jammed or out of paper). For more information on the problem,
double-click this printer to see the Print Status window.

About Print Status

Print Status lets any User view a printer’s queue, and cancel jobs submitted by that
person. A Privileged User can cancel jobs submitted by any user, and can also enable or
disable the printer’s queue. The Administrator (root) can also forward print jobs from
one printer to another.

You can start Print Status in several ways:

¢ Double-click a printer icon on the desktop (see “About Desktop Printer Icons”).

¢ In Printer Manager, select a printer and choose “Show Queue” from the Printer
menu (see “About the Printer Manager”).

e Choose a printer in the “Print Status for” rollover menu in the Other Tools menu in
Print Status (this works only if you have more than one printer available).

For more details on Print Status, see “Using Print Status to Monitor Print Jobs and
Printers.”
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About Print Panel

Print Panel lets you customize print jobs. For example, you can specify the number of
copies you want to print, or customize the banner page of a particular print job. If the
system to which a printer is physically connected has the Impressario software installed,
you can set many more advanced, printer-specific printing options. (For more
information, see “About Impressario” and “Setting Printer-Specific Options.”)
For convenience, place the Print Panel icon on your desktop by following these steps:
1. Choose “File QuickFind” from the Find toolchest.
2. In the File QuickFind text field, type:
/'usr/ sbi n/ Pri nt Panel
3. When the Print Panel icon appears in the drop pocket, drag the icon onto the
desktop.
You can start Print Panel in several ways:
¢ Double-click the Print Panel icon on the desktop.
® Drag a file onto the Print Panel icon on the desktop.
e Choose “Printer Panel” from the Other Tools menu in Print Status.

For detailed information on using Print Panel, see “Customizing Print Jobs With Print
Panel.”

About File Format Filters
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The system does not supply any standard file format filters. This means that when you
send a file to a printer by dragging it onto either a printer icon or the Print Panel icon, or
by selecting the file and choosing “Print” from the Selected menu, the system sends the
file directly to the printer without changing its format. Depending on the file type and
printer type, the printer may not be able to print the file.

In general, you can print by dragging files in these cases:

* Drag a PostScript or ASCII file on a PostScript printer

¢ Drag an ASCII file on an ASCII or dumb printer

® Drag an SGI Image file on a dumb raster or dumb color printer
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About Impressario
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Many applications include file format filters. When you give a print command within an
application, it often converts the file to a standard format (such as PostScript) before
sending it to a printer. Or, it may give you the option of saving a file as PostScript or as
text. Once you have done this, you may be able to drag the resulting file onto a printer
icon (if the printer supports that format).

If the system to which a printer is physically connected has the optional Impressario
software, you can print many additional file types. For more information, see “About
Impressario.”

Because the additional Impressario filters are available only on the system to which the
printer is physically connected, you cannot drag files of these types onto a printer or Print
Panel icon on your own desktop to print them. Instead, you must follow these steps:

1. On your own system, choose “Open Unix Shell” from the Desktop toolchest.
2. In the window that appears, type:
| p filename - dprintername
Where filename is the name of your file, and printername is the name of the printer.

3. To close the window, type:

| ogout

Impressario provides a full range of tools and drivers for printing, viewing, and scanning
a variety of image types. The product includes:

* Sophisticated printer drivers that let you control the printers” advanced capabilities
through a software options panel, and report up-to-the-minute status on the
printers and print jobs

® scanners, a tool that lets you configure new scanners, gscan, a tool that lets you
scan images from an IRIS screen, an image file, or a scanner bed, and several
scanner drivers

e vstiff,aStream TIFF viewer that lets you view any file type that your system can
print

* Behind-the-scenes filters that can convert most file types to a format that you can
view or print (see also “About File Format Filters”)
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To check whether a printer is connected to a system that has Impressario software,
double-click the printer icon to start Print Status, and check the message in the Current
Printer Status area. If it is an Impressario printer, you see a message similar to this:

Impressario 2.0 LaserWriter driver, version 1.10

Also, when you use Print Panel to customize a job for the printer, the More Options
button will be available so you can set advanced, printer-specific Impressario printing
options. (For more information, see “Setting Printer-Specific Options.”)

If you have Impressario installed, you can find detailed information about it in the online
Impressario User’s Guide. To access this book, choose “On-line Books” from the Help
toolchest, then double-click the Impressario User’s Guide icon in the SGI_EndUser
bookshelf.

Placing Available Printers on Your Desktop
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When a Privileged User sets up the system to access a printer that is connected to either
your own system or another system on the network, an icon for that printer appears in
the Printer Manager. Users can then place the icon onto their desktop for easy access to
the printer’s queue and for drag and drop printing. (See also “About Desktop Printer
Icons.”)

To place a printer on your desktop, follow these steps:

1. Start the Printer Manager by clicking the words Printer Manager, or by choosing
“Printer Manager” from the System toolchest

2. Drag the icon onto the desktop.

3. Close the Printer Manager by choosing “Exit” from the Printer menu.

A Privileged User can also use the Find Remote Resources form to locate printers that are
connected to other systems on the network, and to drag those icons onto the desktop for
use. This has the same effect as using the Printer Manager to install a network printer;

that is, once the printer is dragged onto the desktop, it also appears in the Printer
Manager window.
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Printing Files
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To use the Find Remote Resources form to locate a printer:

1.

2.

3.

4.

Choose Desktop > Shared Resources > On a Remote Workstation.
The Find Remote Resources form appears.
Type the name of the remote system into the field at the top of the form.

A list of all the system’s shared directories, media devices, and printers appears in
the display.

Note: If the remote systems’s resources do not include a printer, but you know that
the remote system is connected to a printer, then the remote system probably does
not have the printer marked as shared. To remedy this, someone needs to choose
Desktop > Shared Resources > On This Workstation from the remote system’s
Toolchest, then use the window that appears to make the printer(s) shared.

Drag the printer icon you want onto your desktop for easy access. Dragging it onto
your desktop lets you use the device as if it existed on your own system.

Click the Close button to close the form.

To remove a printer icon from your desktop but keep it available in the Printer Manager,
any user can select the icon and choose “Remove” from the Selected toolchest.

A Privileged User can remove a printer from all desktops and from the Printer Manager
by following these steps:

1.
2.

Choose “Printer Manager” from the System toolchest.

Select the printer and choose “Delete” from the Printer menu. Users on your system
can no longer access the printer.

You can print files from the desktop or from within an application. Click a topic for more
information.

“Printing by Dragging Icons Onto Printers or Print Panel”
“Printing From Icon Views or the Desktop”

“Printing From an Application”
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Printing by Dragging Icons Onto Printers or Print Panel

If no printer icons appear on your desktop, see “Placing Available Printers on Your
Desktop.” You can then print many types of files (see “About File Format Filters”) by
following these steps:

1.

Drag the file icon onto the printer icon.

If you drag a folder icon onto the printer icon, you print a list of all the files and
directories within the directory.

To check on the progress of your print job, double-click the printer icon. It shows a
queue of jobs waiting to be printed.

You can customize a print job. For example, to specify how many copies to print or to
customize the banner page, you can drag a file onto the Print Panel icon. (For details on
placing the Print Panel icon on the desktop and using Print Panel, see “Customizing Print
Jobs With Print Panel.”)

Printing From Icon Views or the Desktop

The “Print” command is available in the Selected menu of each Icon View, from the
Selected menu on the Toolchest. You can print many types of files using this command.
(See “About File Format Filters.”) Follow these steps to use the “Print” command:

1.

2.
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Select the icon that you want to print.

Select a folder icon if you want to print a list of all the files and directories within
that directory.

Choose “Print” from the Selected menu on the window that contains the icon. If the
icon is on the desktop, choose “Print” from the Selected toolchest.

The file is sent to your default printer. To specify a default printer, see “Designating a
Default Printer.”

To monitor the progress of the job, you may want to drag the printer icon onto your
desktop; see “Placing Available Printers on Your Desktop.”
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Printing From an Application

Many applications include print commands. Typically, when you give the print
command, the application looks for a specific printer. Consult the documentation that
came with the application to learn how to specify which printer the application should
use.

Customizing Print Jobs With Print Panel

Use Print Panel to customize your printing jobs. If the Print Panel icon is not on your
desktop, you can place it there by following these steps:

1. Choose “File QuickFind” from the Find toolchest.
2. In the File QuickFind text field, type:
Pri nt Panel

3. When the Print Panel icon appears in the drop pocket, drag the icon onto the
desktop.

Overview of Print Panel
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Print Panel lets you customize print jobs. For example, you can specify the number of
copies you want to print, or customize the banner page of a particular print job.

To use Print Panel, follow these general steps:

1. Specity the file in the Files to print field.

2. Click a printer in the Available printers list to select one.

3. Set printing options in the Options area.

If the More Options button is not greyed out, the selected printer is an Impressario
printer. (See “About Impressario.”) You can click this button to further customize
the job.

4. If you want these options to apply to future print jobs, click the Save Options button.
5. Send the file to the printer by clicking the Print button.
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About the Print Panel Menus

The File menu contains these choices:

“Print” sends the selected file to the highlighted printer. (The filename appears in
the Files to print field; the printer name is highlighted in the Available printers list
specified in the Options area.) Choosing “Print” is the same as clicking the Print
button.

“Open...” brings up the File Open window, which lets you browse through the
filesystem for a file.

“More Options...” is available only if the Impressario software is installed on the
system to which the printer is connected. (See “About Impressario.”) This option
brings up an advanced, printer-specific options window. It is identical to clicking
the More Options button.

“Save Options...” saves all the options that you set in both the Options area and in
the window that appears when you choose “More Options.” It is identical to
clicking the Save Options button.

“Exit” stops Print Panel, and closes the window.

The Other Tools menu contains one choice, “Print Status for.” Choose a printer in the
Available printers list, then choose “Print Status” to see the printer’s queue and status
information. You can also double-click a printer name in the list to see its Print Status
window.

The Help menu contains a list of help topics. Choose a topic to see online help.

Selecting Files to Print From the Print Panel
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You can select a file to print in three ways:

Drag the file onto the Print Panel icon.
Type the full pathname of the file in the Files to print field.

You can print several files at once by typing in more than one pathname. Be sure to
separate each pathname with a space.

Choose “Open...” from the File menu to see the File Open window. It lets you
browse through the filesystem and select a file.
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In this window, you can double-click a directory to open it, and its name will appear
in the Selection field. You can also type a pathname directly into the field. When the
file you want to open appears in the field, click the OK button.

Click the Filter button to search for a specific set of files. By default, the system looks
for all directories and files, noted with a filter of * (the wildcard character). To search
instead for all files that end in .doc, enter *. doc in the Filter window.

Selecting a Printer in Print Panel

The Available printers list shows all printers that a Privileged User has installed using the
Printer Manager.

Click a printer to select it. If you want more information about a printer, double-click it
to see its Print Status window.

When you choose “Print” from the File menu or click the Print button, the job goes to the
printer that you selected.

Using Print Panel to Specify the Number of Copies to Print

Specify the number of copies you want to print by highlighting the number in the
Number of copies field, and typing a new number. You can also click the up or down
arrows next to this field to increase or decrease the number.

Using Print Panel to Set the Banner Page Title Options
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By default, the printer prints a banner page before printing your job. The banner page
includes your login name and system name. To change the title that appears at the top of
the page, click the box next to Custom under Banner page title, then type a new title in the
field.

If the More Options button is available, you can eliminate the banner page. See “Setting
Printer-Specific Options.”
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Using Print Panel to Set Job Completion Options

Print Panel reports when the job is finished by either sending a message to your console
window or sending you electronic mail. Click the box next to Send mail or Send message to
console to specify how you would like to be notified. If you do not want to be notified,
leave both check boxes empty.

Setting Job Handling Options

To keep Print Panel from creating a temporary copy of the job (and from using up disk

space), under Print file handling choose Link in spool directory. To have Print Panel create

the copy so you can safely edit or delete the original file while it is being printed, choose
Copy to spool directory.

Setting Printer-Specific Options

The Printer-specific options field is filled in automatically when you set advanced printing
options using the More Options button or menu choice. If you are familiar with the IRIX
| p command, you may enter | p command line options in this field.

To change advanced, printer-specific settings and print a file with the new settings,
follow these steps:

1. Drag the file onto the Print Panel icon; or start Print Panel by clicking the words
Print Panel now, then typing a file name in the Files to print field.

2. Select a printer by clicking it in the Available printers list, then click the More Options
button.

You see an Options window. There is a scroll bar on the right side of the display area
that you must slide down to reveal all options.

3. Change the settings.

See “Changing Printer Settings for All File Types,” “Changing Printer Settings for
PostScript Files,” “Changing Printer Settings for Image Files,” and “Changing
Printer Settings for ASCII Text Files.”

4. Contfirm or cancel the new settings.

* To confirm that the settings are correct and to make the Options window
disappear, click OK.
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* To confirm that the settings are correct and to keep the Options window
displayed, click Apply.

* To cancel the new settings and to make the Options window disappear, click
Cancel.

5. To save these settings so they become your default settings for the printer that is
selected, and to save the settings on the Print Panel so they are the default settings
for all printers, click Save in the main Print Panel. See also “Saving Printing
Options.”

Note the Printer-specific options field on the main Print Panel; it contains command
line arguments that represent the settings that you changed in the Options window.

Note: The Administrator can specify default printer settings for all users, but
individual users can override them for their own print jobs; see chapter 6 of the
online Impressario User’s Guide for details.

6. To print the file using the new settings, click Print on the main Print Panel. Print
Panel sends the job to the printer and the Print Panel window disappears.

Changing Printer Settings for All File Types

General printing settings apply to all three file formats that Impressario supports. They
often include:

Paper Size Specify the size of paper in the printer’s paper tray by clicking the box
next to A ( 8.5x11-inch), A4 (European A-size) or Legal (8.5x14-inch).

Printer Resolution
Some printers can print at a range of resolutions. The lower the
resolution, the poorer the quality of the printed image.

Print Banner Page
Specify whether to print a banner page as page one of the job. Click in
the Yes box if you want a banner page; click in the No box if you do not.

Verbose Logging
Specify whether to report the details of all printing activity in the
[ var/spool /| p/| og file. Click in the On box to activate verbose
logging; click in the Off box to eliminate it.
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Depending on the printer’s type and model, more general options may be available; for
example, you may be able to specify whether to print in color or in black and white.

Changing Printer Settings for PostScript Files

PostScript printing options apply only to PostScript files that conform to the Adobe
structuring conventions; they do not apply to Image files or to ASCII text files. (See
“Changing Printer Settings for ASCII Text Files” for information on processing ASCII
text files as if they were PostScript.)

PostScript printing options include:

Page Ordering ~ Normal prints so that page one is the first page of the job; Reversed makes
page one the last page. Click the box next to the option that you prefer.

Page Range Lets you print all pages or a subset of pages and, within the range you
select, lets you print only even or only odd pages.

To print all pages, click the box next to All.

To print all odd pages in the file, click the boxes next to All and Odd Pages
Only; to print all even pages, click the boxes next to All and Even Pages
Only.

To print a subset of pages, click the box next to From, then type the
starting page and ending page in the fields.

To print all odd pages within this subset of pages, click the box next to

Odd Pages Only; to print all even pages within the subset, click the box
next to Even Pages Only.
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Changing Printer Settings for Image Files
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The options for printing Image files let you control the orientation, lightness, and size of
the printed image. These options apply only to files in the Image format; they do not
apply to PostScript or ASCII text files.

To change the orientation of the image on the page, change one or more of these settings:

Mirror Image

Rotate

Click Yes to flip the image horizontally.

Click the box next to Best Fit to automatically rotate and scale the image
so that it is printed as large as possible on the page.

Click the box next to Angle and type in the number of degrees you would
like to rotate the image. The image rotates in a counter-clockwise
direction, so typing 90 in this field rotates the image 90 degrees to the
left.

To change the size of the image, change one or more of these Scaling settings:

None

Resolution

Click this box to make the image on the page contain the same number
of dots as the image on the screen. This makes the image on the page
appear smaller than the image on the screen, since most printers print
smaller dots (that is, print with higher resolution) than the screen can
display. If the image is larger than the page, only the portion of the
image that fits on the page will be printed.

The resolution of an image is the number of dots per inch (dpi) that are
in the image. The larger this number is, the smaller the dots are in the
image. By default, the resolution of your printer appears in this field.
To make the printed image the same size as the image on your screen,
enter the resolution of your screen in this field. To find the resolution of
your screen, type the following command in a shell window:
/usr/bin/ X11/ xdpyinfo | grep resol ution

If your screen’s resolution is 72 dpi, you see this message:

72x72 dots per inch
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If your screen’s resolution is 96 dpi, you see this message:
96x96 dots per inch

When printing an image that you originally scanned in, you can match
the size of the image to the original by entering the resolution at which
you scanned in the original.

Page Fill Specify what percentage of the printed page your image should occupy.
Impressario scales and centers the image to fit.

Changing Printer Settings for ASCII Text Files
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The Options window lets you change a plain ASCII text file into a formatted PostScript
file. Click the Yes box next to Format Text and several options become available.

Note: Only the settings that you change under Text File Options in the Options window
affect ASCII text files. The PostScript File Options that appear earlier in the window (Page
Ordering and Page Range) affect only those files whose native format is PostScript.

To change the layout of the text on the page, change these settings:

Orientation Click Portrait to orient your text vertically (the way the text of this
document is oriented); click Landscape to orient it horizontally.

Columns Per Page
Click the box next to the number of columns you would like; all columns
are the same width, with approximately a 1/8" margin between them.
Your text will flow from one column to the next.

Margins Type a number in the Top, Bottom, Left, and Right fields to change the
page margins.
To change the font style and size, change these settings:

Font Click any font that appears in the scrolling list (the fonts listed are those
installed on the printer host).

Size Click any font size.
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Saving Printing Options
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To include page numbers or change the order in which the pages are printed, change
these settings:

Page Ordering  Normal prints so that page one is the first page of the job; Reversed makes

page one the last page. Click the box next to the option that you prefer.

Page Numbering

Lets you include a page number on each printed page. Choose where
you want the page number to appear by selecting an item from the Page
Numbering menu button. Enter the number you want to begin with in
the field labeled “Start numbers at.”

The Save Options button in the Print Panel window saves two groups of settings:

The settings in the main Print Panel window, which apply to all printers shown in
the list of available printers; this information is saved in the . gl pr c file in your
home directory.

The settings that you change in the Options window for the selected printer (the
printer whose name is highlighted in the Available printers list); these settings are
saved in a file named

/var/ spool /| p/ settings/ <printernane>/ <user name>.

Note: This second group of settings is available only for Impressario printers; see
“About Impressario.”

When you save these settings, they apply only to jobs that you submit to the printer; they
do not apply to jobs that other users submit. The Administrator can change system default
settings for a printer, but any user can override these settings for their own jobs.

To save printer-specific settings (available only for Impressario printers), follow these
steps:

1.
2.

When the settings in the Options window are correct, click the OK or Apply button.
In the Print Panel window, click the Save button.

You see the Save Settings window, which shows a list of all printers whose settings
you have changed during this session with Print Panel.
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In the Save Settings window, select the printer(s) whose settings you want to save,
then click the Save button.

Note: If you are a Privileged User, you see two buttons for saving: Save-Personal
saves the settings only for you; Save-All Users saves the settings for all users.

The settings that apply to all printers and the printer-specific options are now
saved. These settings will be in effect the next time you print a job from the desktop
or from an application program.

Now you can either print the file that is specified in the Files to print field by clicking the
Print button, or you can dismiss the Print Panel window by choosing “Exit” from the File
menu.

Using Print Status to Monitor Print Jobs and Printers

Overview of Print Status
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Print Status allows you to monitor print jobs and printers. You can start Print Status in
several ways:

Double-click a printer icon on the desktop (see “About Desktop Printer Icons”).

Select a printer and choose “Print Status for” from the Other Tools menu in Print
Panel (see “About Print Panel”).

Select a printer and choose “Show Queue” from the Printer menu in the Printer
Manager (see “About the Printer Manager”).

Choose a printer in the “Print Status for” rollover menu in the Other Tools menu in
Print Status. (This works only if you have more than one printer available.)

Print Status lets any User view a printer’s queue, and cancel jobs that the user has
submitted. A Privileged User can cancel jobs submitted by any user and can also enable
or disable the printer’s queue. The Administrator can forward a selected job to another
printer.

The top portion of the Print Status window shows the printer’s model, location code and
location description, and the system to which it is physically connected.
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The Current Printer Status is active only for Impressario printers (see “About
Impressario”). It displays messages about the physical printer itself. It shows what the
printer is currently doing, gives detailed information about any printer problems, and
reports the version of the printer driver.

The Printer Request Queue area shows the list of all jobs that are waiting to be printed. It
lists the job’s title, its owner (the person who sent the job), its size (in kilobytes), and its
ID number. When the top job in the queue disappears, that job has been printed.

About the Menus

The Printer menu offers these choices:
e “Send Test Page” sends a one-page test file to the printer.

e “Update Printer Status” checks the printer and displays its current status in the
Current Printer Status area (only for Impressario printers; see “About Impressario”).

e “Exit” dismisses the Print Status window.

The Queue menu offers these choices:
e “Cancel Selected Job” removes the job that you have selected from the queue.

e “Move Print Job to Another Printer” is a rollover menu. The Administrator can
forward the selected job to one of the printers on the rollover menu.

e “Printer Accepting Your Jobs” and “Printing Your Queued Jobs” shows whether the
printer is able to accept jobs into its queue and/or print them. Only the
Administrator can disable the printer through this menu.

Note: If you check the queue of a remote printer and see that jobs are not
disappearing from the queue, the Administrator of the system to which the printer
is connected may have disabled the printer using this menu choice.

The Other Tools menu offers these choices:

e “Printer Panel” starts Print Panel with no file specified for printing. Print Panel has
help available through its Help menu.

e “Printer Manager” starts the Printer Manager that you usually start from the
System toolchest. The Printer Manager has help available through its Help menu.
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“Print Status for” starts Print Status for another printer. A menu of printers appears
to the right of the arrow; choose a printer to see its Print Status window.

Viewing the Queue of Print Jobs

You can start Print Status to check a printer’s queue in several ways:

Double-click a printer icon on the desktop (see “About Desktop Printer Icons”).

Select a printer and choose “Print Status” from the Other Tools menu in Print Panel
(see “About Print Panel”).

Select a printer and choose “Show Queue” from the Printer menu in the Printer
Manager (see “About the Printer Manager”).

Choose a printer in the “Print Status for” rollover menu in the Other Tools menu in
Print Status. (This works only if you have more than one printer available.)

The Printer Request Queue area shows the list of all jobs that are waiting to be printed. It
lists the job ID number, the owner (the person who sent the job), and the size (in
kilobytes). When the top job in the queue disappears, that job has been printed.

Cancelling a Print Job
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Any User can cancel his own print job using Print Status. Follow these steps:

1.

Double-click the printer icon to open its Print Status window (or use one of the
other methods for starting Print Status described in “Viewing the Queue of Print
Jobs.”)

Click on a job in the Printer Request Queue to select it.

Choose “Cancel Selected Job” from the Queue menu.

A Privileged User can cancel any job in the same way.
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Forwarding a Print Job

The Adminstrator can forward a job to a different printer.

1.

Double-click the printer icon to open its Print Status window. (You can also use one
of the other methods for starting Print Status described in “Viewing the Queue of
Print Jobs.”)

Click on a job in the Printer Request Queue to select it.

Open the Queue menu, then choose a printer from the Move Print Job to Another
Printer rollover menu.

Disabling or Enabling a Printer’'s Queue

A Privileged User can stop a printer from accepting new print jobs into its queue, and can
stop the printer from printing jobs that are already in the queue.

1.

Double-click the printer icon to open its Print Status window. (You can also use one
of the other methods for starting Print Status described in “Viewing the Queue of
Print Jobs.”)

To keep new jobs from entering the queue, choose “Printer Accepting Your Jobs”
from the Queue menu to make the check mark in the box next to this choice
disappear. To accept jobs, choose “Printer Accepting Your Jobs” again to make the
check box appear.

To keep jobs that are already in the queue from being printed, choose “Printer
Printing Your Queued Jobs” from the Queue menu to make the check mark in the
box next to this choice disappear. To allow jobs to be printed, choose “Printer
Printing Your Queued Jobs” again to make the check box appear.

Note: If you are checking the queue of a remote printer and jobs are not disappearing
from the queue, the Administrator of the system to which the printer is connected may
have disabled the printer using either of these menu choices.
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Checking the Status of a Printer

Testing a Printer
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Only Impressario printers can report printer status (see “About Impressario”). With
these printers, you can check a printer’s status in two ways:

Double-click the printer icon to open its Print Status window. (You can also use one
of the other methods for starting Print Status described in “Viewing the Queue of
Print Jobs.”)

If the window has been open for a while, you can update the status information by
choosing “Update Printer Status” from the Printer menu.

For printers that do not use Impressario, the Current Printer Status area is empty.

Monitor the printer’s desktop icon; it changes to show when a printer is idle, busy,
or broken (see “About Desktop Printer Icons” ).

Icons representing printers that do not use Impressario do not change.

To send a test page to a printer, follow these steps:

1.

2.

Double-click the printer icon to open its Print Status window. (You can also use one
of the other methods for starting Print Status described in “Viewing the Queue of
Print Jobs.”)

Choose “Send Test Page” from the Printer menu.

If the jobs that are ahead of the test page in the queue do not exit from the queue in a
reasonable period of time, there may be a problem with the printer. Cancel the jobs in the
queue, and resend the test page. If you still have problems, see “Troubleshooting
Printing”.
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Designating a Default Printer

From the desktop, users can send files to a particular printer in two ways:

Select a file and choose “Print” from the Selected toolchest or menu. The system
sends the file to the printer that a Privileged User has designated as the default
printer for the system.

Drag a file onto a specific printer, or drag a file onto Print Panel and specify a
printer. The system sends the file to that printer.

If only one printer appears in your Printer Manager, it is automatically the default
printer. If several printers appear, a Privileged User can designate a default printer for all
users on the system by following these steps:

1.

Start the Printer Manager by clicking the words Printer Manager now, or by
choosing “Printer Manager” from the System toolchest.

Select the printer icon, then choose “Set Default” from the Printer menu or click the
Default button. A label appears above the list of printers that indicates which printer
is the system default.

Troubleshooting Printing
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If your job reached the printer’s queue but is not printing, follow these steps:

1.
2.

Cancel the job (see “Cancelling a Print Job”).

Start the Printer Manager by clicking the words Printer Manager now, or by
choosing “Printer Manager” from the System toolchest.

Select the printer icon, then choose “Send Test Page” from the Printer menu.

If the printer does not print the test job, see the section on troubleshooting printer
problems in the Personal System Administration Guide.

When you drag a file onto a remote Impressario printer (see also “About Impressario”)
you may see an error message that says:

Cannot print. No convert rule for: filename of type: type, resubnit fromthe
shel | .
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5: Printing

This means your system does not have the correct filter to print the file, but the system
to which the printer is connected does have the filter (see also “About File Format
Filters”). To submit the job again, follow these steps:

1. On your own system, choose “Open Unix Shell” from the Desktop toolchest.
2. In the window that appears, type:

| p filename - dprintername

where filename is the name of your file, and printername is the name of the printer.
3. To close the window, type:

| ogout

If you encounter other problems printing, see the detailed troubleshooting information
in the online book, Personal System Administration Guide.
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Chapter 6

Finding Things

This chapter explains how to find files, directories, applications, and images. It contains:
¢ “Finding Files, Directories, and Images”

¢ “Finding Applications”

¢ “Finding Files, Applications, or Directories Using File QuickFind”

¢ “Finding Files, Applications, or Directories Using the Search Tool”

Finding Files, Directories, and Images

Recommended General Approach for Finding Files and Directories

Start with File Quick Find (see “Finding Files, Applications, or Directories Using File
QuickFind”). If that does not work and/or you do not know the full path location (the
pathname) of the file, then use the Search tool (see “Finding Files, Applications, or
Directories Using the Search Tool.”).

See also “Useful Techniques for Finding Files and Images” below.

Useful Techniques for Finding Files and Images
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In many cases, you may want to use a combination of the following techniques. This
section includes “A Quick Way to Find a File in an Icon View Window,” “When You
Cannot Remember the Exact Name of an Image,” and “When You Cannot Remember the
Name of a File.”
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6: Finding Things

A Quick Way to Find a File in an Icon View Window

Use type-to-select. Move the mouse cursor to the background of the Icon View window,
click once, and begin typing the name of the file. As soon as the file is recognized, it is
selected (highlighted). Once the correct file is selected, press Ent er to open the file.

If you know the name of the file you are looking for, this technique helps you avoid
scrolling and scanning through a large group of files to find the one you it.

When You Cannot Remember the Exact Name of an Image

Browse through miniature views of images. If you cannot remember the name of an
image, but you know which directory it is in, open that directory so that is displayed in
an Icon View. Choose View > as Thumbnail Images in the Icon View window. This gives
you mini-views of all the images in the directory. Use the Icon View thumbwheel to
increase or decrease the size of the images.

Limit the Icon View display to match the image type or part of the name. Open the
directory that the image is in and choose Actions > Search/Filter Files from the Icon View
window. Use the “Show files that match name:” field to limit the files displayed. For
example, if you are looking for a GIF file, type in *gi f . If you are looking for an image
that has the word “bird” in the title, type * bi r d*.

When You Cannot Remember the Name of a File
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Get an extra-quick view of the content of various files. Open the directory that you think
contains the file you want. Choose Options > Show Content Viewer in the Icon View
window. A viewer opens at the bottom of the window. Click once on any file in the
directory to view a quick, read-only version of the file in the content viewer.

Limit the Icon View display by date. If you know which directory the file is in and have
a general idea of how long it has been since the file contents were last edited, open the
directory and choose Sort > By Date, and View > As List. This can help you narrow your
search.

Limit the Icon View display by a text string contained in the file. If you know which
directory the file is in and you know some piece of text that is probably in that file, open
the directory in an Icon View, choose Actions > Search/Filters Files. Enter a string of text
in the “Show files containing text:” field.
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Finding Applications

Limit search by time. If you have a general idea of how long it has been since the file
contents were last edited, but do not know what directory the file is in, use the Search tool:
choose Match > Date Modified, then use the time menu button and field— it lets you
specify whether you want to find files that are older than or newer than a certain number
of days, or older than or newer than a specified file.

Limit search by file type. If you know what kind of file it is, and you use naming
conventions for this particular kind of file (for example, if all Showcase filenames end in
“.sc”), use the Search tool. In this Showcase example, you would enter *. sc in the name
“contains string” field of the Search tool.

Finding Applications

This section includes: “Browsing for Applications,” “Finding Out What Application to
Use,” and “Finding Icons for Applications.”

Browsing for Applications

The Icon Catalog is your one-stop shopping place for the applications on your system.
Open it from the Toolchest by choosing Find > Icon Catalog, or choose from one of the
Icon Catalog categories listed on the Find menu.

Finding Out What Application to Use
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Quick Answers were designed to help you when you are not sure what you need to use to
accomplish a particular task. Access it from the Toolchest by choosing Help > Quick
Answers.

Note: Quick Answers documents only applications and utilities that are bundled with the
standard system software.
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Finding Icons for Applications

If you want to find the icon for an application, so that you can keep it on the desktop or
on an Icon View shelf, you can look for it in the Icon Catalog (see “Browsing for
Applications” above), then drag it to another location (which makes a reference icon to it).

You can also use File Quick Find (for instructions, see “Finding Files, Applications, or
Directories Using File QuickFind”) or the Search tool (see “Finding Files, Applications,
or Directories Using the Search Tool”) to locate an application icon, but these tools
require you to know the shell command for launching the application. For example, the
shell command for launching Movie Maker is novi emaker.

Tip: The shell command for an application is often the application name in lower case,
with no spaces.

Finding Files, Applications, or Directories Using File QuickFind

Using File QuickFind

78

File QuickFind is a small window into which you can type the name of applications, files,
and directories whose icons you want to find on your system.

Click a topic for step-by-step instructions on using “File QuickFind":

* “Using File QuickFind”

¢ “Troubleshooting File QuickFind”

If the File QuickFind window is not already open, choose “File QuickFind” from the Find
toolchest.

1. Type the name of a file, directory, or application in the type-in field provided.

If the file or folder icon resides in your home directory or search path, type the icon
name only. For example, to fetch the icon for a file named r eport 1 in your home
directory, type: report1
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2.

3.

If the file or folder icon is not in your home directory or search path, include the full
UNIX pathname. For example, if you want to find the folder icon for the / usr/ t np
directory, type/ usr/ t np in the field provided. If you want to find the icon for a file
called r eport 1 in the / usr/t np directory, type: / usr/tnp/report1

Press the Ent er key or double click the icon to open it.

Pressing the Enter key also places the icon name on the recycle list. If you need to
find the icon again, and the File QuickFind window is still open, place the cursor
over the recycle button; then press the left mouse button.

If you want, you can drag the icon to a different location—such as the desktop or a
page in the Icon Catalog—so it is easily accessible.

To add directories to your path, see “Adding Directories to Your Search Path
(Advanced).”

Troubleshooting File QuickFind
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When you use the “File QuickFind” command to search for an icon, the software
searches through a series of directories to find the file or application. The series of
directories it searches is called your path:

If you launched File QuickFind from a directory in an Icon View window, the current
directory is searched first.

Your home directory is searched next.

Then all directories listed in your path.

If File QuickFind does not find the file, it either does not exist, or the directory that
contains the file is not included in the current path. If it did not find it in your path, you
can do one of the following to find the icon:

Type the full pathname into File QuickFind to find the file.

For example, if you want to find the icon for a file called r epor t 1 in the / usr/t np
directory, type: / usr/t np/ report 1

Add the directory to your path so that you do not have the enter the full pathname
every time you search for certain files, directories, or applications. See “Adding
Directories to Your Search Path (Advanced)” for instructions.

Use the Search tool to find the file—the Search tool does require that you know the
path.
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Finding Files, Applications, or Directories Using the Search Tool

The Search tool helps you find icons for files, directories, or applications.

Using the Search Tool: An Overview
If you do not remember the name of a file or the directory in which it is stored, you may
have to search for it. You can use the Search tool to find files and directories based on:
® The filename, or a portion of the name
* The type of icon it has
e How recently the file was created or modified
* The person who owns the file
e The size of the file

* The permission settings for the file (permission settings specify whether people can
view and edit the file)

¢ The text in an ASCII text file
By default, the Search tool searches for files that are located on your system. It does not
search remote directories, even if the remote directory’s icon has been placed on your

desktop (mounted). To search in mounted directories, click to remove the check in the
checkbox next to the label only on this host.

To search for files on another system on your network, see “Finding Files on Another
System.”
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Using the Search Tool: Basic Instructions
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If you do not remember the name of a file or the directory in which it is stored, you may
want to use the Search tool to locate it. (If the Search tool is not already open, you can
launch it from the Toolchest by choosing Find > Search For Files.)

1.

Type the name, or a portion of the name, in the field next to the label “name.”

By default, the Search tool finds files whose name contains the string you type. For
example, suppose you type doc. You find all files whose name contains that
sequence of characters, regardless of the capitalization.

If you want to find files that match a particular name, you need to change the
setting from “contains string” to “matches pattern.” To do so, place the cursor over
the menu button labeled contains string; then press the left mouse button. Choose
“matches pattern.” Now, if you type “doc,” you only find files named doc.

Note: When you select “matches pattern,” you can use an asterisk (*). The asterisk
is called a wildcard character. For example, type *doc and you find all files that end
in doc. Do not include an asterisk if the Search tool is set to “contains string.” The
Search tool will look for a file name that includes the asterisk.

In the field next to the label “look,” type the name of the directory from which you
want to start the search.

Choose commands from the Match menu to specify what type of files you want to
find.

Each command on the Match menu reveals a new set of controls. To hide the
controls, choose “is ignored” from the menu button that you want to ignore.

e Choose “Icon” to specify the type of file you want to find. For example, if you
are looking for a file you created using the IRIS Showcase application, you can
specify that you want to find all IRIS Showcase files. See also “Finding Types of
Icons” and “Finding Directories.”

® Choose “Date Modified” to find files based on the time and date they were
created or modified.

¢ Choose “Ownership” to find files that are owned by a particular user.

A drop pocket and type-in field appear. Enter the name of the user or drop an
icon into the drop pocket. If the user’s icon is available, drop that into the drop
pocket. You can also find one file that is owned by that person, and place its
icon in the drop pocket.
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6: Finding Things

Finding Large Files
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Choose “Size” to find files that are greater than, less than, or equal to a specified
size. Several menu buttons and a type-in field appear. See also “Finding Large
Files.”

Choose “Permissions” to find files based on their permission settings.

A menu button appears. It offers two choices. You can find files that are marked
read-only (allow only reading) or files that are editable (allow reading and
writing).

Choose “Content” to find an ASCII text file that contains a specified sequence of
characters.

A type-in field appears. If you choose “Contains string,” type exactly the text
that you want to find—do not use the asterisk (*) as a wildcard character. For
example, if you type *. doc you will only find files that actually contain the text
string “*.doc.” However, when you choose “Matches pattern,” you can use the
asterisk as a wildcard character.

Press the Search button.

A list of icons that meet the search criteria appears in the lower portion of the
window.

Note: By default, the Search tool searches for files that are located on your system. It does
not search in remote directories whose icons you have placed on your desktop (mounted).
To search these directories, click the box next to the label “only on this host.” The
checkmark disappears.

You can use the Search tool to find files that are smaller than, greater than, or equal to a
specified size. If the System Monitor warns you that your disk is getting full, you might
want to use the Search tool to locate large files. (If the Search tool is not already open, you
can open it from the Toolchest by choosing Find > Search For Files.)

1.

Leave the field next to the label “name” empty.

This assures that you'll find all large files, regardless of their names. You have
another option: choose “is ignored” from the menu button. When you choose “is
ignored,” the controls for specifying a name disappear. To open them again, choose
“Name” from the Match menu.
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Finding Types of Icons

007-1342-170

In the field next to the label “look,” type the name of the directory from which you
want to start the search.

Choose “Size” from the Match menu.

A new area appears. It includes two menu buttons. One lets you choose whether
you want to find files that are greater than, equal to, or smaller than a specified size;
the other lets you choose what measurements you want to use—megabytes, bytes,
blocks, or kilobytes.

Choose ““is greater than” from the menu button next to the label “size.”
Type a number in the “size” type-in field.
Click the Search button.

Icons greater than the specified size appear in the results area.

Note: You can delete files to make more room on your system'’s disk. Before doing so,
consider making a backup copy of these files. Use the System Manager to find out how
to backup files. From the Toolchest, choose System > System Manager.

You can use the Search tool to find icons of a particular type—directories, audio files, IRIS
Showcase files, text files, or image files, for example. A unique icon identifies each of
these file types.

For this example, suppose you want to use the Search tool to find an IRIS Showcase file.
(If the Search tool is not already open, you can open it from the Toolchest by choosing
Find > Search For Files.)

1.

Leave the field next to the label “name” empty.

This assures that you'll find all files, regardless of their names. You have another
option: choose “is ignored” from the menu button. When you choose “is ignored,”
the controls for specifying a name disappear. To open them again, choose “Name”
from the Match menu.

In the field next to the label “look,” type the name of the directory from which you
want to start the search.

Choose “Icon” from the Match menu.
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A new area appears in the window.
Drag an icon of the type for which you are searching, and drop it into the drop pocket.

For example, if you want to find a particular IRIS Showcase file, drag an IRIS
Showecase file icon and place it in the drop pocket. The icon changes and the name
of that file type appears in the pathname field.

Press the Search button.

A list of files appears in the lower portion of the window. In this case, all of the files
on the list are IRIS Showcase files.

Finding Files on Another System
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You can use the Search tool to find files on another system if your system is on a network
and if the directory that contains the file is marked as shared by the remote system. To
find out whether a directory is shared, see “Accessing Another System’s Media Devices
or Printers.” In addition, NFS should be installed and you should have Aut onount or
Aut oFS turned on. To set this up, choose System > System Manager from the Toolchest,
go to Network and Connectivity, then click Set Up and Start NFS to open an Interactive
Guide.

If the Search tool is not already open, open it from the Toolchest by choosing Find >
Search For Files.

To find files on another system using the Search tool:

1.

If there is checkmark in the “only on this host” checkbox, remove it so that the
search is not limited to your own system.

Type the name of the file you want to find in the field next to the label “name.”
For more details, see “Using the Search Tool: Basic Instructions.”

In the field next to the label “look,” type / host s followed by the name of the system
and directory in which you want to search.

If the system is in a different domain of the network, include this after the system
name. For example, to search in the / usr/ t np directory on a system named
wi zar d in the . bl dg2 domain, type:/ host s/ wi zard. bl dg2/ usr/tnp

A folder icon should appear in the drop pocket next to the pathname you type. If it
does not appear, you can not search the directory you have specified. You may be
unable to search for one of several reasons:
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Finding Directories
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4.

5.

® The directory is marked as private; the owner has not set it up as a shared
directory. See “Sharing Directories With Other Systems” for more details.

* The permission settings prevent you from searching the directory. See
“Permissions Settings: A Definition” for more information on permission
settings.

® The remote system is down.
* NFSis not installed (see first paragraph of “Finding Files on Another System”).

Choose commands from the Match menu to narrow the search to specific types of
files.

Each command on the Match menu reveals a new set of controls. See “Using the
Search Tool: Basic Instructions” for more details.

Press the Search button.

A list of files that meet the search criteria appears in the lower portion of the
window. If you need to access a remote file frequently, drag the icon onto the
desktop, onto a shelf, or onto a page in the Icon Catalog. This gives you quick access
to a file on another system. To make a copy of the file, drag it into an open Icon View
window or over a folder icon.

You can narrow the search so that the Search tool only finds directories that meet the
search criteria.If the Search tool is not already open, you can open it from the Toolchest
by choosing Find > Search For Files.

1.

Type the name, or a portion of the name, in the field next to the label “name.”
For more details, see “Using the Search Tool: Basic Instructions.”

In the field next to the label “look,” type the name of the directory from which you
want to start the search.

Choose “Icon” from the Match menu.

A new area appears in the window.

Type “Directory” in the type-in field or drag a folder icon into the drop pocket.
Press the Search button.

A list of directories appears in the lower portion of the window.
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Creating and Saving a Custom Search

The controls for performing a specific type of search are stored on a page. For example,
suppose you use a software application that automatically creates a backup copy of the
file you are editing. It names these files f i | enane. bak. This protects you from losing
information if the program quits unexpectedly. To regain disk space, you might want to
find old backup files and delete them periodically. (If the Search tool is not already open,
you can open it from the Toolchest by choosing Find > Search For Files.)

1. In the Search tool, choose Page > New > File Search.

A new page appears. The tab displays the label “Files1.” This number increases
each time you choose “File Search.”

2. Type. bak in the field next to “name.”

By default, the Search tool finds files whose name contains the string of characters
you specify. If you type . bak, you find any files with a name that contain the
sequence of characters “.bak.”

If you have changed the setting to “matches pattern,” you need to type *. bak. The
asterisk is a wild card. You find all files with names that end with.bak.

3. Make sure the full pathname of your home directory appears in the field next to the
label “look.”

4. Choose “Date Modified” from the Match menu.
A menu button and new type-in field appear.

5. Choose “was before” from the menu button.

6. Type 7 in the field next to the menu button.

This specifies that you want to find files that end in . bak and are more than seven
days old.

7. Press the Search button.
You see a list of . bak files that are more than seven days old.

8. Choose “Rename” from the Page menu; then type a new name in the window that
appears. For this example, suppose you type “OldFiles.
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Chapter 7

Using Multiple Desks

This chapter contains:

e  “Whatis a “Desk”?”

* “Creating a Desk”

* “Switching Between Desks”

¢ “Moving Windows Between Desks”

e “Copying Windows Between Desks”

e “Listing All the Windows in Your Desks”
¢ “Renaming a Desk”

¢ “Deleting a Desk”

¢ “Placing a Window in All Desks”

* “Removing a Window From the Global Desk”
¢ “Manipulating Windows on a Desk”

®  “Customizing the Desks Overview”

What is a “Desk”?

When you log in, you see a collection of windows and icons on background. This is called
a desk. You can create new desks with different backgrounds, and with the windows you
need to use to perform a particular task. For example, using multiple desks can be helpful
in situations such as the following:

® Suppose that from your system, you regularly log on to other systems for certain
daily tasks. For convenience, and to avoid confusion, you can create a different
desktop for each of the other systems you regularly log in to.
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Creating a Desk

Suppose you spend a portion of your day creating marketing presentations and a
portion of your day reading mail. You can create a desk for each. One desk displays
the windows that you use while you are creating a presentation. The other desk
displays the windows that you use while you are reading and sending mail.

First, if the Desks Overview window is not already open, you can open it by choosing
Desktop > Extra Desks from the Toolchest.

1.

Choose Desk > New Desk.

The snapshot of a new desk appears in the Desks Overview window. The default
desk is named “Desk 1”; the first new desk you create is labeled “Desk 2.” The
number increases with each new desk you create.

Any windows or icons that appear on the global desk automatically appear on the
new desk.

Place the cursor over the desk; then double-click the left mouse button to go to the
new desk.

You can now use this desk as you please. Windows that you open on this desk will
not appear on other desks (except for the Global desk). To give your additional desk
a specific name, see “Renaming a Desk.”

Related Topics:
e “Switching Between Desks”
e “Moving Windows Between Desks”

e “Copying Windows Between Desks”

Note: Unlike the windows, the icons that you place on the desktop background appear
in all of your desks. You can not vary these icons from desk to desk.
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Switching Between Desks

Switching Between Desks

Use the Desks Overview window to go from one desk to another. (If the Desks Overview
window is not already showing, open it by clicking the words Desks Overview now, or
by choosing “Extra Desks” from the Desktop toolchest.)

1.

Place the cursor over the desk you want to display.

If the Desks Overview window is too small to display all of the desks, the desk that
you want to switch to might be hidden. Click the arrows that appear on the right or
bottom edge to scroll through the desks.

Double-click the left mouse button. Your screen changes; the new desk appears.

Note: You can use an alternative method. Select the desk you want to display; then
choose “Go to Selected” from the Desk menu.

Moving Windows Between Desks
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You can move windows from one desk to another using the Desks Overview. To do so,
drag the miniature picture of the window from one desk and drop it into another desk.
(If the Desks Overview window is not already showing, open it by clicking the words
Desks Overview now, or by choosing “Extra Desks” from the Desktop toolchest.)

1.

2.

3.

Make sure that the desks are represented as snapshots, rather than buttons.

A snapshot is a picture that shows a miniature version of each window that is on
the desk. If the desks are represented as buttons, choose “Show Snapshots” from the
Overview menu.

If necessary, resize the Desks Overview window so you can see the snapshot of the
desks between which you want to move the windows.

Place the cursor over the window that you want to move.

The name of the window appears when the cursor is over it.
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Note: If the name does not appear, choose “Display Window Name” or “Display
Icon Name” from the Overview menu. “Display Window Name” displays the name
that appears in the title bar of the window; “Display Icon Name” shows the name
that appears on the window when it is minimized (stowed).

Press the left mouse button and drag the window into the snapshot of the other
desk.

If you want to position the window in the same location in the other desk, drop the
window into the title bar of the desk.

Release the mouse button and the window disappears from one desk and appears
in the other desk.

Note: If you move a window onto the global desk, that window appears on all of your
desks.

Copying Windows Between Desks
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You can copy a window from one desk to another using the Desks Overview window.
For example, suppose you are using IRIS Showcase to create a presentation. You can copy
the IRIS Showcase window into another desk so that you can access it from there as well.
To do so, press the Ctr| key; then drag the item from one desk to another in the Desks
Overview window.

If the Desks Overview window is not already showing, open it by clicking the words
Desks Overview now, or by choosing “Extra Desks” from the Desktop toolchest.

1.

2.

3.

Make sure that the desks are represented as snapshots, rather than buttons.

A snapshot is a picture that shows a miniature version of each window and icon
that is on the desk. If the desks are represented as buttons, choose “Show
Snapshots” from the Overview menu.

If necessary, resize the Desks Overview window so you can see the snapshot of the
desks between which you want to move the windows.

Place the cursor over the window that you want to copy.

The name of the window appears when the cursor is over it.

007-1342-170



Listing All the Windows in Your Desks

Note: If the name does not appear, choose “Display Window Name” or “Display
Icon Name” from the Overview menu. “Display Window Name” displays the name
that appears in the title bar of the window; “Display Icon Name” shows the name
that appears on the window when it is minimized (stowed).

4. Pressthe Ctrl key and left mouse button; then drag the window into another desk.

If you want to position the window in the same location in the other desk, drop the
window into the title bar of the desk.

5. Release the mouse button and a picture of the window appears in that desk too.

Note: If you copy a window onto the global desk, that item appears on all of your desks.

If you close a window that you have copied into another desk, the window closes in both
of the desks. To make a window disappear from one desk only, select the window in the
Desks Overview display; then choose “Remove from Desks” from the Window menu.

Listing All the Windows in Your Desks
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To get a list of all the windows that exist on your desks, choose “List AlL..” from the
Windows menu on the Desks Overview menu. A new window appears. It contains a list
of all the windows that are open or minimized.

You can copy a window into your current desk using this list.

1. Place the cursor over the name of a window; then click the left mouse button to
select it.

A black rectangle surrounds the name when it is selected.
2. Click the Apply or OK button.

The window appears in your current desk. If you clicked Apply, the List All window
stays on the screen. If you clicked the OK button, the List All window disappears.
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Renaming a Desk

Deleting a Desk
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To rename a desk, select a desk in the Desks Overview window; then choose the
“Rename Selected” command. (If the Desks Overview window is not already showing,
open it by clicking the words Desks Overview now, or by choosing “Extra Desks” from
the Desktop toolchest.)

1.

Place the cursor in the Desks Overview window, over the desk that you want to
rename; then click the left mouse button once to select it.

A yellow outline appears around the selected desk.

Choose “Rename Selected” from the Desk menu.

The name of the desk is highlighted.

Type a new, unique name.

To replace the existing name, begin typing. The existing name disappears, and
the new name appears as you type.

To edit a portion of the name, place the cursor within the black rectangle
surrounding the name; then click the left mouse button to place a marker. Begin
typing to add characters after the marker; press the Backspace key to delete
characters preceding the marker.

To replace or delete several characters, press the left mouse button and drag the
cursor over the characters. Release the mouse button when the characters you
want to delete or replace are selected. A black rectangle surrounds these
characters. To delete the characters, press the Backspace key; to replace the
characters, begin typing.

To apply the name, press the Ent er key. To cancel the name change, press the Esc

key.

If you do not press the Enter key, the desk reverts to its original name when you
close and re-open the Desks Overview window.

To delete a desk, use the “Delete Selected” command on the Desks Overview window. If
the Desks Overview window is not already showing, open it by clicking the words Desks
Overview now, or by choosing “Extra Desks” from the Desktop toolchest.
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Placing a Window in All Desks

1. Place the cursor in the Desks Overview window, over the desk that you want to
delete; then click the left mouse button once to select it.

A yellow outline appears around the selected desk.
2. Choose “Delete Selected” from the Desk menu.

The selected desk disappears.

Placing a Window in All Desks

The global desk acts as a template for all other desks. Any windows that you place on the
global desk will automatically appear on all of your desks. You can place an item on the
global desk in one of three ways:

¢ If the window already appears on one of your desks, you can drag it into the global
desk in the Desks Overview window. See “Copying Windows Between Desks” and
“Moving Windows Between Desks.”

* You can open the global desk; then open windows. See “Switching Between Desks.”
* You can use the “Add to Global” command on the Window menu.

1. Make sure that the desks are represented as snapshots, rather than buttons. A
snapshot is a picture that shows a miniature version of each window and icon
that is on the desk.

If the desks are represented as buttons, choose “Show Snapshots” from the
Overview menu.

2. In the Desks Overview window, place the cursor over the window that you
want to place on all desks; then click the left mouse button to select it. A yellow
outline appears around the selected window.

3. Choose “Add to Global” from the Window menu. The selected window is
placed on the global desk and appears on all desks.

For instructions on removing a window from the global desk, see “Removing a Window
From the Global Desk.”
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Removing a Window From the Global Desk

“Placing a Window in All Desks” explains how to place a window on the global desk. If
you decide to remove a window from the global desk:

1.
2.

Choose “Show Global Desk” to display the global desk.

Select the window in the Desks Overview window; then choose “Remove from
Desk” on the Window menu.

The window disappears from the global desk; it remains on the other desks.

To remove the window from all desks except one:

1.
2.

Choose “Show Global Desk” to display the global desk.

Place the cursor over the window you want to remove from the global desk; then
drag it into the snapshot of another desk.

The window disappears from the global desk and all other desks except the one you
placed it on.

To remove the window from all desks:

1.

Switch to the global desk.
= Choose “Show Global Desk.” A snapshot of the desk appears in the window.

«  Double-click the snapshot of the global desk. The screen changes and you move
to the global desk.

Double-click the window to close it.

The window disappears from the global desk and all other desks.

Manipulating Windows on a Desk
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Most windows on your screen have a Window menu button in the upper left corner. Place
the cursor over this button, and then press the left mouse button to display a menu with
commands for manipulating the window. The Window menu on the Desks Overview

window also provides access to many of these commands.

This section provides two examples: “Minimizing All Windows in a Desk” and

“Minimizing a Selected Window.”
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Customizing the Desks Overview

Minimizing All Windows in a Desk

When you minimize a window, you turn it into a small square so that it uses very little
screen space. To minimize all of the windows in a desk, except the Desks Overview
window, choose “Minimize All” from the Window menu. To restore all of the windows
to their original size, choose “Restore All.”

Note: If the Desks Overview window is not already showing, open it by clicking the
words Desks Overview now, or by choosing “Extra Desks” from the Desktop toolchest.

Minimizing a Selected Window

You can use the Window menu to minimize selected windows. (If the Desks Overview
window is not already showing, open it by clicking the words Desks Overview now, or
by choosing “Extra Desks” from the Desktop toolchest.)

1. Make sure that the desks are represented as snapshots, rather than buttons.

A snapshot is a picture that shows a miniature version of each window and icon
that is on the desk. If the desks are represented as buttons, choose “Show
Snapshots” from the Overview menu.

2. In the Desks Overview window, place the cursor over the window that you want to
minimize; then click the left mouse button to select it.

A yellow outline appears around the selected window.
3. Choose “Minimize” from the Window menu.

The window becomes a small square.

Customizing the Desks Overview

Changing the Order of Desks

You can change the arrangement of desks within the Desks Overview window.
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7: Using Multiple Desks

Place the cursor over the title of the desk; then press the left mouse button and drag.
An outline of the desk shows where you are moving the desk.

Release the mouse button when the desk is positioned over the desk whose place
you want it to take.

Displaying the Names of Windows in a Desk

By default, a snapshot for each desk appears in the Desks Overview window. The
snapshot displays rectangles that indicate the location and relative size and shape of each
window on the desk. If you need additional help identifying a window, place the cursor
over the rectangle. The window name appears.

By default, you see the name that appears on the window when it is minimized. To see
the name that appears in the title bar of the window, choose “Display Window Name”
from the Overview menu. If you do not want to see any window names, choose “Display
No Names” from the Overview menu.

Hints for Resizing the Window

You can make the Desks Overview window small and still use it effectively. This section
provides hints for doing so.
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Resize the window so it is smaller. Notice that arrows appear along the right or
bottom edge and the menus collapse into one menu called “Menu.” You can use the
arrows to scroll from one desk to another.

Hide the global desk. By default, a snapshot of the global desk appears in the Desks
Overview window. If you do not need to use it frequently, choose “Hide Global
Desk” from the Overview menu. To show the global desk again, choose “Show
Global Desk.”

Make the snapshots or buttons smaller. See “Resizing Snapshots or Buttons.”

Hide the menu bar by choosing “Hide Menubar” from the Overview menu. The
menu bar disappears and you can make the window slightly smaller.

To access the menus, place the cursor in the window; then press the right mouse
button to reveal a pop-up menu. To show the menu bar again, choose “Show
Menubar” from the Overview menu.
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Customizing the Desks Overview

Viewing Desks as Snapshots or Buttons
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The Desks Overview window shows each of your desks. You can choose to display these
as snapshots or as buttons. A snapshot is a small picture that contains a miniature version
of each window on the desk; a button is more compact and provides a list view of your
desks. Figure 7-1 shows the Desks Overview window displaying a snapshot of each desk
(top) and a button representing each desk (bottom).

Figure 7-1 The Desks Overview Window

By default, the desks are displayed as snapshots. To change the setting:
® Choose “Hide Snapshots” from the Overview window.

¢ Choose “Show Snapshots” again to revert to the original view.
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7: Using Multiple Desks

Resizing Snapshots or Buttons

Each desk is represented as a snapshot or button in the Desks Overview window. You can
make these smaller or larger by choosing a command from the Scaling rollover menu on
the Desk menu.

The first five commands are pre-defined. The last command, “Custom,” lets you choose
a custom setting. The instructions for doing so follow:
1. Choose “Custom” from the Scaling rollover menu.
The Desk Overview Custom Scaling window appears.
2. Drag the slider in the middle of the window.
Drag to the left to get a smaller number; drag to the right to get a larger number.

3. Click the Apply button to add the entry to the menu and leave the window open.
Click the OK button to add the entry to the menu and close the window.

The “User defined” command shows the custom setting you selected; the buttons or
snapshots in the Desks Overview window are resized.
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Chapter 8

Managing Windows

If you run an application and open several other windows, your screen quickly becomes
cluttered with windows. You need to know how to organize windows into desks, move
and shrink windows, change the way windows overlap, and close and quit from
windows when you are finished using them.

This chapter contains:

¢ “Organizing Windows Into Desks”

¢ “Opening Fewer Windows”

¢ “Resizing Windows”

¢ “Minimizing Windows”

¢ “Moving Windows”

¢ “Raising and Lowering Windows”

¢ “Changing the Window Focus Behavior”

¢ “Closing Windows”

Organizing Windows Into Desks
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If your screen becomes cluttered with windows, consider creating a separate desk on
which to place certain windows. For example, if you spend a portion of your day using
3D modeling software, and a portion of your day typing and mailing reports, you might
want to create a desk for each task. One desk displays the windows that you use to build
3D models. The other desk displays the windows that you use to write reports and send
them to coworkers using electronic mail.
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8: Managing Windows

To create a new desk, use Desks Overview. To open it, click the words Desks Overview
now, or from the Toolchest, choose Desktop > Extra Desks. Refer to the Desks Overview
Help button for detailed instructions, or see Chapter 7, “Using Multiple Desks.”

Opening Fewer Windows
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One way to conserve screen space is to open fewer windows.

Place commonly used icons on the desktop so you can access them easily. See “Using
a Shelf for Convenient Icon Access.”

Open one Icon View inside of another using one of these techniques:

Choose “as List” from the View menu on an Icon View window. Icons in the
window are organized in a list; an arrow appears next to folder icons. Click the
arrow and the contents of that directory are listed underneath the folder icon.

Locate the icon for the directory you want to open. Drag the icon and place it in
the drop pocket in the upper left corner of the window. The window changes to
display the contents of that directory.

Use the path finder at the top of the Icon View window. See “Opening a
Directory Using the Path Finder” for details.

Open a directory in an already opened Icon View. Instead of opening another
Icon View, hold down the Al t key and double-click a directory icon within a
currently opened Icon View. The directory appears, replacing the previous
displayed directory.

You can make this the default behavior for a Icon Views by choose Options >
Default Layout from an Icon View window. Then put a checkmark in the Open
in Place checkbox.
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Resizing Windows

Resizing Windows
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You can resize windows to help you manage screen space on your desktop.

Figure 8-1 Resizing a Window by Dragging Out the Border

1.

Position the cursor on the window border.

The cursor changes to indicate that you can resize the window. Place the cursor on a
horizontal border to change the height of the window; place it on a vertical border
to change the width of the border; place it on a corner border to change both the
width and the height.

Press and hold the left mouse button.
Resize the window by dragging the cursor.

When you start to move the border, an outline of the window appears showing the
new size of the window.

Release the left mouse button when the window is the size you want.
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8: Managing Windows

Minimizing Windows

Moving Windows
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You can turn a window into a small square icon so that it uses very little screen space.
This is called stowing or minimizing a window. Applications continue to run in windows
that have been minimized.

To minimize a window:
1. Place the cursor over the Minimize button, as shown in Figure 8-2.

You do not need to place the cursor on the small button; place it anywhere within
the button’s outer border.

=0

Figure 8-2 Clicking the Minimize Button

2. Click the left mouse button.
The window becomes a small square icon.

3. Restore the window to its original size by clicking the small square icon.

You can also minimize a window using the “Minimize” command on the Window menu.

When you work with many different windows, frequently you need to move a window
to a different place on the screen.

¢ Ifa window has a title bar, you can grab the title bar or any part of the window
border with the left mouse button to move the window.

¢ Ifa window does not have a title bar, you can grab any edge of the window border
with the left mouse button to move the window.

¢ Ifawindow does not have a title bar or border, press the Al t key and hold down the
right mouse button. Select “Move” from the menu that appears. The cursor changes
to a crossbar and lets you move the window.
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Raising and Lowering Windows

Raising and Lowering Windows

If windows are lying on top of each other on your screen, and the window you want is
hidden, you can raise the window to the top of the stack, or lower the windows that are
covering it to the bottom of the stack.

To raise a window, place the cursor inside the title bar or within the window border and
click the left mouse button. The window pops to the top.
To lower a window:
1. Place the cursor over the Window menu button.

The Window menu button is the small square in the upper left corner of the title bar.
2. Press the left mouse button and choose “Lower” from the menu.

The window jumps to the bottom of the stack and exposes the windows that were
beneath it.

Tip: If the title bar or window border is not visible, you can access a menu that lets you
raise or lower the window by positioning the mouse cursor over the window and
pressing the right mouse button and the Al t key at the same time.

Changing the Window Focus Behavior
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By default, you need to move your mouse cursor into a window in order to type in it.
This is called implicit focus or “point to type.” You can change the focus behavior to
explicit focus or “click to type” using the Window Settings Control Panel.

If the Window Settings control panel is not already open on your screen, open it by
clicking the word Windows now, or by choosing “Windows” from the Customize menu
in the Desktop toolchest.
To change the keyboard focus behavior:
1. Next to “Keyboard Focus:”

¢ C(Click the button next to “Point to type” to select implicit focus.

e C(Click the button next to “Click to type” to select explicit focus.
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2.

Closing Windows

Selecting “Click to type” means that you give a window focus by clicking on it.
The window continues to have focus until you click on another window,
regardless of the location of the cursor.

A checkmark appears to let you know it is activated, and a window appears, telling
you that the window manager will need to be restarted in order for the change to
take effect.

Click OK.

If you click OK, all the windows you currently have open will redraw, and the
keyboard focus behavior changes.

When you are finished working in a window, you can make it disappear in one of several
ways.

Place the cursor over the Window menu button; then double-click the left mouse
button. The Window menu button is the small square in the upper left corner of the
title bar.

If an application has a Close or Quit button, click that. If an application has a
“Close,” “Quit,” or “Exit” command on one of its menus, choose that.

If the title bar or window border is not visible, you can access a menu that lets you
close the window by positioning the mouse cursor over the window and pressing
the right mouse button and the Al t key at the same time.

Note: When you close a window, you stop whatever process (application) is running in
that window, and the window disappears. When you quit from a window, you stop
whatever process (application) is running in that window, and you stop any other
processes associated with that window.
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Chapter 9

Sharing and Protecting Files, Media Devices, and
Printers

Files that you own can be shared with other users on your system and, if you choose,
with other users on your local network. You can set permissions to prevent other users
from accessing your files, or designate certain directories or resources as “shared” so that
others can access them across the network.

For details, click an item on the list below.

¢ “Understanding and Changing Permissions”

¢ “Sharing Resources With Other Systems”

Related Topic: Chapter 10, “Accessing Other Systems and Resources on Your Network”

Understanding and Changing Permissions

007-1342-170

Every time you create a new file, the system automatically identifies you as the file’s
owner, and assumes that you do not want other users on your system to change the file
but you do want others to be able to read its contents. In this way, the system sets
ownership and permission settings for the file.

For details, click an item on the list below.

¢ “Changing Permissions”

e “Owner, Group, and Others: A Definition”

* “Permissions Settings: A Definition”

e “Viewing Permissions Information”

Related Topic: “Sharing Directories With Other Systems”—a quick way to change
permissions on directories so that others can access and edit the contents.
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Changing Permissions

Each file on the system is owned by one User, and has an associated list of who can and
cannot access the file in different ways. You can change permissions on files that you own
(that is, those labelled with your login name) using the Permissions tool.

To change permissions, select the file or directory icon or icons (in an Icon View window)
whose permissions you want to change, then choose Selected > Change Permissions. The
Permissions tool launches. Refer to the Permissions tool Help for more details.

For a definition of read, write, and execute abilities, see “Permissions Settings: A

Definition.” For a definition of owner, group, and others, see “Owner, Group, and
Others: A Definition.”

Owner, Group, and Others: A Definition

When you set permission settings for a file or directory, you divide users on your system
into three categories: you (the file’s owner), your group, and everyone else.

The concept of a group is important in working environments that require an added level
of privacy. For example, suppose you are part of a team that is working on a new product.
You need to share files with others on the team, but you do not want people outside of
the team to view or modify these files. You form a group. See “Understanding User
Accounts, Groups, and the Network” in the Personal System Administration Guide to learn
how to establish and modify groups.

Permissions Settings: A Definition
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You can grant varying levels of permission settings for files and directories. The three
levels for files are read, write, and execute.

® Read allows other users on your system to view a file but does not allow them to
edit it.

*  Write allows other users on your system to make changes to files.

e Execute allows other users on your system to run applications and commands and
open directories to view and search their contents.
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Sharing Resources With Other Systems

The three levels for directories are read, write, and execute.
® Read allows other users on your system to view the files in a directory.

*  Write allows other users on your system to place files inside or delete files from the
directory.

®  Execute allows other users on your system to pass through a directory on their way
to another directory.

Viewing Permissions Information

To determine who owns a file and what exactly the permission settings are:
1. Select the file or directory icon.

2. Hold down the right mouse button and choose “Get Info,” or choose “Permissions”
from the Selected menu.

Sharing Resources With Other Systems

Use the Shared Resource Manager to designate directories, media devices, and printers
as available to other users on other system. For information, see:

¢ “Sharing Directories With Other Systems”
¢ “Sharing Media Devices and Printers With Other Systems”

Sharing Directories With Other Systems
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Designating a directory as “shared,” means that you are allowing users on other systems
to open the directory on their own deskfop and access it as if the directory resided on their
own system—in other words, other users are given read, write, and execute permission
(see “Permissions Settings: A Definition” for clarification).

To share a directory so users on other systems can view or change its contents, follow
these steps:
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1. Select the directory you want to share, hold down the right mouse button, and
choose Share with Network... from the Selected menu that appears.

The Share a Directory guide appears.
2. Follow the instructions in the guide to share the directory.

You can stop sharing a directory the same way: select the icon, then choose Stop
Sharing... from the right mouse button menu.

After you complete the task, you can check to make sure the directory is shared by
choosing Desktop > Shared Resources > On This Workstation from the Toolchest. This
opens the Shared Resource Manager that displays all the shared resources on your
system.

Note: You can also share files and directories on the Web using OutBox by selecting
“Share > Publish to Outbox” from the Selected menu. For details about using OutBox,
refer to the OutBox Help menu.

Sharing Media Devices and Printers With Other Systems
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Designating media devices or printers as “shared” means that you are allowing users on
other systems to open the device or printer icon on their own desktop and access it as if
the device resided on their own system.
To share a device or printer so users on other systems can access it, follow these steps:
1. From the Toolchest, choose Desktop > On This Workstation.

The Shared Resource Manager appears.
2. Click on the Media or Printers button.

The Share Removable Media or Share Printers guide appears.
3. Follow the instructions in the guide to share the device or printer.
After you complete the task, you can check to make sure the directory is shared by
selecting “On This Workstation” from the Shared Resources menu in the System

toolchest. This opens the Shared Resource Manager that displays all the shared resources
on your system.
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Chapter 10

Accessing Other Systems and Resources on Your
Network

If your system is on a network, you can access files, media devices, and printers from
other systems on the network. For information, see:

“Accessing Another System’s Media Devices or Printers”
“Using Host QuickFind to Find Remote Host Icons”
“Using the Access Desktop Tool”

“Accessing Files and Directories On Other Systems”

“Logging In to Another System”

Related Topic: “Accessing Applications On Remote Systems”

Accessing Another System’s Media Devices or Printers
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If your system is on a network, you can use the Find Remote Resources tool to access
another system’s shared resources—directories, media devices, and printers. To do this:

1.

2.

3.

From the Toolchest, choose Desktop > Shared Resources > On a Remote
Workstation.

Type in the name of the other system.

A list of all the system’s shared directories, media devices, and printers appears in
the display.

If the resource(s) you want to access do not appear, the owner of the system has
probably not marked them as shared. See “Sharing Media Devices and Printers With
Other Systems” to find out how they can easily remedy this.

Drag the device icon you want onto your desktop for easy access. Dragging it onto
your desktop lets you use the device as if it existed on your own system.

109



10: Accessing Other Systems and Resources on Your Network

Using Host QuickFind to Find Remote Host Icons

Other systems on your network are referred to as “remote hosts.” If your machine is on
a network and you have optional NFS software installed (use Software Manager to find
out if NFS is installed), you can locate an icon for a remote host. For easy access to the
remote host, you can drag the host icon onto your desktop.

1.

2.

If Host QuickFind is not already open on your screen, choose “Host QuickFind”
from the Find toolchest to open it.

To find an icon for a remote host, type in the remote hostname and press Ent er. The
host’s Find Remote Resources form appears. This form displays all the shared
resources on the remote system.

Using the Access Desktop Tool

You can use the Access Desktop tool for a few different tasks. Choose from:

“Accessing Remote Files and Directories With the Access Desktop Tool”
“Using the Access Desktop Panel to Access Applications on Another System”

“Accessing Files, Directories or Toolchests as Another User”

Accessing Files, Directories or Toolchests as Another User
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If you are logged into an account, but want to access a particular file, directory, or
Toolchest in the account of another user on the system, you can do so using the Access
Desktop tool. For example, if you are logged into the guest account, and you want to edit
a file owned by the root account, you can open the Access Desktop tool, “login” as root,
then open the directory that contains the file you want to edit.

1.

2
3
4.
5

From the Toolchest, choose Access Files > As Another User.

Type in the login name and password (if applicable) of the user you want to become.
Select “Directory” to open a directory.

Type in the pathname of the directory you want to view.

Click the Apply button.

An Icon View of the directory appears.
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Accessing Files and Directories On Other Systems

Accessing Files and Directories On Other Systems

If your machine is on a network, you can access directories on other systems on the
network in any of several ways:

“Accessing Remote Files Using Automount”

“Accessing Remote Files and Directories With the Access Desktop Tool”
“Accessing Files Using FTP in an Icon View Window”

“Accessing Files on the Web Using an Icon View Window”

“Accessing Files Using the FTP Command in a Shell”

“Accessing Remote Files Using the rcp Command”

Accessing Remote Files Using Automount

If two systems are on a network and optional NFS software is installed on both systems
(use Software Manager to find out if NFS is installed), you can access files on the remote
system using automount. To do this, follow these 3 steps:

1.
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Make sure the directory on the remote system is marked as shared:

* From the Toolchest, choose Desktop > Shared Resources > On a Remote
Workstation.

*  When the Find Remote Resources window appears, type in the name of the
workstation you want to access.

A list of the shared directories appears in the display.

Note: If the directory is not listed, it is not shared. The owner of the remote directory
can use the Share a Directory guide to share the directory. (For information, see
“Sharing Directories With Other Systems.”)
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2. To open an Icon View of the directory, you can do any of following:

¢ Drag the directory icon from the Find Remote Resources window to your
desktop and open it.

e  From an Icon View window, choose Actions > Access Files > In Automounted
Directory. / host s/ appears in the path finder.

Type in the remote system name and the directory path for the directory you
want to open, and press Ent er.

For example, if the system where the remote directory resides is called
mur gat r oi d, and the directory you want to open is / usr / peopl e/ dave, the
pathname would look like this:

/ host s/ nur gat r oi d/ usr/ peopl e/ dave

¢ From the Toolchest, choose Desktop > Access Files > In Automounted Directory.
If you do this, an Icon View window appears with / host s/ in the path finder.

Type in the remote system name and the directory path for the directory you
want to open. (See above for an example.)

3. When the Icon View of the directory opens, you can drag a file from one Icon View
to another to copy it.

If you want to copy a file from your local system to the remote directory, the owner
of the remote directory must have activated write permission for the directory. They
can do this using the Share a Directory guide. (For information, see “Sharing
Directories With Other Systems.”)
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Accessing Remote Files and Directories With the Access Desktop Tool
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If your system is on a network, and you want to access or copy files and directories to or
from another system on the network, you can do so with Access Desktop tool.

To open the Access Desktop tool from the Toolchest, choose Desktop > Access Files > By
Remote Login.

1.
2.

Type in the name of the remote workstation.
Type in a user name and password (when applicable).

You need to type in the account name of a user who has a login account on the
remote system. If you do not have an account on the remote system or do not know
another account name on the system, enter guest.

Select “Directory” and type in the pathname for the directory you want to open.
Click the Apply button.

An Icon View of the remote directory appears on your desktop. You can now
navigate through other directories on the remote system, as long as the user name
you specified has read permission on the directories you want to view.

You can copy files and directories from your system onto the other system and vice
versa by dragging the icons from one directory to the other.

Consider the following if the Icon View does not appear:

Does the user account name you specified have read permission on the directory? If
not, the owner of the directory must change the permissions so that you can access
the directory.

Is the workstation name correct?
Does the user you specified have an account on the remote system?
Did you type in the correct password?

Is the directory pathname correct?
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Accessing Files Using FTP in an Icon View Window

The f t p program lets you transfer files using the Internet File Transfer Protocol. To use
f t p, you must have a login account with a password on the remote workstation. If the
account does not have a password, f t p will not work., unless the site allows anonymous
login. If a site has anonymous login, anonynous appears in the username field, and your
E-mail address appears in the password field.

To use f t p in any Icon View window:

1. Type the f t p pathname into the path finder, and press Ent er.

For example, if the name of the system you want to access is IRIS9, you would type:
ftp://1R S9/
You can also open an Icon View with f t p: // already typed into the path finder by

selecting “Icon View of an FTP Site” from the Internet toolchest or from the Internet
menu in an Icon View.

2. When the login window appears, type in a username and password, then click the
OK button.

If a site has anonymous login, anonynous appears in the username field and your
E-mail address appears in the password field. Click the OK button to log in.

The files appear in the display. You can drag them to another Icon View to copy
them into a new location.

Note: You cannot copy or move any files into an Icon View of an FTP site.

Accessing Files on the Web Using an Icon View Window
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You can access remote files on the Web by typing a Web site address (“URL”) into the path
finder in an Icon View window. To type a Web site into the path finder, begin the address
withhttp://.

When you enter a Web site into an Icon View window, a list of all the links on the Web
page appear. Each text item and image is converted to a file that you can copy to your

system by selecting the icon, pressing the Ct r | key, and dragging the icon into a directory
folder.
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Note: You cannot copy or move any files into an Icon View of a Web site.

Tip: You can also open a Web site by dragging a WebJumper icon into the Icon View drop
pocket.

Accessing Files Using the FTP Command in a Shell

The f t p program lets you transfer files using the Internet File Transfer Protocol. To use
f t p, you must have a login account with a password on the remote workstation. If the
account does not have a password, f t p will not work.

Using ftp to Log Into Another System
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To use the f t p command to transfer files between workstations, you must first log in to
the remote machine using f t p. This example shows how to use f t p to connect to the
system | RI S9.

Note: If | Rl S9 is in a different domain (bl dg2, for example), you would use
I RI S9. bl dg2 in the example below instead of | Rl S9.

1. Open a shell window by choosing “Open Unix Shell” from the Desktop toolchest.
2. Start the program by typing:

ftp I RS9
3. PressEnter.

The screen displays something similar to this:

Connected to | RI S9.
220 I RIS9 FTP server ready.

4. Type the login name at the prompt that appears; then press Ent er. A user named j oe
would type:

Name (I RIS9:joe): joe
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5. Type the password at the password prompt; then press Ent er.

331 Password required for joe.
Passwor d:

Note: If the account does not have a password, you cannot use f t p.

6. You are logged in when the screen displays:

230 User joe logged in.

Copying a File to Another System Using the ftp Command

Once you are logged in to the remote workstation, you can transfer files from your system
tol RI' S9, and vice versa, using the put and get commands. (If you have not logged in
to the other workstation yet, see “Using ftp to Log Into Another System.”)

This example shows how to transfer a file called f i | el from your machine to | Rl S9.
Type the following at the f t p prompt:

ftp> put /usr/people/joe/filel /usr/tnp

This copiesfi | el from/ usr/ peopl e/ j oe onyoursystemto/ usr/tnponl Rl S9.To
copy fil e2 from | R S9 to your system, type:

ftp> get /usr/people/fred/file2 /usr/tnp

This copiesfi | e2 from/ usr/ peopl e/ fredonl| Rl S9 to the / usr/t np directory on
your system.

The f t p program has many options. See the ftp reference page (man page) for further
details.

Accessing Remote Files Using the rcp Command

If two systems are on a network, you can copy files between these systems using the r cp
command in a shell window.
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Anatomy of the rcp Command

You can use the r cp (remote copy) command to copy information from your system to
another system, or vice versa. To do so, you need this information:

® The name of the system you are copying to or from and, if the system is in a
different domain, the domain name.

* A login name to access the system.
®  The pathname of the file being copied.

® A pathname indicating where you want the copied file to be placed on your
workstation.

The command syntax shows how you specify this information:
rcp [user@]source[.domain]:filename local_filename
(The square brackets indicate that the information contained within them is optional.)

See the r cp reference page (man page) for more detailed information on the command
syntax.

Copying Files From Another System Using the rcp Command
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This section shows how to use the r cp command to copy files from another system. See
“Anatomy of the rcp Command” for more details on the command.

This example supposes you want tocopyfi | el from/ usr/ peopl e/ fred onasystem
named | RI S9 and place it in the / usr/t np directory on your system.
1. Open a shell window by choosing “Open Unix Shell” from the Desktop toolchest.
2. If you have a login account on | Rl S9, type:

rcp | RIS9:/usr/people/fred/filel /usr/tnp

If you do not have a login account on | Rl S9, copy the files as guest by typing:
rcp guest @RI S9: /usr/people/fred/filel /usr/tnp
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Note: If | Rl S9 is in a different domain (bl dg2, for example), you would use
I RI S9. bl dg2 in the example below instead of | Rl S9.

3. PressEnter.

Copying Files to Another System Using the rcp Command

This section shows how you use the r cp command to copy files to another system. See
“Anatomy of the rcp Command” for more details on the command.

This example supposes you want to copy fil e2 from
/'usr/ peopl e/ j oe on your system to/ usr/t np on a system called | RI S9.
1. Open a shell window by choosing “Open Unix Shell” from the Desktop toolchest.
2. Type:
rcp /usr/peoplel/joel/file2 guest @RI S9:/usr/tmp

Copying a Directory Using the rcp Command

To copy a directory and its contents from one system to another, you use the -r option
to r cp. This example shows what you would type to copy the directory

/'usr/ peopl e/ j oe/ reports from your system to / usr/ t np on a system called

| Rl S9.

1. Open a shell window by choosing “Open Unix Shell” from the Desktop toolchest.
2. Type:
rcp -r /usr/peoplel/joel/reports guest @RI S9:/usr/tnp

Note: The - v option lets you see the names of files as they are copied. Consider the
example. If you add the - v option, you see the names of the files in the r eports
directory as they are copied to | Rl S9.
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Logging In to Another System

If your workstation is part of a network of workstations, you may be able to log in to
another workstation remotely — that is, sit in front of your workstation but access files
on another workstation. This means you can also sit in front of another workstation and
access your own workstation. The following topics cover different ways of doing this,
presented in order of difficulty, with the first option being the most “user-friendly”:

* “Accessing Remote Files and Directories With the Access Desktop Tool” (located in
a different section)

¢ “Logging In to Another System Using the rlogin Command”
¢ “Using rsh to Perform Commands on Another System”

* “Using telnet to Log In to Another System”

Logging In to Another System Using the rlogin Command

Using rsh to Perform
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Ther | ogi n command lets you log in to another system. This example shows how to log
in remotely to | RI S9 as guest .

Note: If | Rl S9 is in a different domain (bl dg2, for example), you would use
| RI S9. bl dg2 in the example below instead of | Rl S9.

1. Open a shell by choosing “Open Unix Shell” from the Desktop toolchest.
2. Type:rlogin guest @RI S9

To log out of | Rl S9 when you are finished, type:

exit

Then press Ent er.

Commands on Another System

r sh connects you to a remote workstation just long enough to run commands that you
specify on the same command line as r sh. Once the command is finished, the connection
is broken. For example, to find out who is logged in on | Rl S9:
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1.

Open a shell by choosing “Open Unix Shell” from the Desktop toolchest.

2. Type:

rsh guest @RI S9 who

This runs the command who on | RI S9 and returns the information to your shell window.
If you do not specify a command, r sh behaves just like r | ogi n; it logs you into the
remote workstation.

For further details, see the rsh and rlogin reference pages (man pages).

Using telnet to Log In to Another System
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Thet el net program offers you another way of logging in to a remote workstation. To use
t el net, type a set of information into a shell window.

Note: If | Rl S9 is in a different domain (bl dg2, for example), you would use
I RI S9. bl dg2 in the example below instead of | Rl S9.

SRR I

Open a shell by choosing “Open Unix Shell” from the Desktop toolchest.

Type the name of the system to which you want to log in. For example, to log in to
I RI S9, type:

telnet | R S9

The screen shows:

Trying 192.26.180. 10. ..
Connected to | Rl S9.
Escape character is *"]’.

IRIX System V.3 (IRl S9)

| ogi n:

Type your login name (or guest, if you do not have an account on that system).
Press Ent er.

If the system asks for a password, type it, then press Ent er.

Use the remote workstation just as you use a shell window on your own system.

007-1342-170



Logging In to Another System

7. When you are finished and want to end the connection to the remote system, type:
| ogout

Then press Ent er.
The screen displays:

Connection closed by foreign host.

The t el net program has many options. See the telnet reference page (man page) for
further details.
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Customizing the Desktop Environment

The following customizations are available through desktop user-interface programs:
¢ “Changing the Desktop Background”

* “Setting Default Icon View Preferences”

¢ “Changing Window Color Schemes”

* “Customizing the Screen Saver”

¢ “Customizing Mouse Settings”

¢ “Customizing Keyboard Settings”

¢ “Customizing Window Settings”

¢ “Changing the Language and Keyboard Layout”
¢ “Controlling System Alerts”

¢ “Customizing Desktop Settings”

The following customizations require you to edit or create special files:

¢ “Disabling Icons on the Desktop”

* “Adding Directories to Your Search Path (Advanced)”

¢ “Running Applications When You Log In Using the .sgisession File”
¢ “Modifying the Toolchests (Advanced)”

¢ “Using Your Own Customized Backgrounds (Advanced)”

¢ “Using Custom Icons on Your Desktop (Advanced)”

123



11: Customizing the Desktop Environment

Changing the Desktop Background

Each desk has its own background color. You can change any desktop background color
or pattern using the Background Setting control panel. You can also create custom colors.
For details, see:

¢ “Choosing a Solid Color for Your Desktop Background”

¢ “Choosing a Multicolored Pattern for Your Desktop Background”

Choosing a Solid Color for Your Desktop Background
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If you want your desktop background to be one solid color rather than a pattern of two
colors, you can choose a color using the color palette in the desktop Background Setting
control panel.

If you have not already opened the Background Setting control panel, open it by clicking
the word Background now or by choosing “Background” from the Customize menu in
the Desktop toolchest.

To choose a solid color for your desktop background:

1. Click on the word “Solid” in the Patterns list.

2. Click on the small, colored square above the Cancel button.

The Color Browser window appears on top of the main control panel window. You
may want to move the Color Browser window aside so you can see both windows.

3. Click on one of the colors below the Options menu label, or create your own custom
color. To do this:

Move your mouse cursor on top of the small circle in the colored hexagon.
Press down on the left mouse button, and move your mouse.
Release the mouse button when the circle is above a color you like.

The color beneath the circle appears in the rectangle next to the “Current Color”
label.

Move the slider bar next to “Value” back and forth to brighten or darken the
color.
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Click the down arrow between the “Current Color” and “Stored Color” rectangles
to store a color you like while you browse through other colors.

4. When you have found a color you like, click the OK button in the Color Browser
window.

5. Click the Apply button in the main Background Setting control panel.
Your background changes to the new color.

6. Click the Close button in the main Background Setting control panel window to
close the panel.

Note: If the background on your screen flashes when you run Graphics Library
applications, you may have hardware that supports only a single colormap. To prevent
the screen from flashing, choose one of the colors below the Palette Colors label in the
Color Browser window when choosing a background color.

Choosing a Multicolored Pattern for Your Desktop Background
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You can choose a multicolored pattern for your desktop background by using the
Background Setting control panel. First choose the pattern you want, then choose the
colors.

If you have not already opened the Background Setting control panel, open it by clicking
the word Background now or by choosing “Background” from the Customize menu in
the Desktop toolchest.

To choose a pattern and colors for your desktop background:

1. Scroll through the list of patterns in the patterns list, then click on a pattern you
want.

The display to the right of the list of patterns switches to the new pattern, and a
number of small colored squares appear below it. These squares represent the colors
you can use in your pattern.

2. Click on one of the small squares.

The Color Browser window appears on top of the main control panel window. You
may want to move the Color Browser window aside so you can see both windows.
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3. Click on one of the colors below the heading “Palette Colors,” or create your own
color. To do this:

* Move your mouse cursor on top of the small circle in the colored hexagon.
¢ Press down on the left mouse button, and move your mouse.

As you move your mouse around the hexagon, the color beneath the small
circle appears in the rectangle next to the “Current Color” label. This rectangle
acts as your color palette while you choose a new color.

¢ Release the mouse button when the small circle is on top of a color you like.

* Move the slider bar next to “Value” back and forth to brighten or darken the
color.

4. Click the Apply button in the Color Browser window to see the new color mix with
your pattern in the sample background square.

If you do not like the color, you can continue to choose new colors and click Apply
until you decide on a color you like. Click the down arrow between the “Current
Color” and “Stored Color” rectangles to store a color you like while you browse
through other colors.

5. Click on another small colored square in the main window and create the next color.

6. Click the Apply button in the Color Browser window to see the new color mix with
the pattern and the first color you chose in the sample background square.

7. Continue to click on the small colored boxes and create new colors until you have
created a color combination that you like.

8. Click the OK button in the Color Browser window.
The window closes.
9. Click the Apply button in the main Background Setting control panel.
Your desktop background changes to the new multicolored pattern.
10. Click the Close button in the main Background Setting control panel to close the

panel.

You can also create colors by choosing “Value and RGB” or “HSV and RGB” from the
Sliders menu. These menu options reveal sliders that allow you to change the colors by
moving the sliders instead of moving the circle within the hexagon.
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Note: If the background on your screen flashes when you run Graphics Library
applications, you may have hardware that supports only a single colormap. To prevent
the screen from flashing, choose colors below the Palette Colors label in the Color
Browser window when choosing background colors.

Setting Default Icon View Preferences
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By default, icons that appear in Icon Views are arranged alphabetically. Also, hidden files,
shelf, thumbnail images, align to grid, open in place, content viewer, and search/file filters
are turned off. Dynamic Help is turned on. To change any of these default settings, use
the Default Layout for Icon Views panel.

If this panel is not open, open it now by choosing Desktop > Customize > Icon Views
from the Toolchest. The settings you make with this panel become the new default—
appearing in any new Icon Views opened. However, the settings labeled “Global
Settings” (Dynamic Help, Pathfinder, and Open in Place) apply to any currently open
Icon Views as well.

The Icon View preferences panel allows you to control the following features:

Shelf Displays a new area of the Icon View window. The shelf is a place for
you to put icons that you need to use frequently while working in a
particular directory. For example, if the directory contains many files,
you might want to place the files you use most frequently on the shelf.
Or, if the directory contains many color Showcase slides, you might
want to place the icon for a color printer onto the shelf. See “Using a
Shelf for Convenient Icon Access” for instructions.

Content Viewer
Displays a new area of the Icon View window. When you select a file
icon in the window, the Content Viewer displays a read-only version of
a selected file. This allows you to quickly view file contents without
opening the file.

Search/Filter Files
Displays a new set of controls in the Icon View window. Use it to search
for certain file characteristics and to limit the number of icons you see in
the Icon View window. For example, to display only files that begin with
“d,” type d. To display only files that end in “. r gb,” type *. r gb.
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Dynamic Help Dynamic help is information that appears at the bottom of an Icon View

Pathfinder

Open in Place

window when you move your mouse cursor across items in the window.

The region across the top of an Icon View, which displays the pathname
of the current directory.

Causes any folder you open from an Icon View to appear within that
Icon View, instead of being launched as another window.

Preserve Layout When Opening in Place

Sort by

View as

Preserve Layout causes folders opened “in place” to maintain the Icon
View settings of the Icon View from which they are opened.

Use this menu to choose the way icons are sorted, or arranged, in the
window.

Use this menu to choose the way icons are displayed in the window.

Truncated Names

Shortens the filename labels on icons. Useful for creating more room in
the Icon View window. Does not alter the actual name of the file.

Thumbnail Images

Align to Grid

Hidden Files

When there are image icons in an Icon View window, this command
displays mini-views of each image (instead of the generic icons).

Causes icons to automatically align with an invisible grid when they
appear or are placed somewhere—this helps them display in an orderly
manner.

Displays hidden files. Many IRIX configuration files are hidden by
default. You do not see them in an Icon View window. These files are
commonly called dot files because a “.” appears as the first character in
the filename. Your . | ogi n and . cshr c files are examples of hidden

files.

Default Icon Size Thumbwheel

Allows you adjust the size the icons that appear in Icon Views. To return
icons to the factory default size, click the small square to the right of the
thumbwheel.

Note: If you want to change the default size of icons on the desktop
background, use the Desktop Settings Panel. To open the panel from the
Toolchest, choose Desktop > Customize > Desktop.
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Shortcut: The keyboard shortcut for temporarily applying the Open in Place behavior to
a directory is to hold down the Alt key while double-clicking the directory (folder) icon.

Changing Window Color Schemes

You can use the Color Scheme Browser to change the color scheme of windows on your
screen. You can also edit the colors in a chosen scheme and save the changes.

For more information, see:

¢ “The Color Scheme Browser: An Overview”

¢ “Choosing a Color Scheme”

¢ “Editing a Color Scheme”

¢ “Deleting a Color Scheme”

* “About the Color Scheme Sample Images”

¢ “Using the Color Browser”

The Color Scheme Browser: An Overview

Each item in a window has a color assigned to it. These items, when combined, create a
scheme of colors that make the window easy to read, understand, and look at. The Color
Scheme Browser contains a number of preset color schemes that you can apply. It also
allows you to edit colors in a scheme and create your own combination of colors.

To open the Color Scheme Browser, click the words Color Scheme Browser now, or
choose “Color Schemes” from the Customize menu in the Desktop toolchest.

Choosing a Color Scheme
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You can choose a different color scheme for windows on your screen by using the Color
Scheme Browser. If you have not already opened the browser, open it by clicking the
words Color Scheme Browser, or by choosing “Color Schemes” from the Customize
menu in the Desktop toolchest.
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Editing a Color Scheme
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To choose a color scheme:

1.

Browse through the schemes by clicking on different names in the color schemes
list.

The display to the right of the schemes list shows you a sample image of the chosen
color scheme.

Click the Apply button when you find a scheme you like.

A message appears telling you that the new scheme will not affect existing open
applications. To use the new schemes, restart those applications.

Choose “Exit” from the Application menu to close the Color Scheme Browser
window.

If you want to use a particular color scheme in the Color Scheme Browser, but do not like
one of the colors in the scheme, you can use Edit Mode to change the color.

If you have not already opened the Color Scheme Browser, open it by clicking the words
Color Scheme Browser, or by choosing “Color Schemes” from the Customize menu in the
Desktop toolchest.

To edit a color scheme:

1.

Click on the name of the scheme you want to edit.

The display to the right of the schemes list changes to show the sample scheme.
Choose “Edit Mode” from the Application menu.

A thumbwheel and color palette appear at the bottom of the sample scheme.

Use Quick Help to familiarize yourself with the assignment of each color in the
color scheme.

e Choose “Quick Help” from the Help menu in the Color Scheme Browser
window.

e Move your mouse cursor over a colored square in the Color Palette. The
assignment of that color appears next to the mouse cursor and in a status
message at the bottom of the Color Scheme Browser window.
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Move your mouse cursor on top of a section of the scheme display to geta
description of that section.

Click the left mouse button to deactivate Quick Help.

Edit the color you want to change.

Click on the square of color in the Color Palette that you want to change.
The Scheme Editor Color Browser appears.

Move your mouse cursor on top of the small circle in the colored hexagon in the
Scheme Editor window.

Press down on the left mouse button, and move your mouse.

As you move your mouse around the hexagon, the color beneath the small
circle appears in the rectangle next to the “Current Color” label. This rectangle
acts as your color palette while you choose a new color.

Release the mouse button when the small circle is on top of a color you like.

Move the slider bar next to “Value” back and forth to brighten or darken the
color.

The color in the sample scheme changes as you alter the color in the editor.

When you find a color you like, click the Ok button to close the Scheme Editor
window.

Move the thumbwheel back and forth to darken or lighten all colors in the scheme.

Save the changes.

Click the Apply button in the main Color Scheme Browser window if you want
to save the changes to the same scheme name.

A message appears telling you that the new scheme was saved in your local
scheme directory, and the scheme name changes to an italic font to show that
the scheme was altered.

If you want to rename the scheme, choose “Save As...” from the Application
menu instead of clicking the Apply button. Then create a name for the altered
scheme. The new scheme appears in the schemes list.

Changes affect your user account only and do not affect color schemes used by
other users on your system.

Choose “Exit” from the Application menu to close the Color Scheme Browser
window.
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You can also change additional colors used in a particular scheme by choosing
“Additional Colors” from the Sample Image menu. A sample display appears showing
any additional colors and assignments for those colors.

Deleting a Color Scheme

If you altered a color scheme and saved it to the current scheme name, the scheme name
shows up in italic font to show that it was altered. You can delete the changes you made
and return to the original scheme by using “Remove Selected Scheme” in the Color
Scheme Browser.

If you have not already opened the Color Scheme Browser, open it by clicking the words
Color Scheme Browser, or by choosing “Color Schemes” from the Customize menu in the
Desktop toolchest.

To delete a color scheme:

1. Select the scheme that contains the changes you want to delete.

2. Choose “Remove Selected Scheme” from the Applications menu.

A notifier appears telling you that the local scheme (the scheme that contains the
changes you made) will be removed from your system. Click the OK button to
continue.

The scheme reverts to the default colors for that scheme, and the scheme name
appears in regular text.

3. Choose “Exit” from the Application menu to close the Color Scheme Browser

window.

To delete all changed schemes at once and return all schemes to their default scheme,
choose “Remove Local Schemes” from the Application menu.

About the Color Scheme Sample Images
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Every item in a window is assigned a color. The Color Scheme Browser contains several
sample images that display a scheme’s assigned colors for each of these items. These
sample images include:

¢ “Basic Colors” displays a scheme’s colors for the most frequently used items in a
window, including buttons, scroll bars, and text input areas.
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e “Additional Colors” displays a scheme’s colors for any additional items in a
window, including scrolled list items, accent colors, and errors.

e “Window Manager Colors” displays a scheme’s colors for window borders.

® “Graphics Colors” displays fixed colors that applications assign to specific items
when they want a color to have a consistent and recognizable meaning. These colors
do not change color as schemes change. They merely darken or lighten in color,
depending on the scheme.

e “Active Guides Colors” displays a scheme’s link colors. Links appear in Active
Guides—many of the system management programs you can launch from the
System Manager are Active Guides.

Using the Color Browser

Use the Color Browser when changing colors in the Background Setting or Color Scheme
Browser control panels.

To select a color using the Color Browser:

1. Move your mouse cursor on top of the small circle in the colored hexagon.

2. Press down on the left mouse button, and move your mouse.

As you move your mouse around the hexagon, the color beneath the small circle
appears in the rectangle next to the “Current Color” label. This rectangle acts as
your color palette while you choose a new color.

3. Release the mouse button when the small circle is on top of a color you like.
4. Move the slider bar next to “Value” back and forth to brighten or darken the color.

5. Click the down arrow between the “Current Color” and “Stored Color” rectangles
to store a color you like if you want to browse through other colors.

6. Click the Apply button if you want to see the current color applied to the sample
image in the main control panel.

7. Click the OK button when you decide on a color.

The Color Browser window closes.

If you are choosing a color for your screen background using the Color Browser in the
Background Setting panel, and want a color that blends in well with your current
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window color scheme, try one of the Palette Colors at the top of the Color Browser. Click
on a colored square to choose a color.

You can also create colors by choosing “Value and RGB” or “HSV and RGB” from the
Sliders menu. These menu options reveal sliders that allow you to change the colors by
moving the sliders instead of moving the circle within the hexagon.

Customizing the Screen Saver

By default, your system has a screen saver mechanism that blacks out the monitor screen
when your system is idle for 10 minutes. After another 20 minutes of idle time, the
monitor shuts off to save power. In both cases, you can reactivate the screen by moving
the mouse.

You can customize the screen saver by using the Screen Saver control panel. For details,
see:

* “Choosing a New Screen Saver”

¢ “Locking Your Screen”

¢ “Changing the Screen Saver Activation Delay”

¢ “Adjusting the Power Save Feature”

¢ “Turning On the Screen Saver Without a Delay”

Choosing a New Screen Saver
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Choose a screen saver using the Screen Saver control panel. If you have not already
opened the panel, open it by clicking the words Screen Saver now or by choosing “Screen
Saver” from the Customize menu in the Desktop toolchest.

To choose a screen saver:

1. If the text near the top of the window says, “Screen Saver Off,” click the box to the
left of the text to turn on the screen saver.

A checkmark appears in the box, and the text, “Screen Saver On,” appears.

2. Click on one of the screen saver choices.
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3. Click Demo and keep your mouse still.
The screen blacks out, and the screen saver you chose is activated.
4. Move your mouse to end the demo.

5. If you like this screen saver, click the Close button to close the screen saver window.
Next time your screen blacks out, the screen saver you chose will display on your
screen.

Locking Your Screen

You can lock your screen by using the Screen Saver control panel. If you have not
already opened the control panel, open it by clicking the words Screen Saver now or by
choosing “Screen Saver” from the Customize menu in the Desktop toolchest.

To lock your screen, click the box next to “Lock Screen” in the control panel. A checkmark
appears. Next time your screen saver is activated, and you try to deactivate the screen
saver by moving the mouse, a login screen appears. This login screen requires you to type
in your password (if your account requires one) to return to your work.

This login window also allows you to return to the screen saver. Click the box to the left
of the login name, and the screen saver is activated again. Instead of moving your mouse
to deactivate the screen saver, you must click the left mouse button to return to the login
screen.

If you do not want the login screen to come up when you deactivate the screen saver,
click the box to the left of “Lock Screen” to remove the checkmark.

Note: You cannot choose the “Lock Screen” mechanism when using a Graphics Library
screensaver. When you choose a Graphics Library screensaver, a message appears in the
control panel telling you that screen locking is unavailable for that screen saver.

Changing the Screen Saver Activation Delay

By default, if your screen is idle for 10 minutes, it will black out. You can change the
period of time you want the idle screen to stay visible before the screen saver is activated
using the Screen Saver control panel.
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If you have not already opened the control panel, open it by clicking the words Screen
Saver now or by choosing “Screen Saver” from the Customize menu in the Desktop
toolchest.

To change the activation delay:

1. Slide the bar next to “Delay (minutes)” forward or backward to select the number of
minutes you want.

2. Click the Close button to close the control panel.

Adjusting the Power Save Feature

By default, the monitor shuts off when the system is idle for 30 minutes. The screen saver
activates after 10 minutes of idle time. The power saver activates after 20 additional
minutes of idle time. You can turn the power saver off, or you can adjust the amount of
minutes it takes for the monitor to shut off.

To turn the power saver off, click the box next to “Power Saver On.” A checkmark
appears in the box, and the power saver feature is turned off. To reactivate the power
saver, click the box again. The checkmark disappears.

To adjust the amount of minutes it takes for the monitor to shut off, move the slider next
to “Power Saver On” until you select the minutes you want. The slider allows you to
choose anywhere from 1 to 90 minutes.

Note: Some systems may not support this feature.

Turning On the Screen Saver Without a Delay
You can switch the screen saver on without delay by selecting “Start Screensaver” from

the Desktop toolchest. You may want to do this if you have the “lock screen” mechanism
turned on and want to activate it immediately rather than wait for the 10 minute delay.
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Customizing Mouse Settings

Adjusting the Mouse

007-1342-170

You can customize the acceleration and button-click speed of your mouse. If you are
left-handed, you can switch the button behavior of the mouse so you can use the mouse
with your left hand. For details, see:

¢ “Adjusting the Mouse Cursor Acceleration”
* “Switching the Mouse for Left-Handed Use”
* “Adjusting the Mouse Click Speed”

Related Topic: “Customizing for Accessibility”

Cursor Acceleration

Mouse cursor acceleration refers to how quickly the cursor moves on your screen when
you move the mouse. By default, the mouse cursor acceleration is set to slow. You can
increase the acceleration using the Mouse Settings control panel.

You can also change the threshold. The threshold is the amount of units your mouse
needs to move before the pointer starts to move. If you set a high threshold, the pointer
will move more quickly as you move the mouse. If you set a low threshold, the mouse
will need to move further before the pointer will move.

If you have not already opened the Mouse Settings control panel, open it by clicking the
word Mouse now, or by choosing “Mouse” from the Customize menu in the Desktop
toolchest.

To adjust the acceleration of the mouse cursor and to adjust the threshold:

1. Click on one of the diamond-shaped buttons under “Mouse Acceleration.”

The buttons to the left slow down the acceleration; the buttons to the right speed up
the acceleration.

You can also adjust the acceleration by clicking the button below “Finer Control”
and sliding the bar next to “Acceleration” back and forth.

2. To change the threshold level, click the button below “Finer Control,” and move the
sliding bar next to “Threshold” back and forth.
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3. Move the mouse around and watch the pointer move on your screen.

Continue to click on diamonds or move the sliders until you have reached the
desired acceleration and threshold levels.

4. Click the Close button to close the control panel.

Switching the Mouse for Left-Handed Use

You can switch the button behavior of the mouse so you can use the mouse with your left
hand by using the Mouse Settings control panel. If you have not already opened the
panel, open it by clicking the word Mouse now, or by choosing “Mouse” from the
Customize menu in the Desktop toolchest.

To switch the button behavior of the mouse for left-handed use, click the
diamond-shaped button next to the “Left handed” label.

The button behavior switches so that tasks normally performed with the left mouse
button can now be performed with the right mouse button.

Adjusting the Mouse Click Speed
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By default, the mouse click speed is set to a midrange level. This means that you can
double-click a mouse button at a reasonable speed, and the action will be performed. If
you would like the mouse to respond to a slower or a faster click speed, you can adjust
the speed using the Mouse Settings control panel.

If you have not already opened the panel, open it by clicking the word Mouse now, or by
choosing “Mouse” from the Customize menu in the Desktop toolchest.
To adjust the click speed of the mouse:

1. Click one of the diamond-shaped buttons below “Click Speed” in the lower half of
the control panel.

* Click the button below “Slow” to slow down the click speed.
® Click the button below “Fast” to speed up the click speed.

* Click the button between the slow and fast buttons if you want a midrange
click-speed (this is the default).
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* C(Click the button below “Finer Control” to display a sliding bar. Adjust the
speed by sliding the bar back and forth.

2. Test the click speed by double-clicking on the button labeled, “Click Here!”

If you chose a fast click-speed, you will need to double-click the mouse button very
quickly to test it. If you chose a slow click-speed, you should be able to double-click
at a fairly slow rate.

3. Click the Close button to close the control panel.
Any application you start up after you make the change uses the new click speed. Restart

other applications if you want them to use the new click speed, or log out, then log back
in to use the new click speed on the desktop.

Customizing Keyboard Settings

This section includes:

* “Customizing for Accessibility”

¢ “Adjusting Key-Repeat Speed and Delay”
¢ “Turning On Key Click”

Related Topic: “Changing the Language and Keyboard Layout”

Customizing for Accessibility
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Movement-impaired users can customize the keyboard to meet their needs and
preferences by using the Accessibility Panel. Launch this panel from the Toolchest by
choosing Desktop > Customize > Accessibility. Click the Accessibility Panel Help button
for details.

Note: If you cannot bring the Accessibility Panel up from Customize menu, you
probably need to install it. Install the accessx product from the IRIX Applications CD.
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Environment

Turning On Key Click

Key click is a clicking sound you can choose to hear when you type on your keyboard.
Your system ships with the key click turned off.

You can turn key click on or off using the Keyboard Settings control panel. If you have
not already opened the panel, open it by clicking the word Keyboard now, or by choosing
“Keyboard” from the Customize menu in the Desktop toolchest.
To turn on the key click:
1. Click the button next to “Key Click.” A checkmark appears in the box.

When you type on the keyboard, you will hear the key-click sound.
2. Click the Close button to close the control panel.

To turn key click off, click the box to the left of the “Key Click” label. The checkmark
disappears.

You can also use the System and Desktop Sounds panel to turn key click on or off.

Adjusting Key-Repeat Speed and Delay
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The key-repeat speed is the rate at which a keyboard character is repeatedly printed to
your screen when you hold down a key. Key repeat delay is the amount of time the
system waits before beginning the repeat sequence.

You can adjust the key repeat speed and delay using the Keyboard Settings control panel.
If you have not already opened the panel, open it by clicking the word Keyboard now, or
by choosing “Keyboard” from the Customize menu in the Desktop toolchest.

Note: Key repeat sequences are often used when you want to use the Backspace key to
delete a series of characters, or when you want to add multiple spaces using the Space
Bar. Changing the key repeat speed also affects these keys.
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To adjust the key-repeat speed and delay:

1. Click one of the diamond-shaped buttons to adjust the key repeat speed and delay:
¢ Click the button below “Slow” to slow down the repeat speed.
® Click the button below “Fast” to increase the repeat speed.

¢ (lick the button between the slow and fast buttons if you want a midrange
repeat-speed (this is the default).

¢ Click the button below Finer Control to display two sliding bars. Adjust the
repeat speed and delay by sliding the bars back and forth. Move the slider next
to “Repeat Delay” to the left to lengthen the repeat delay. Move it to the right to
shorten the repeat delay.

2. Test the speed and delay by clicking in the text input box next to “Test” and pressing
down on a key on the keyboard.

3. Click the Close button to close the control panel.

Customizing Window Settings

The Window Settings control panel lets you customize window attributes. For details,
see:

* “Changing the Orientation of the Toolchests”

¢ “Changing the Window Focus Behavior”

¢ “Displaying the Windows Overview”

* “Changing the Appearance of a Moving Window”
¢ “Turning On Automatic Window Placement”

* “Saving Your Desktop Layout”
Changing the Orientation of the Toolchests

The toolchests display vertically in the upper left corner of your screen. You can set them
to display horizontally by using the Window Settings control panel.
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If the Window Settings control panel is not already open on your screen, open it by
clicking the word Windows now, or by choosing “Windows” from the Customize menu
in the Desktop toolchest.

To change the orientation of the toolchests:

1. Click the button next to “Horizontal.”

A small marker appears on the button to let you know it is activated, and the
toolchest changes orientation.

A window appears, asking you if you want to restart the window manager.

2. Click OK or Cancel.

e If you click OK, all the windows you currently have open will redraw, and the
Windows Overview appears on your desktop. All the minimized windows for
all desks appear in the Windows Overview.

e If you click Cancel, the Windows Overview will not appear until you log out and
log back in to your system.

3. Click the Close button to close the control panel.

Click the button next to “Vertical” to switch the toolchests back to their original position.

Changing the Window Focus Behavior

By default, you need to move your mouse cursor into a window in order to type in it.
This is called implicit focus or “point to type.” You can change the focus behavior to
explicit focus or “click to type” using the Window Settings Control Panel.

If the Window Settings control panel is not already open on your screen, open it by
clicking the word Windows now, or by choosing “Windows” from the Customize menu
in the Desktop toolchest.
To change the keyboard focus behavior:
1. Next to “Keyboard Focus:”

¢ C(Click the button next to “Point to type” to select implicit focus.

e C(lick the button next to “Click to type” to select explicit focus.
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Selecting “Click to type” means that you give a window focus by clicking on it.
The window continues to have focus until you click on another window,
regardless of the location of the cursor.

A checkmark appears to let you know it is activated, and a window appears, telling
you that the window manager will need to be restarted in order for the change to
take affect.

2. Click OK or Cancel.

e If you click OK, all the windows you currently have open will redraw, and the
keyboard focus behavior changes.

3. Click the Close button to close the Window Settings panel.

Displaying the Windows Overview
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By default, all minimized windows appear individually on your desktop. If you have
Windows Overview turned on, all minimized windows are grouped together and appear
in a window on your desktop. You will also see a borderless, minimized window for
every window open on your desk.

When you use multiple desks, the Windows Overview will appear on all desks. All
minimized windows on all desks will appear in the Windows Overview. You will also
see a borderless minimized window for every window open on every desk.

You can turn Windows Overview on or off using the Window Settings control panel. If
the panel is not already open on your screen, open it by clicking the word Windows now,
or by choosing “Windows” from the Customize menu in the Desktop toolchest.

To turn on Windows Overview:

1. Click the button next to “Display Windows Overview.”

A checkmark appears to let you know it is activated, and a window appears, telling
you that the window manager will need to be restarted in order for the change to
take affect.

2. Click OK or Cancel.

e If you click OK, all the windows you currently have open will redraw, and the
Windows Overview appears on your desktop. All the minimized windows for
all desks appear in the Windows Overview.

143



11: Customizing the Desktop Environment

e If you click Cancel, the Windows Overview will not appear until you log out and
log back in to your system.

3. Click the Close button to close the control panel.

To turn off Windows Overview, click the button next to “Display Windows Overview”
in the Window Settings control panel.

Changing the Appearance of a Moving Window

While you move a window, the window appears as a red outline. If you want, you can
change the look of the moving window from a red outline to an opaque image of the
window using the Window Settings control panel.

If the control panel is not already open on your screen, open it by clicking the word
Windows now, or by choosing “Windows” from the Customize menu in the Desktop
toolchest.
To change the appearance of a moving window:
1. Click the button next to “Opaque Window Move.”

A checkmark appears to let you know it is activated.
2. Click the Close button to close the control panel.

To turn off the opaque window setting, click the button next to “Opaque Window Move.”
The checkmark disappears.

Turning On Automatic Window Placement
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By default, you can place windows anywhere on your screen when you open them. You
can change this behavior so that windows are automatically placed in preset locations on
your screen when you open them. Do this by using the Window Settings control panel.

If the control panel is not already open on your screen, open it by clicking the word

Windows now, or by choosing “Windows” from the Customize menu in the Desktop
toolchest.
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To turn on automatic window placement:

1.

2.

Click the button next to “Auto Window Placement.”
A checkmark appears.
Click the Close button to close the control panel.

Some applications may allow you to set preferences for window placement. These
preferences will override the global settings. See your application documentation for
information on setting window placement for that application.

Saving Your Desktop Layout

The system keeps track of the windows that are open and their location on the screen.
Every time you log in, the system checks the list of windows to determine which ones it
should open automatically. It can do one of two things:

Automatically open the windows that were on your screen when you logged out.
This is the default behavior. See “Automatically Saving the Desktop Layout” for
more details.

Ignore the windows that were open when you logged out. Always open a particular
set of windows that you have chosen. See “Automatically Opening a Specific Set of
Windows” for instructions.

Automatically Saving the Desktop Layout
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By default, the system opens the windows that were on your screen when you logged
out. For example, suppose that you log out while your screen displays a clock, a calendar,
and a nedi t window in which you are editing a text file. When you log into the system
again, the clock, calendar, and nedi t windows automatically reappear.

If you change the setting and want to revert to the default behavior, use the Window
Settings control panel.

1.

If the control panel is not already open on your screen, open it by clicking the word
Windows now, or by choosing “Windows” from the Customize menu in the
Desktop toolchest.

Click the button next to the label Continuously.

Click the Close button to close the window.
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Note: Some applications will not automatically open when you log in. See “Running
Applications When You Log In Using the .sgisession File” for information on how to run
these applications.

Automatically Opening a Specific Set of Windows

By default, the system opens the windows that were on your screen when you logged
out. You can change this behavior so the system opens a specific set of windows.

1. Create the screen layout that you want to see each time you log in (open windows
and position them on the screen).

2. If the control panel is not already open on your screen, open it by clicking the word
Windows now, or by choosing Desktop > Customize >Windows from the Toolchest.

Click Explicitly. It appears under the label Save Windows & Desks.
4. Click the Set Home Session button.
5. Click the Close button to close the window.

Note: If you create new desks, you must open the Window Settings control panel and
click the Set Home Session button again. Otherwise, when you log out or restart the
window manager, you will lose the new desks that you have created.

Some applications will not automatically open when you log in. See “Running
Applications When You Log In Using the .sgisession File” for information on how to run
these applications.

Changing the Language and Keyboard Layout
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U.S. English is the default language for the system. You can choose another language and
a corresponding keyboard key layout, as well as a time zone, using the Language
Controls panel.

If the Language Controls panel is not already open on your screen, open it from the
Toolchest by choosing Desktop > Customize > Language.
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Click the Country button to select the country in which you are working. The system then
guesses which language, keyboard layout, and time zone are appropriate. However, you
can change any of these choices by clicking the Language, Keyboard Layout, or Time Zone

buttons.

Once you have made your choices, you can either apply them to entire system or to your
own user account. To apply them to the entire system click the Set System button, to apply
them only to your own account, click the Set Personal button.

Any internationalized application you start up after you make the change uses the new
language and keyboard layout. Restart other applications if you want them to use the
new language and keyboard layout, or log out, then log back in to use the new language
and keyboard layout on the desktop.

Controlling System Alerts

System alerts are messages that notify you when a system error has occurred. By default,
system alert messages are accompanied by a “beep” sound.

If the System Alert Settings control panel is not open, start it by choosing Desktop >
Customize > System Alerts from the Toolchest.

Use the Alert Settings control panel to do any of the following;:

¢ To turn on all system alerts, click Enabled

¢ To turn off all system alerts, click Disabled

¢ To turn off all system alerts for this login session only, click Disabled for this session
e To turn off all system alert sounds, click to remove the checkmark in front of the

label, Sound Effects

To turn specific system alerts on or off, click Disabled Alerts... button.

Customizing Desktop Settings

The Desktop Settings Panel lets you customize various desktop characteristics. To open
the Desktop Settings Panel from the Toolchest, choose Customize > Desktop.
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For details, see:

“Changing the Default Size of Icons on the Desktop”
“Turning Icon Alignment On or Off”

“Controlling System Sounds”

“Changing Default Viewer and Editor Utilities”
“Changing Default Permission Settings”

“Viewing Image Icons as Thumbnail Images”
“Turning Off the Launch Effect”

“Making “Remove” Delete Instantly”

“Turning File Overwrite Messages On and Oft”
“Displaying Application Errors”

“Enabling or Disabling the Ability to Display Remote Applications”

Changing the Default Size of Icons on the Desktop
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You can change the default size of icons on the desktop, using the Desktop Settings Panel.

To change the default size of icons on the desktop:

1.

Slide the wheel below “Background Icon Size” back and forth.
e Place your cursor on top of the wheel.

® Press down on the left mouse button and move the cursor to the left and right to
move the wheel.

The icon to the right of the wheel changes size.

When you are satisfied with the icon size, click the Close button to close the control
panel.

The icons appear in the new size.

To return icons to the default size, click the small box on the right side of the wheel.
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Turning Icon Alignment On or Off

By default, icons on the background align with an invisible grid when moved—this helps
them display in an orderly manner. This feature is called “Align to Grid.” If you want to
turn this feature off, use the Desktop Settings Panel.

If the control panel is not already open on your screen, open it by clicking the word
Desktop now or by choosing “Desktop” from the Customize menu in the Desktop
toolchest.

To turn off align to grid, remove the check mark in the Align to Grid check box by clicking
it.

Controlling System Sounds
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Your system ships with desktop sounds turned on by default. You hear sounds for
different actions you perform, such as double-clicking an icon, or emptying the
dumpster. You can turn these and other sounds on or off by using the System and
Desktop Sounds panel.

Note: You will not be able to control system sounds if someone has turned off the
soundscheme daemon on your system. You can turn soundscheme back on by entering
commands in a UNIX shell:

% su
# chkconfig -f soundschene on

Confirm that soundscheme is on by entering chkconfig in the shell. The word “on”
should appear next to “soundscheme” in the list that appears.

To open this panel from the Desktop Settings Panel, click the Sounds... button. To open it
from the Toolchest, choose Desktop > Customize > Sounds. Elements of the panel are
explained below. Click the checkboxes on the System and Desktop Sounds panel to
enable or disable sounds. If the sound is enabled, a checkmark appears in the box.

Master Volume Control:

Mute System  Turns all system sounds on or off.
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Enable Selected Sounds:

Startup & Shutdown Tunes
Turns on or off the music that occurs at system start up and shutdown.

Desktop Sounds
Turns on or off the various sounds made by the desktop, such as the
sounds that occur when dragging or removing a file.

System Alert Sounds
Turns on or off all system alert sounds, such as sounds that occur when
there is a system error. (To turn on or off specific system alerts, choose
Desktop > Customize > System Alerts from the Toolchest.)

Keyboard Bell Turns on or off the keyboard error beep.
Key Click Turns on or off a special typing click sound.

Play Desktop Sounds Through:

Use the Play Desktop Sounds Through menu button to tell your system where to send the
desktop sounds. By default, desktop sounds play through the system’s built-in speaker,
headphones, and primary line-out jacks (all at once). When you plug headphones into
the headphone jack, the system automatically mutes the speakers.

Some systems provide additional output ports on the back of the system. You can use the
Play Desktop Sounds Through menu button to direct the desktop sounds to play through
the default ports or through one of these alternate ports. This can be useful if you want
to record to a digital tape deck through your system’s digital output ports, but you want
desktop sounds to play through the analog output so that they do not interfere with the
recording.

This menu button only affects desktop sounds. It does not, for example, determine the
output of your built-in CD Player.

Note: Desktop sounds turn off immediately for some applications. For other
applications, you must log out and log back in before the sound turns off.
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Note: Control the volume of all system sounds by moving the Audio Panel volume
sliders. To open the Audio Panel from the Toolchest, choose Desktop > Control Audio.
Also, some systems have volume control buttons on the front of the workstation.

Changing Default Viewer and Editor Utilities

Your system ships with default viewers and editor utilities set. You can change these
default utilities by using the Default Viewer and Editor Utilities control panel.

To open this panel from the Desktop Settings Panel click the Utilities... button. To open it
from the Toolchest, choose Desktop > Customize > Utilities.
To change a default viewer or editor utility:

1. Move the cursor on top of the button next to the utility you want to change and
press the left mouse button.

A menu appears.
2. Move your cursor on top of the choice you want, then release the mouse button.

If you want to use a text editor that is not listed in the Text Editor menu, choose
“Other...” Then type in the name of the editor you want to use.

3. Click the Close button to close the panel.

Changing Default Permission Settings
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Whenever you create a new file default permissions are placed on the file. These default
permissions allow you, the owner, to read, write and execute the file. They also allow the
group and others to read and execute, but not to make changes to the file.

To open this window from the Deskop Settings Panel, click the Permissions... button.

These settings affect only files and directories that you create using the desktop tools.
They do not affect files and directories that you create in a shell window.
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To change the default file permission settings:
1. Click the Permissions button.
The Default File Permissions form appears.

2. Click the buttons below Read, Write, and Exec to set the default permissions for
each user.

A button is activated when a checkmark appears on the button.

3. Click OK to set the permissions. Click Cancel if you do not want to change the
permissions.

4. Click the Close button to close the Desktop Settings panel.

For more information on permissions, see “Understanding and Changing Permissions.”

Viewing Image Icons as Thumbnail Images

If you have image file icons out on the desktop, you can view the icons as small
thumbnails of the images by using the Desktop Settings Panel.

If the control panel is not already open on your screen, open it by clicking the word
Desktop now or by choosing “Desktop” from the Customize menu in the Desktop
toolchest.

To preview image file icons on the desktop:

1. Click the button next to “Show Icons as Thumbnail Images.”

A checkmark appears in the box and the icons on the desktop redraw and
thumbnails of the images appear.

2. Click the Close button to close the panel.

Turning Off the Launch Effect

When you start up an application, you see a visual effect that lets you know that the
application is starting up. The effect stops when the application opens. The launch effect
is turned on by default. You can turn it off using the Desktop Settings Panel.
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If the control panel is not already open on your screen, open it by clicking the word
Desktop now or by choosing “Desktop” from the Customize menu in the Desktop
toolchest.
To turn off the launch effect:
1. Click the button next to “Show Launch Effect.”
The checkmark disappears.
2. Click the Close button to close the panel.
Now when you start up an application, you will not see the launch effect. To turn the

launch effect back on, click the button next to “Show Launch Effect.” A checkmark
appears.

Making “Remove” Delete Instantly
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By default, when you choose “Remove” from the Selected menu, the files are moved into
the dumpster. These files are stored in the dumpster until you decide to delete them
permanently from your system by emptying the dumpster.

If you want files to be removed from your system immediately rather than moving them
into the dumpster, you can disable the dumpster. When you disable the dumpster, it
becomes an ordinary directory called “dumpster.” Now when you choose “Remove”
from the Selected menu to remove selected files, these files are deleted from your system
immediately.

Use the Desktop Settings Panel to disable the dumpster. If the control panel is not already
open on your screen, open it by clicking the word Desktop now or by choosing
“Desktop” from the Customize menu in the Desktop toolchest.
To make “Remove” delete instantly:
1. Click the checkbox next to “Make ‘Remove’ Delete Instantly.”

A checkmark appears in the box.
2. Click the Close button to close the panel.
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Turning File Overwrite Messages On and Off

By default, when you attempt to overwrite a file, a notifier pops up and asks you if you
really want to overwrite the file. If you do not want this notifier to come up, you can turn
it off by using the Desktop Settings Panel.

If the control panel is not already open on your screen, open it by clicking the word
Desktop now or by choosing “Desktop” from the Customize menu in the Desktop
toolchest.
To turn off the overwrite file notifier:
1. Click the button next to “Warn on File Overwrite.”

The checkmark disappears.
2. Click the Close button to close the control panel.

To turn on the overwrite file notifier, click the button next to “Warn on File Overwrite.”
The checkmark reappears.

Displaying Application Errors
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You can use the Desktop Settings Panel to turn on a status window that displays
application errors. If the control panel is not already open on your screen, open it by
clicking the word Desktop now or by choosing “Desktop” from the Customize menu in
the Desktop toolchest.
To turn on the status window:
1. Click the button next to “Display Application Errors.”

A checkmark appears.
2. Click the Close button to close the control panel.

Next time an error is generated by an application, the status window appears on your
screen, and the error message appears in the window.

To turn off the status window;, click the button next to “Display Application Errors.” You
must log out, then log back in, to disable the status window.
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Enabling or Disabling the Ability to Display Remote Applications

You can use the Desktop Settings Panel to enable or disable the ability to run applications
on remote systems by displaying them on your screen.

If the control panel is not already open on your screen, open it by clicking the word
Desktop now or by choosing “Desktop” from the Customize menu in the Desktop
toolchest.

To enable or disable remote display:

1. Click the toggle button next to “Enable Remote Display” to turn remote display on
or off.

A checkmark indicates Enable Remote Display is turned on.
2. Click the Close button to close the control panel.

There are a few different ways to control the remote display. For complete details, see
“About the Remote Display Feature.”

Disabling Icons on the Desktop
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By default, certain icons appear on your desktop. If you prefer not to have icons appear
on your desktop, you can disable this function by creating a file called nodeskt op in
your . deskt op_<host nanme> directory.

To do this:

1. Open an Icon View window of your home directory by choosing “Home Directory”
from the Desktop toolchest.

2. Double-click the . deskt op_<host name> directory to open it.

The . deskt op_<host name> directory is a “hidden” file. If it is not visible in your
home directory, choose “Hidden Files” from the View menu in the Icon View.

3. Create an empty file using your text editor, name it nodeskt op, and place it in the
. deskt op_<host name> directory.

4. Log out, then log back in.

Icons no longer appear on your desktop.

155



11: Customizing the Desktop Environment

If you want the standard icons to return to the desktop, delete the nodeskt op file. Log
out, then log back in. Icons appear on your desktop.

Adding Directories to Your Search Path (Advanced)
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When you use File QuickFind to search for an icon, or you search for or start applications
from a shell window, the software searches through a series of directories to find the file
or application. The series of directories it searches is called your path. If you add useful
directories to your path, such as various directories that contain applications, you can use
File QuickFind to bring up other files or applications in addition to those located in your
home directory.

You can add directories to your path by editing the . cshr c file.

1.

Open your home directory by choosing “Home Directory” from the Desktop
toolchest.

Select “Hidden files” from the View menu.
A list of all the hidden files appears in the Icon View.
Open the .cshr c file.

The . cshr c file is in your home directory. You can bring up the . cshr c file by
using File QuickFind.

Locate the line that begins with the text below, or create it if the line does not exist.
set path = ($path

After “$path,” type the names of the directories that you want to add. Be sure to
leave a blank space between directory names and end the list of directory names
with a closing parenthesis.

For example, the whole line might look like this:

set path = ($path /usr/local/bin /usr/peoplel/joe)
Save the file and exit the text editor.
To make the system recognize the new path setting, do one of the following:

® Place the cursor in the shell window; then type:

source .cshrc

* Logout and log back in again.
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Running Applications When You Log In Using the .sgisession File

You can use the Window Settings control panel to save your desktop layout and have
certain applications open automatically when you log in (see “Saving Your Desktop
Layout”). Some third-party applications, however, may not be recognized by these
settings. If you want these applications to start up automatically when you log in, you
can create a file in your home directory called . sgi sessi on.

To create a . sgi sessi on file:
1. Open a shell by choosing “Open Unix Shell” from the Desktop toolchest.
2. Create the .sgi sessi on file.

e Place the cursor in the shell window.

* Type cd to move to your home directory. This is where system startup files such
as .sgi sessi on are stored.

¢ Run a text editor and create the .sgi sessi on file. For example, type:
nedit .sgisession

3. Type startup information for applications you want to start up when you log in. For
example, if you want to start up an application called “fun,” and the application is
stored in the / usr/ sbi n directory, create a line in the file like this:

/usr/sbin/fun

If you want to add another application, create a new line, and add the startup
information for that application.

4. Save and close the file.

Next time you log out and log back in, the system will read your . sgi sessi on file and
will start up the applications you specified.

Modifying the Toolchests (Advanced)
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A file called syst em chestr ¢ exists in your / usr/ | i b/ X11 directory. This file
determines the system-wide settings for the toolchests. You can add toolchests and
toolchest menu items to your account by creating a file called . auxchest r ¢ in your
home directory. This file adds the items you specify to all the items already specified in the
system chestrc file.
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If you want to customize the toolchests more extensively by adding, deleting, and
renaming items, copy the syst em chest r ¢ file into your home directory and rename
it . chestr c. Then edit this file. The . chest r c file replaces the function of the

syst em chest r ¢ file for your user account only.

Note: The syst em chest r c file allows dynamic menu items in the toolchests. These
items appear and disappear depending on which desktop item is selected. When you
create a. chest r c file, these dynamic abilities become disabled.

Understanding the system.chestrc File
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The syst em chest r ¢ file contains all the toolchest headings and toolchest menu items
that appear on your desktop.

Open the syst emchest r ¢ file in your/ usr/ | i b/ X11 directory. At the top of the file,
you see some lines similar to these:

Menu Tool Chest

{

"Desktop" f.nenu Desktop
no- | abel f.separator
"Sel ected" f.nenu Sel ected
no- | abel f.separator

" Fi nd" f. menu Find
no- | abel f.separator
“Syst ent f.menu System
no- | abel f.separat or
“Hel p” f.menu Hel p

}

This defines the toolchests. The left side lists the names of the toolchests. Notice that the
names are enclosed in quotes. The right side describes what happens when you choose
a particular item. For example, when you choose the Desktop toolchest, you post the
Desktop toolchest menu.

Every other line in this section reads:

no- | abel f.separator

This draws the line that separates one toolchest from another.
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Below the definition of the toolchest menu headings, you find sections that describe the
contents of each toolchest. Find the section of the file that looks similar to this:

Menu | nt er net

{
“(pen Wb Browser” f.checkexec.sh.le “/usr/sbin/launchVébJunper”
“Browse Qut Box Page” f. checkexec.sh.le “/usr/Iib/ deskt op/ openhonepg”
no- | abel f. separat or
“lcon Viewof a Vb Site” f.checkexec.sh.le “/usr/sbin/fm-p http://”
“lcon View of an FTP Site” f.checkexec.sh.le “/usr/sbin/fm-p ftp://”
no- | abel f. separat or
“Ceate a VébJunper” f. checkexec. sh. e “/usr/sbi n/ webj unper”
}

This section of the file creates the Internet menu of your Toolchest. The left side lists the
names that appear in the Internet menu. Again, the names are enclosed in quotes and a
separator line divides the menu into several groups. The right side describes what
happens when you choose a particular item. For example, when you choose “Create a
WebJumper,” you start the program webjumper, which opens the WebJumper window.

Adding Toolchests and Toolchest Menu Items Using the .auxchestrc File

To add toolchests and toolchest menu items, create a filenamed . auxchest r ¢ and place
it in your home directory. Enter items in the format used in the syst em chest r c file
located in your / usr/ | i b/ X11 directory. See “Understanding the system.chestrc File”
for information about the syst em chestr c file.
To add toolchests and toolchest menu items by creating a . auxchest r ¢ file:
1. Open a shell window by choosing “Open Unix Shell” from the Desktop toolchest.
2. Create the . auxchestrc file.

¢ Place the cursor in the shell window.

¢ Type cd and hit Ent er to move to your home directory.

e Start the text editor and create the file. For example, type:

nedit .auxchestrc
3. Enter text specifying the toolchest you want to add.

For example, if you wanted to add a new toolchest called “Applications,” you
would enter the following:
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Menu Tool Chest

{

no- | abel f.separator
"Applications" f.menu Applications
}

Enter text specifying the menu items you want to add to that toolchest.

For example, if you wanted to add jot to the Applications toolchest menu, you
would type the following:

Menu Applications
{

}

Save and close the . auxchest r c file.

jot" f.checkexec "/usr/sbin/jot"

Log out, then log back in.

The new toolchest named Applications appears with the toolchests, and the menu
item “jot” appears in the Applications toolchest menu.

Adding, Deleting, and Renaming Toolchests and Toolchest Menu Items Using the .chestrc

File
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If you only want to add toolchests or add menu items to the toolchests, see “Adding
Toolchests and Toolchest Menu Items Using the .auxchestrc File.” If you want to
customize the toolchests more extensively by adding, deleting, and renaming items,
create a. chestr c file:

1.
2.

Open a shell window by choosing “Open Unix Shell” from the Desktop toolchest.

Create a file called . chest r ¢ in your home directory by copying the file
system chestrc from your/ usr /i b/ X11 directory and renaming it. To do
this:

e Place the cursor in the shell window.
* Typecd and hit Ent er to move to your home directory.
e  Type:

cp /usr/lib/X11/systemchestrc .chestrc

then press Ent er.
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It is very important that you begin by copying and renaming this file, because

* Thesystem chestr c file determines the system-wide setting for the
Toolchest window. If you change this file in the / usr /| i b/ X11 directory, your
changes affect everyone who has a login account on the workstation.

¢ Ifyouhavea .chestrc file in your home directory, the system reads this file
instead of syst em chest rc. It is best to add to or delete from a copy of the
original so you do not leave out any essential information.

Note: The syst em chest r c file allows dynamic menu items in the toolchests.
These items appear and disappear depending on which desktop item is selected.
When you create a . chest r ¢ file, these dynamic abilities become disabled.

Edit the . chest r ¢ file by running the text editor. For example, type:
nedit .chestrc

Since this file is a copy of the syst em chest r c file, see “Understanding the
system.chestrc File” for information on how to interpret the file. You can add,
delete, and rename items.

When you are finished, save and close the file.
Log out, then log back in.

The toolchests appear the way you specified in the . chest rc file.

If you want to revert to the default Toolchest window, remove the .chest r ¢ file from
your home directory or name it something other than .chestrc.

Using Your Own Customized Backgrounds (Advanced)
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If you have a custom background that you want to display using bgpast e, you can
display it if you turn off icons on the background and the desktop background tool. See
the bgpaste(1) man page for details.

To display a custom background using bgpast e:
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1. Open an Icon View of your home directory by double-clicking the folder icon on
your desktop, or by choosing “Home Directory” from the Desktop toolchest.

2. Choose “Hidden Files” from the View menu to see the dot files (files that have

“" o

filenames that begin with “.”) in your home directory.

3. Open the directory named . deskt op- <host name> and create a file called
nodeskt op in that directory. This will turn off icons on the background.

4. Place the following line in your . Xdef aul t s or. Xr esour ces file in your home
directory:

4Dwnt SG_useBackgrounds: Fal se

5. Log out then log back in.

When you log back in, the desktop backgrounds and icons on the background are turned
off, and you can generate your own background using bgpast e.

To turn the desktop backgrounds back on, remove the line 4Dwnt SG_useBackgr ounds:

Fal se from your . Xdef aul ts or. Xr esour ces file. To turn icons on the background
back on, delete the nodeskt op file. Log out, then log back in.Turning Off the Desktop
User Environment

You can turn off the desktop user environment for every account on the system by
logging in as root, and typing:

/et c/chkconfig desktop off
in a shell window. When you log out and log back in, your toolchest will not contain any
items specific to the desktop user environment. Also, session management, desks, and

icons on the background will be turned off.

To turn the user environment back on, log in as root and type:

/ et c/ chkconfi g desktop on

in a shell window. Log out, then log back in. The user environment turns back on.
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Using Custom Icons on Your Desktop (Advanced)

You can edit the file/ usr/ 1 i b/ fil et ype/ Makefil e. personal for the following
purposes:
* To replace the icon for a particular program with your own design, or to create

unique icons for one of your own programs and for any data files the program
creates.

Note: In order to use custom icons, you need to have first created the icon, which
you can do with the IconSmith program. For help and advice on icon image design,
please consult the IRIX Interactive Desktop Integration Guide and the IRIX Interactive
User Interface Guidelines, which are online books you can access with InfoSearch, if
you have these books installed. IconSmith may be installed from the “desktop_tools”
product on your IRIX Applications CD. Icon image files must end in “.fti”.

* Toadd menu items to the right-mouse-button menu (or Toolchest Selected menu)
for a specific type of icon.

Note: In order to do this, you need to know how to program your icons to behave
the way you wish them to behave. For help with programming new menu
commands or new mouse-click responses for your icon, please refer to the IRIX
Interactive Desktop Integration Guide, the IRIX Interactive User Interface Guidelines, and
the fftr(1) man page, all of which you can access with InfoSearch.

New icons will appear only in the desktop environment that appears when someone logs
into your login account.

This file is not designed for Silicon Graphics partners or professional application
developers. Their filetypes should instead be installed alongside the system filetypes in
lusr/lib/filetype/install. For full instructions, developers should refer to the
online book IRIX Interactive Desktop Integration Guide, which can be accessed with
InfoSearch.
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Editing the Makefile.personal
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1.

Create the special directory for your personal icons. It must be created in the
following way:

% nkdi r ~/.deskt op- <hostname>/ fi |l et ype/
where <hostname> is the name of your workstation.
In a shell, go to the system filetypes directory:

% cd /usr/lib/filetype

Copy Makefi | e. personal to your new icons directory, and rename it “Makefile”
without the “.personal” suffix:

% cp ./ Mkefil e.personal ~/.desktop- <hostname>/fil etypel/ Makefile

Copy the example .ftr file to your personal filetype directory. The command shown
will copy the file as “mine.ftr”, but you can rename this file as you wish, as long as it
ends with the “.ftr” suffix:

% cp ./sanpl eFtrs/sanple.ftr ~/.desktop- <hostname>/fil etype/ m ne.ftr
Go to the new directory and add write permission on the i ne. ftr file.
% cd ~/ . deskt op- <hostname>/fil et ype/

% chnod u+w mine.ftr

Use your favorite editor (for example, nedit or jot) to define one or more new
filetypes in the file whose name ends with the “.ftr” suffix.

See the mi ne. ftr file’'s comments for instructions on editing it to replace an icon
image or to add menu commands to the right-mouse-button menu of an icon.

(This step is for icon editing only.) Create a directory for your icon images, then go
to that directory:

e 9% nkdir ~/.desktop-<hostname>/fil etypeliconlib/
e Copy your custom icon images to the directory you created for them.

This step compiles your filetypes and icon pictures into an icon database file called
deskt op. ot r. It differs from the system / usr/1i b/fil et ype/ desktop. otr
file in that your personal deskt op. ot r contains only your personal icon
definitions, whereas the system deskt op. ot r contains icon definitions for the
entire system and is applied to all login accounts.

Make sure you are in the filetype directory, then enter the make command:

% cd ~/.deskt op- <hostname>/fil et ype
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% make

Important. Fix any errors that are reported during the “make” process. Common
errors include:

®  Omitting a semicolon at the end of a MATCH rule
¢ Using “=" instead of “=="in a tag MATCH rule

¢ A missing ICON rule or icon picture file

* Typos in the included icon picture’s path

This step is particularly important when you are adding custom icons. If you copy a
filetype from under the / usr /i b/ fi | et ype directory and redefine the icon
image behaviors, then the IRIX Interactive Desktop will use your version instead of
the default system version, so use caution when you copy a filetype. For example,
you can override the system definition for TYPE WebJumpsite with your own icon
picture and behaviors, but if there are any mistakes in your personal version of this
filetype, then all your Webjumper icons will be affected and may appear as generic
text files.

If such a problem occurs, you can immediately restore the default icons by moving
aside your . f tr file that contains the overridden filetype:

%nm mne.ftr mne.ftr.skip
Then rebuild your personal icons database:

% make cl obber; nmke

Tip: To avoid problems, it can be safer to derive a new type from a system type by
copying the filetype and then changing the type name. For example, if you want
some special behavior for your Webjumpers, you can copy and paste the
WebJumpsite filetype from the / usr /i b/ fi | et ype/ syst eml webj unper. ftr
file, change the type name to “MyWebJumpsite,” then add your custom behaviors.

10. In the interest of performance, the IRIX Interactive Desktop does not re-type files if

their type has been determined once before and saved in the TypeCache. To make
the Desktop re-type all files and pick up your newly defined filetypes, you need to
remove the TypeCache:

% cd ~/.deskt op- <host nane>

% rm-r TypeCache

11. Log out and log back in.
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Chapter 12

Opening a Utility

007-1342-170

Using System Utilities

This chapter includes these sections:

“Opening a Utility”
“Working With Shells”
“Clocks”

“Calendar Utility”
“Calculator Utility”
“Magnifier Utility”
“Snapshot Utility”

“Show Color Map Utility”
“Reset Color Map Utility”
“System Usage Utility”
“Font Names Utility”

The Toolchest menu in the upper left corner of your screen contains an Icon Catalog that
holds collections of utilities, tools, and applications. The system utilities are located on

the Desktop Tools page of the Icon Catalog.

To get to these utilities:

1.

Pull down the Find menu, which is located on the Toolchest menu in the upper left

corner of your screen.

2. Select Desktop Tools.
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You can also open the utilities using an IRIX command in a shell. See “Starting Up
Utilities From a Shell.”

Resizing Utility Windows
Many utility windows can be resized to your preference. To resize a utility window after
it is placed:

1. Position your cursor anywhere on the very edge of the window. You know your
cursor is positioned correctly for resizing the window if the cursor becomes an
arrow with a bar at its point.

Press and hold down the left mouse button.
2. With your cursor, push or pull the border until you reach the desired window size.
3. Release the mouse button. The window is now the new size. You can resize it again

at any time.

Some utilities can be sized only if you select “Size” from the standard window menu. See
“Working With Borderless Windows” for simple instructions on bringing up the window
menu.

Starting Up Utilities From a Shell

You may start up any of the utilities by typing the appropriate IRIX command in a shell
window. The IRIX command is provided in this chapter for each of the utilities.

For example, to start up Desk Clock from a shell, type cl ock and then press Ent er.

Working With Borderless Windows

Some of the utilities are displayed on the screen with no border; some have a border but
no window menu button. To display a window menu for these items:

1. Position the cursor over the utility window.

2. Hold down the Al t key.

3. Press the right mouse button.
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Input Focus

A window menu appears. You may choose “Quit,” “Move,” or any other listed
command. This procedure works for any window, whether or not it has a border.

A few of your desktop utilities require you to control the input focus of the cursor. Input
focus allows only one window at a time to recognize mouse movement and typing. This
allows the utility to apply itself to items on the screen that are outside of the utility
window. See “Magnifying a Section of Your Screen” for an example of working with
input focus.

This guide notes whether or not a utility requires input focus, and includes input focus
procedures in the utility instructions.

The input focus can be controlled in two different ways. First, position the cursor over
the utility window that you are using, then do one of the following:
® Press and hold the middle mouse button.

e Press and hold any key on the keyboard. It is best to use a non-printing key such as
Shift so you do not inadvertently start typing into another window.

Working With Shells
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Using the left mouse button, you can select text in a shell window three different ways:
*  While holding down the mouse button, drag the cursor over the text to select it.

* Double-click to select an individual word.

¢ Triple-click to select a single line of text.

Selected text appears highlighted and is automatically copied to a memory buffer. It can
be pasted into another shell or back into the same shell using the middle mouse button.
This is a handy way to repeat a command in a shell without retyping it, or to do simple
editing for electronic mail.

To paste text from one shell into another:

1. Select the text you want to paste.

2. Position the cursor over the shell that you are pasting into.
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3. Click the middle mouse button.

The text appears after any text that is already in the shell.

Shell Window Options

Every shell window contains a pop-up menu. You may use the menu to position and size
the window as well as change its display font. To view the pop-up menu, position the
cursor over the shell window and press the right mouse button. The menu appears as
illustrated in Figure 12-1.

Figure 12-1  Shell Window Pop-Up Menu

The pop-up menu commands are outlined below:

Pop Brings the window to the top, over any other windows that obscure it
Send Pastes the selected text (same as clicking the middle mouse button)
Size Provides several options to modify the dimensions of the window
Font... Lets you change the display font for the shell window

Clone Creates a duplicate of the window in one of several optional sizes
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Using most of the pop-up menu commands is very straightforward; however the
“Font...” command requires additional instructions.

Using the Font...Command in the Shell Window Pop-Up Menu

Choosing “Font...” from the shell window pop-up menu displays the dialog box
illustrated in Figure 12-2.

Font: Style: Size:
clean (schumacher) 4| |bold Al |2 &
courier (adobe) hold obligue ]
fixed (misc) hold sans 7 |
fixed (misc, jisx0201.1376, 0) =| | bold semicondensed a —
fixed (somy) medium ]
fixed (sory, jisx0201.1376, 0) —1 | medium italic m
international () medium ohligue 11
iris (,, ascii) medium sans 12
lucidatypewriter (b&h) medium semicondensg 13
nil {, , fontspecific) v E1R LT

D Zhow proportional width fonts
D Zhow size in points

Font Mame:
r |

| Accept || Apply || Cancel || Help |

Figure 12-2  Font... Dialog Box

The dialog box shows all the available fonts, along with the font styles and sizes. If you
want the dialog box to show only the proportional width fonts or to show the size in
points, click on the appropriate check box. The check boxes toggle on and off as you click
them.

To change the display font for your shell window:

1. Select a font from the “Family” list.

The Family list contains some of the font families loaded into the system. Only the
names available for the selected font will be visible in the darker print.
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2. Select a font style from the “Style” list box.

The Style list shows, in darker print, the available styles for the selected font.
3. Select a font size from the “Size” list box.

The Size list shows only the available sizes for the selected font and style.

When you have selected a font, style, and size, the name of the font bearing all three
properties is automatically written into the “Font Name” text field. If you wish, you
may enter this font name manually. See the section, “Using the Font Names Utility
to Select a Font for a Shell Window,” to find out how you can choose from a much
wider selection of fonts.

Click Apply to apply the new font to the shell window, or Accept to apply the new
font and dismiss the dialog box. Press cancel to cancel your selection and close the
dialog box.

Note: See the Personal System Administration Guide for more information on shells and
commands.

Clocks
Clocks are available on the Desktop Tools page. All of the IRIX clocks display the
standard system time. If the clocks do not display the correct time, use the IRIX dat e
command to reset the system time. See the Personal System Administration Guide.
Desk Clock

To bring up the Desk Clock utility, open the Find menu, select Desktop Tools, and
double-click the clock icon.

The Desk Clock utility is illustrated in Figure 12-3.
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Figure 12-3  Desk Clock
To start up Desk Clock from a shell window, type cl ock and then press Ent er.

Desk Clock has an alarm that you can set to go off at any designated time. To set the
alarm:

1. Position the cursor over Desk Clock and press the right mouse button.

A pop-up menu appears as illustrated in Figure 12-4.

GA!BRESr

[ siarm

Figure 12-4  Desk Clock Pop-Up Menu

2. Choose “alarm” from the pop-up menu.

A red hand appears on the face of Desk Clock.

3. Position the cursor over the red clock hand, hold down the left mouse button, and

drag the red hand to the desired alarm time.

The exact time the red hand points to is indicated at the bottom of Desk Clock. Keep in

mind that the Desk Clock alarm cannot distinguish between a.m. and p.m.

The pop-up menu also has a “calendar” command. Choosing “calendar” brings up the

Calendar utility (See “Calendar Utility” in this chapter).

Desk Clock appears on the screen as a borderless window. To display a window menu,
position the cursor over Desk Clock, hold down the Al t key, and press the right mouse
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Analog Clock

Calendar Utility

174

button. This lets you size, move, or quit Desk Clock, or use any other feature of the
window menu.

To start the Analog Clock utility, open the Find menu, select Desktop Tools, and
double-click the xclock icon.

The Analog Clock, shown in Figure 12-5, simply displays the time and has no additional
features.

To start up Analog Clock from a shell window, type xcl ock and then press Ent er.

Figure 12-5  Analog Clock

To start the Calendar utility, open the Find menu, choose the Desktop Tools page, and
double-click the ical icon. The calendar is shown in Figure 12-6.

Figure 12-6  Calendar
To start up Calendar from a shell window, type i cal and then press Ent er.

Calendar appears with the current month displayed and the current day indicated in red.
Clicking on the calendar with the middle mouse button advances the calendar by one
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Calculator Utility

Calculator Utility

Magnifier Utility
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month with each click. Clicking on the calendar with the left mouse button makes the
calendar go back one month with each click.

To start the Calculator utility, open the Find menu, choose the Desktop Tools page, and
double-click the xcalc icon.

To start up Calculator from a shell window, type xcal ¢ and then press Ent er.
The Calculator utility, shown in Figure 12-7, is a feature-laden, scientific calculator. It can

be operated by clicking the appropriate calculator button with the left mouse button or
by using the numeric keypad on the keyboard.

Figure 12-7  Calculator

If you use the numeric keypad, press Ent er when you want to execute the operation you
have entered. For example, after entering 2 + 2, press Ent er to complete the equation.

The calculator uses algebraic notation (not Reverse Polish Notation) and follows the

rules of algebraic precedence. In other words, entering 2 + 2 x 3 Enter gives you?2 +
(2x3), or 8.

To start the Magnifier utility, open the Find menu, select the Desktop Tools page, and
double-click the mag icon.

To start up Magnifier from a shell window, type nag and then press Ent er.
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The Magnifier utility provides a magnified view of selected portions of your computer
screen. The Magnifier window shows you a static image; it changes only when you click
to select a new area for magnification.

Magnifying a Section of Your Screen

Snapshot Utility
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The Magnifier window can magnify any area of the screen you click on. This requires that
you control the cursor’s input focus so the IRIX software understands that you are still
working with Magnifier when you move the cursor out of its window. For more
information on input focus options, see “Input Focus” under the “Opening a Utility”
section.

To use Magnifier:

1. Position the cursor over the Magnifier window. A special cursor appears in the
shape of a magnifying glass. Hold down the Shift key or the middle mouse button.
This holds the input focus on Magnifier.

2. Still holding down the Shift key or the middle mouse button, move the cursor over
the area on your screen that you want to magnify and click the left mouse button.

A magnified picture of the section you selected appears in the Magnifier window. You
can sweep out this small window, so that you can see more of the section you magnified.
For instructions on resizing windows, see “Resizing Utility Windows” under the section
“Opening a Utility.”

To start the Snapshot utility, open the Find menu, choose Desktop Tools, and double-click
on the snapshot icon.

To start up Snapshot from a shell window, type snapshot and then press Ent er.
Snapshot lets you take a “snapshot” of either the entire screen or selected areas of the

screen and then save the snapshot as an RGB image. The small window appears as a
borderless rectangle with the label “snapshot,” as shown in Figure 12-8.
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Figure 12-8  Snapshot

About the Snapshot Menu

007-1342-170

Position your cursor over the snapshot window. The pointer cursor changes to a camera
cursor when you do this. Press down the right mouse button. This displays the pop-up
menu shown in Figure 12-9.

shapshot

Save scrn as snap.rgh
Mew file name

Foasie snain gk
Redraw Bubberband
Save and Exit

Exit

Figure 12-9  Snapshot Menu

You can display the pop-up menu anywhere on the screen by pressing the right mouse
button when the input focus is on Snapshot (as indicated by the camera cursor).
The menu provides a variety of options:

Save scrn as snap.rgb
Saves the full screen snapshot in the current directory as an RGB image,
with the filename snap. r gb.

New file name Allows you to save the image with a new filename or pathname. When
you choose this option, a box appears. Type in the filename or pathname
and press Ent er.

Ipaste snap.rgb Pastes the saved image on the screen.
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Red

raw Rubberband
Allows you to alter the snapshot area that you selected. (See “Taking a
Snapshot of a Selected Area.”)

Save and exit  Saves the snapshot with the default filename snap. r gb, or the new

Exit

filename you entered, and exits the Snapshot utility.

Immediately exits Snapshot.

Taking a Snapshot of a Selected Area

178

To take a snapshot of a selected area of your screen, you must control the input focus by
holding down the Shift key. For more information on input focus, see “Input Focus” in
the “Opening a Utility” section.

To take a snapshot of a selected area:

1.

Position your cursor over the Snapshot window and hold down the Shift key.
The cursor takes on the shape of a camera when you use Snapshot.

Still holding down the Shift key, move the camera cursor over to the area you want a
snapshot of and use the left mouse button to drag a box around the area. This is the
area that Snapshot will capture.

Release the Shift key and the mouse button.

Position the cursor over the Snapshot window and press the right mouse button to
display the pop-up menu.

If you are happy with the box area you created, proceed to Step 6. If you would like
to alter the box, select “Redraw Rubberband” from the pop-up menu.

Hold down the Shift key and move the cursor to one of the edges of the snapshot
box you created. The cursor changes shape depending on where you place it in the
box. For example, if you place the cursor on one of the edges, it becomes a bar with
a dotted line outline.

Still holding down the Shift key, push or pull at the box outline until you are
satisfied with your snapshot area.

Release the Shift key. Choose “Save as snap.rgb” from the Snapshot menu to save
the snapshot as an RGB image.
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You can also choose “New file name” to rename the image file; then select “Save as
filename,” where filename is the name you entered into the “New file name” dialog
box.

You can now either paste the image on the screen by typing i past e <filename>, or open
the saved image later in an image processing program.

Note: When you use i past e to paste a snapshot image on your screen, the image has a
borderless window. You must to use the Alt key and the right mouse button to display a
window menu. See “Working With Borderless Windows” for detailed instructions.

Taking a Snapshot of the Entire Screen

1. Position the cursor over the Snapshot window and press the right mouse button.
The Snapshot pop-up menu appears.

2. Choose “Save scrn as snap.rgb” from the menu.

Note: This menu option does not exist if you have already selected a portion of your
screen to snap. If this is the case, exit and restart Snapshot.

The “Save scrn as snap.rgb” selection saves a snapshot of your entire screen in your
current directory as the RGB file named snap. r gb. You can now paste it on screen, or
open it later in an image processing program. Pasting it on screen takes a few moments,
and because of the way the pasted image is drawn on screen, you should wait until the
process is completed before moving the cursor.

You may also choose “New file name” to rename the image file; then choose “Save scrn
as filename” (where filename is the name you choose) or “Save and exit.”

Show Color Map Utility
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The Show Color Map utility shows you the current color map of your system. The color
map represents the colors that are currently being used by the system for screen display.
The number of colors your system can display depends on its configuration. Not all
colors are used under normal circumstances. Show Color Map lets you alter the colors
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used by the system for specific purposes, such as altering the color of your desktop
Calendar (ical).

Each of the colors in the color map is displayed along the bottom of the Show Color Map
window, usually below an area of black. If you are running an application that has
introduced colors into the system that are not normally part of the color map, these new
colors are represented by the black portion of the window.

Clicking on the window toggles it between two grid sizes, one twice as large as the other.

Note: The subject of color maps can become very technical, and a full treatment of the
subject lies beyond the scope of this guide. See the showmap and cedit reference pages for
additional information.

Using the Show Color Map Utility to Alter Colors:

To start the Showmap utility, open the Find menu, select Desktop Tools, and double-click
the showmap icon.

To start up Show Color Map from a shell window, type showrap and then press Ent er.

To alter colors on your screen:

1. Place the cursor over the showmap window and press the right mouse button, which
displays a pop-up menu.

2. Choose “cedit” from the pop-up menu.

The cedit window appears on the screen. It contains a sample color box on the right
and three slide bars to adjust the primary colors.

3. Place the cursor over the cedit window and hold down the Shift key to lock the input
focus.

4. Still holding down the Shift key (but without pressing a mouse button), move the
cursor over to the screen color you want to alter and click the left mouse button to
select it.

The selected color appears in the cedif window sample color box. The slide bars
representing the primary colors automatically adjust to the selected color.

180 007-1342-170



Reset Color Map Utility

5. Drag the cedit slide bars up and down to adjust the color to your preference.

The selected color visibly changes on the screen as you adjust the slide bars.
After altering the color map, you can easily reset it to its original values by clicking on
the Reset Color Map utility, as described in the next section. Or, you can reset the color

map to the original values by choosing “makemap” from the showmap window pop-up
menu.

cedit works well on tools such as ical and jot, but there are some items it usually cannot
affect. These include:

¢ “Dithered” colors (such as the background color in the desktop window). Dithered
areas are areas where two colors are used in alternating pixels to give the
appearance of a single color.

* Applications with their own colormap. cedit can edit only the colors currently
installed in the hardware color map.

Reset Color Map Utility

The Reset Color Map utility simply resets the altered color map to its original values. You
would use this after using the Show Color Map utility.

To activate the Reset Color Map utility, open the Find menu, select the Desktop Tools
page, and double-click the makemap icon.

To invoke the Reset Color Map command from a shell window, type makenap and then
press Ent er.

The colors that were altered with showmap return to their original state after the Reset
Color Map utility is used.

System Usage Utility

The System Usage utility displays a graphic representation of the CPU activity of your
system.
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To start the System Usage utility, open the Find menu, select the Desktop Tools page, and
double-click the gr_osview icon.

To start up System Usage from a shell window, type gr _osvi ew and then press Ent er.

The graphic representation is dynamic; it changes as the CPU activity changes. The
System Usage window presents a color bar with six types of CPU activity represented:

user Your direct use of the CPU.

sys The activity of the operating system.

intr The “interrupt overhead” of the CPU.

afxf Use of the CPU to display graphics (graphics input).

gfxc Use of the CPU to display graphics (graphics context switching).
idle Idle time, no CPU activity.

Each type is assigned a color, and as that type of activity occurs, the representational
color takes over a greater proportion of the color bar.

Font Names Utility

The Font Names utility provides the full name of a font, as well as a sample of it, based
on requested attributes, such as font size, weight, and other properties. IRIX
distinguishes fonts by giving them a fourteen-part name. The Font Names utility can
provide all fourteen parts and store the name in a memory buffer, enabling you to paste
your custom font name into another application.

To start the Font Names utility, open the Find menu, select Desktop Tools, and
double-click on the xfontsel icon.

To start up Font Names from a shell window, type xf ont sel and then press Ent er.
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Using the Font Names Utility to View Font Samples

To see samples of different fonts:

1.

Click on “fmly” (meaning font family) with your left mouse button, and choose a
font from the pop-up menu.

As you change font properties, such as “fmly,” the alphanumeric sample in the last
section of the xfontsel window changes to the match the properties you have
selected. In addition, the middle section of the xfontsel window displays the full font
name. See Figure 12-10.

é—fndry—fmly—wght—slant—sWdth—adstyl—pxlsz—ptSz—resx—resy—spc—angdth—rgstry—encdngé

—*—gourier-medium-r—*-*-1§-*—F_F_F_k_*_*x

ABCDEFGHIJKLMNCOPQRSTUVWHY Z
abodefghijklmnopgrstuvwxysz
0123456789

dmcE iBASNTAECEIDHOUY

Figure 12-10 Font Names Utility

2.
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If you wish, continue to change the font by selecting different options from any of
the pop-up menus.

Most end users find the “wght” (meaning weight), “slant” (meaning font slant), and
“pxlsz” (meaning font size) properties to be the most useful options.

(optional) You can now click on the select button to save the complete font name in a
memory buffer. Use the middle mouse button to paste the font name somewhere
else.

For an example of this, see “Using the Font Names Utility to Select a Font for a Shell
Window.”

Click on the quit button when you are ready to exit the xfontsel utility.
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Using the Font Names Utility to Select a Font for a Shell Window

To use the Font Names utility to apply a new font to a shell window, perform the

following:

1. Click on “fmly” (meaning font family) with the left mouse button, and choose a font
from the pop-up menu.

2. If you wish, continue to change the font by selecting different options from any of
the pop-up menus.

3. When you find the font you want, click the select button. This saves the font name in
a memory buffer.

4. Open a shell window and hold down the right mouse button to bring up the shell
pop-up menu.

5. &till holding down the right mouse button, move the cursor to the “Font...” menu
choice and release. A new window appears.

6. There is a “Font Name” box in which you can insert a specific font name. If there is
any writing in this box, use the back space key to delete it.

7. Press the middle mouse button. This should paste the exact font name you selected
into the “Font Name” box.

8. Click the Apply button to simply apply the font to the shell window.

Or, click Accept to apply the font and exit this font window at the same time.

Your shell window should now display the font of your choice.

Note: This font change only applies to your current shell window, not to other shell
windows during your current or future login sessions.

For more information about using fonts, see the xfontsel reference page and “Working
with Fonts” in Topics in IRIX Programming.
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Chapter 13

Anatomy of the Desktop

This chapter contains reference (as opposed to task-oriented) information about the tools
and commands that are a part of the desktop environment. It contains:

“Anatomy of a Window”

“About the Remote Display Feature”

“About the Toolchests”

“The Icon View Window: An Overview”
“Anatomy of an Icon View Window”

“The Desks Overview Window: An Overview”
“Anatomy of the Desks Overview Window”
“The Launch Window”

“The Search Tool: An Overview”

“Anatomy of the Search Tool”

“The Icon Catalog: An Overview”

“Anatomy of the Color Scheme Browser Window”
“The Color Scheme Browser Menus”
“Understanding the makeDotDesktop Window”
“About the Error Message Window”

Anatomy of a Window

Most of the windows that appear on your screen have standard fixtures. This section lists
fixtures that you'll see on many different windows. Figure 13-1 shows a window and
labels some of the common fixtures.
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The Title Bar

186

mmow Path Pathname Title \,“{',%’r‘,i('}ﬂff
Button Bar Field Bar Button
Maximize
Window
Button
Drop Recycle
Pocket Eutton
Border

Figure 13-1 A Window With the Common Fixtures Labeled

You can use the fixtures labeled in Figure 13-1 to manipulate windows in a variety of
ways. See Chapter 8, “Managing Windows.”

Note: Occasionally, you see a window that is missing these fixtures. Such a window is
called a borderless window.

The title bar allows you to move, raise, and lower windows.

* Place the cursor in the title bar; then press the left mouse button and drag to move
the window.

e Place the cursor in the title bar; then click the left mouse button to raise the window
to the top of the stack of windows.

* Place the cursor in the title bar; then press the Gt r| key and left mouse button
simultaneously to lower the window to the bottom of the stack of windows.
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Anatomy of a Window

The Window Menu Button

The Minimize Button

The Maximize Button

The Border
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The Window menu button lets you access the Window menu and provides a shortcut for
closing windows.

e Place the cursor over the button and press the left mouse button to see the Window
menu.

e Double-click the button with the left mouse button to close the window.

You click the Minimize button with the left mouse button to turn the window into a small,
square icon. This does not close the window or stop any of the programs that are running.
It turns it into an icon that takes up less screen space.

You click the Maximize button with the left mouse button to make the window as large as
it can be. Some windows become as large as the screen; others change only slightly. If a
window does not change or becomes smaller when you click the Maximize button, the
window was already at its largest size. To restore a maximized window to its original
size, click the Maximize button again.

You use the border in conjunction with the mouse buttons and keyboard keys to
manipulate the window in a variety of ways:

® Place the cursor on the border; then press the right mouse button to open the
Window menu.

® Place the cursor on the border. When you see a resize cursor, drag the mouse to
resize the window.

® Place the cursor on the border; then press the middle mouse button and drag to
move the window.

®  Place the cursor on the border; then press the left mouse button to raise the window.
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The Scroll Bars

The Drop Pocket

The Path Finder Field

The Path Bar
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® Place the cursor on the border; then press the Ct r| key and left mouse button
simultaneously to lower the window.

You can see windows with scroll bars along the left or right and top or bottom edge.
These indicate that the window is too small to display all of its contents. Use the scroll
bar to view hidden portions of the window.

A drop pocket is the small square into which you can drop icons. Here are several ways in
which you can use drop pockets:

¢ Drag a folder icon and place it into the drop pocket on an Icon View window. The
window displays the contents of that folder.

¢ Drag an IRIS Showcase icon and drop it into a drop pocket on the Search tool to
specify the type of files you want to find—in this case, IRIS Showcase files.

You can also drag icons out of the drop pocket and place them onto the desktop, onto a
shelf, or into the Icon Catalog.

The path finder field shows the full pathname of the directory, Web site, or FTP site whose
icon or contents are displayed in the window. You can type a new name in this field to
display the contents of a different directory, Web site, or FIP site. See “Opening a
Directory Using the Path Finder.”

The path bar lets you move from one directory to another, without typing. It contains a
small button representing each directory in the pathname. See Figure 13-2.
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The Recycle Button

Click here to display the / directory.

— Click here to display the A directory.

Figure 13-2  Using the Path Bar

The Recycle button keeps a list of names you have specified in a type-in field. For
example, place the cursor over the Recycle button on an Icon View window; then press
the left mouse button to see a list of directories whose contents you have previously
displayed in the window. Choose an item from this list and the window changes to
display the contents of that directory.

About the Remote Display Feature

The Remote Display feature lets you control your system’s ability to run applications
from remote systems and display them on your screen. Keep in mind that Remote
Display makes your own desktop remote display open to all remote hosts, so you may
want to turn it off when you are not using it.

There are four ways to enable or disable the remote display. The first two ways are
temporary, affecting only your current login session. The other two ways are permanent,
affecting your current session and all future logins.

Temporary Remote Display Settings
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The following are the two temporary settings, in that they only apply to your current
login session. When you log out, these settings revert to the permanent settings.

¢ To enable Remote Display for a specific system, from the Toolchest, choose Desktop
> Access Files > By Remote Login.

¢ To enable Remote Display for all hosts, choose System > Utilities > Enable Remote
Display. You can also choose Disable Remote Display from the Utilities menu.
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Note: Because the above settings are temporary, the Desktop > Customize > Desktop
panel’s Enable Remote Display checkbox does not reflect their status.

Permanent Remote Display Settings

The following two settings are permanent, in that they become the default whenever you
log in. You can temporarily override these permanent settings by using either of the two
temporary measures above.

¢ To enable or disable the remote display for all users of the system, choose System >
System Manager > Security and Access Control > Improve System Security. Each
user added to the system will have this setting by default.

*  You can choose to enable or disable remote display for your own account by using
the Desktop > Customize > Desktop panel. This setting is applied when you log in.
This setting takes precedence over the setting chosen in the Improve System
Security task.

About the Toolchests

The Toolchest menu contains a stack of “toolchests” organized into categories for easy
access to virtually all system functions and programs. Move the cursor over a label on a
toolchest; then hold down the left or right mouse button to pop up a menu.

The Desktop Toolchest

The Desktop toolchest contains commands that let you create and customize desks, open
directories, adjust the audio volume, log out, and more.

The “Access Files > In my Home Directory” Command
The “Access Files > In my Home Directory” command opens an Icon View window that

shows the contents of your home directory. You can also open your home directory by
double-clicking the folder icon that appears on the desktop.
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The “Access Files > In Automounted Directory” Command
If your system is on a network, you can open a directory on another system in the network
using the “In Automounted Directory” command. An Icon View window appears with

/' host s/ typed into the path finder. For more information on accessing files using
automount, see “Accessing Remote Files Using Automount.”

The “Access Files > As Another User” Command

The “Access Files > As Another User” command lets you open an Icon View window or
toolchests as another user on your system.

The “Access Files > By Remote Login” Command

The “Access Files > By Remote Login” command lets you open a remote Icon View or
toolchest as a user on the remote system.

The “Shared Resources > On This Workstation” Command

The “Shared Resources > On This Workstation” command displays a list of all the
directories, media devices, and printers that your system has marked as shared.

The “Shared Resources > On a Remote Workstation” Command

The “Shared Resources on a Remote Workstation” command lets you access a list of
directories, media devices, and printers for a remote system that you name.

The “Customize” Command
The “Customize” rollover menu lists the control panels that you can use to customize the

desktop—change the background or screen saver, adjust the mouse setting, and more.
Refer to each panel’s Help button to find out more about using them.

The “Extra Desks” Command
The Desks Overview window shows you the available desks and lets you create and

rearrange your own desks. Choose the “Extra Desks” command to open this window. See
Chapter 7, “Using Multiple Desks,” for detailed instructions.
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The “Control Audio” Command

The “Control Audio” command opens the Audio Control Panel. Use this to adjust the
volume.

The “Empty Dumpster” Command
Deleting files is a two-step process. You place the files in the dumpster; then you use the

“Empty Dumpster” command to empty the dumpster. At this point, the files are
permanently deleted from the system’s disk.

The “Eject Media” Command

Select a media device icon on your desktop, then select “Eject Media” to eject media from
the device.

The “Start Screensaver” Command

Use the “Start Screensaver” command if you want to turn the screen saver on command
rather than wait for the usual time lapse for the screen saver to take affect.

The “Open Unix Shell” Command
The shell is the traditional interface to UNIX workstations. It is a window in which you

type IRIX commands. To open a shell, choose the “Open Unix Shell” command. Also see
Appendix A, “Using IRIX Commands”.

The “Log Out” Command

Choose the “Log Out” command when you are finished using the system and want to
ready it for another user.

The Selected Toolchest

The Selected toolchest contains commands that affect icons on the desktop. Select an icon
on the desktop; then choose an item from the menu.
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The “Open” Command

The “Open” command opens a selected icon and displays its contents in a window. If you
open a folder icon, you see an Icon View window that shows the contents of that
directory. If you open a file icon, you can edit or view the file.

The “Make Copy” Command

The “Make Copy” command makes a copy of the selected icon. The copy is named
copy_of _fi | enamne. If the selected icon is on a shelf, the copy appears on the shelf and
in the directory that contains the original icon. The same is true for the desktop and Icon
Catalog. The copy appears on the desktop or the Icon Catalog page, as well as in the
directory that contains the original icon.

The “Make Reference” Command

The “Make Reference” command creates a a referenced copy of a selected icon. The
reference icon is a pointer to the original. You can drag it into an Icon View window, or
onto a page in the Icon Catalog, allowing you to access the icon from several different
places.

See also “Making a Referenced Copy of an Icon.”

The “Remove” Command

The “Remove” command removes the selected icon and places it in the dumpster
directory. Placing a file in the dumpster is the first step to deleting the file from your
computer’s disk. See “Removing Files and Reference Icons.”

Note: You can change the behavior of the “Remove” command so that it deletes files
rather than moving them into the dumpster. See “Making “Remove” Delete Instantly.”

The “Print” Command
The “Print” command sends the contents of the selected icon to your default printer. If you

select a folder icon, you print a list of the files in that directory. If you select a file, you
print the contents of the file (text or images, for example).
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See also “Printing Files.”

The “Share with Network” Command

Use the “Share with Network” command to share a selected directory with other systems
on a network. See “Sharing Directories With Other Systems” for more information.

The “Stop Sharing” Command

Use the “Stop Sharing” command to stop sharing a selected directory with other systems
on a network.

The “Publish to Outbox” Command
Use the “Publish” command to publish a selected file on your OutBox page. Selecting

“Publish” opens the OutBox tool interface and places the file you selected in the OutBox
pathname field. See the Help in OutBox for more information on publishing a file.

The “Get Info” Command
The “Get Info” command displays a form that shows detailed information about the

selected file, folder, or application icon. The command is gray and inaccessible if you
have selected another type of icon.

The “Add New Directory” Command
The “Add New Directory” command creates a new directory labeled enpt y. di r. The
folder icon appears in the window from which you choose the “Add New Directory”
command. If you choose “Add New Directory” from the Selected toolchest, the folder

icon appears on the desktop and is stored in your home directory. See also “Creating a
Directory.”

The “Select All” Command

The “Select All” command selects all icons on your desktop.
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The “File QuickFind” Command

The “File QuickFind” command opens a window into which you can type the name of
an icon you want to find. For example, suppose you want to place the IRIS Showcase icon
on the shelf for a a particular Icon View window. Choose “File QuickFind”; then type
showcase in the type-in field. The icon appears. For further details, see “Finding Files,
Applications, or Directories Using File QuickFind.”

The “Find Original” Command

Select a reference icon on the desktop, then select “Find Original” to open an Icon View
window containing the original icon.

The Internet Toolchest

The “Open Web Browser” Command

The “Open Web Browser” command opens Netscape Navigator, the default Web
browser. To change the default Web browser, use the Ultilities control panel. To open the
panel, select “Utilities” from the Customize menu in the Desktop toolchest.

The “Browse OutBox Page” Command

The “Browse OutBox Page” command opens up your OutBox Web page in the Netscape
Navigator™ Web browser. The Web page was automatically created for you when you
first logged in if you installed the OutBox web server.

The “Icon View of a Web Site” Command

Use the “Icon View of a Web Site” command to open an Icon View window with ht t p: //
typed into the path finder. When you type a Web site address into an Icon View
pathname field, a list of all the links on the Web page appear. See “Accessing Files on the
Web Using an Icon View Window.”
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The “Icon View of an FTP Site” Command

Use the “Icon View of an FTP Site” command to open an Icon View window withft p: //
typed into the pathname field. Type the rest of an FTP site to access files an FIP site. See
“Accessing Files Using FTP in an Icon View Window.”

The “Create a WebJumper” Command

The “Create a WebJumper” command opens the WebJumper tool. WebJumper lets you
create icons that “jump” you to your favorite Web sites.

The Find Toolchest

The Find toolchest contains a collection of tools that will help you find icons—file icons,
application icons, and system icons, for example.

The “Search For Files” Command

The “Search for Files” commands opens the Search tool. The Search tool lets you search
for files based on:

The filename, or a portion of the name

The type of icon it has

How recently the file was created or modified
The person who owns the file

The size of the file

The permission settings for the file (permission settings specify whether people can
view and edit the file)

The text in an ASCII text file

The “File QuickFind” Command

This command is equivalent to the “File QuickFind” command that appears on the
Selected menu. It opens a window into which you can type the name of an icon you want
to find. For example, suppose you want to place the IRIS Showcase icon on the shelf for a
a particular Icon View window. Choose “File QuickFind”; then type showcase in the
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type-in field. The icon appears. For further details, see “Finding Files, Applications, or
Directories Using File QuickFind.”

The “Host QuickFind” Command

The “Demos” Command

You can use the “Host QuickFind” command to find an icon for a remote host. See the
Help in Host QuickFind for more information.

“Demos” opens a local Web page of Silicon Graphics demos.

The Icon Catalog Command

Launches the Icon Catalog, which shows collections of applications and tools that are
available on your system. Under the Icon Catalog command, there are several menu
items, such as “Media Tools” and “Applications,” each of which opens to a specific page
of the Icon Catalog. Once the Icon Catalog is opened, you can navigate between pages by
clicking the tabs at the bottom of the window. Refer to the Icon Catalog Help menu for
more details.

The System Toolchest

The Help Toolchest
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The System toolchest contains several commands that let you access the system
management tools. The System Manager is a good “one-stop shopping” place for
virtually all of your system management tasks—it includes a Search capability and
Interactive Guides that make system administration tasks easy. See the online Personal
System Administration Guide for complete information on these tools and system
administration tasks.

The Help toolchest includes:
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The “Info Search” Command
The “Info Search” command opens the documentation search tool. This lets you access

and search all documentation on the system, including online books, help, man pages,
and release notes.

The “Quick Answers” Command
Choose “Quick Answers” when you need to perform a task but are uncertain which tool
to use or how to begin. It includes quick answers to questions related to the tasks and
tools that are a part of your system’s end user software environment. You'll find answers

in the form of short “how to” descriptions, links that launch applications to use, or
pointers to the information you need.

The “Hints and Shortcuts” Command

The “Hints and Shortcuts” command opens a guide to useful desktop features for
working smarter and faster.

The “Online Books” Command

The “Online Books” command opens the document library for all online books.

The “Man Pages” Command
The “Man Pages” command opens a browser you use to view manual pages. A manual

page, frequently called a “reference page (man page),” contains reference information
about IRIX commands.

The “Release Notes” Command
The “Release Notes” command opens a browser you can use to view online release notes.

Each software product has an associated release note. Typically, the release note contains
installation information as well as a list of known bugs and ways to work around them.

The “Legal Notice” Command

The “Legal Notice” command opens a window that contains software copyright
information.
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The Icon View Window: An Overview

Icon View windows appear when you open a folder icon. They display the files and
directories that a particular directory contains. By default, the contents are displayed as
icons. You can manipulate the view of the icons in many ways, such as displaying image
icons as “thumbnails” of the images they represent. Icon View windows have many
useful features—see Hints and Shortcuts for several examples (from the Toolchest,
choose Help > Hints and Shortcuts).

The background of the main part of an Icon View window is green. You can also display
a blue portion of the window, which is called a shelf. The shelf is a place for you to put

icons that you need to use frequently while working in that directory. For details, see
“Using a Shelf for Convenient Icon Access.”

Anatomy of an Icon View Window

This section explains each portion of an Icon View window.

The Toolbar

The toolbar appears along the left edge of the Icon View window. Click the buttons on
the toolbar to change the way icons are displayed in the window.

The Display as Icons Button

Click this button to display the contents of a directory as icons. This button is equivalent
to the “as Icons” command on the View menu.

The Display as List Button
When you open a folder icon, the contents of the directory appear as icons. Click this

button to view the icons as a sorted list. This button is equivalent to the “as List”
command on the View menu.
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The Display in Columns Button

Click this button to organize the icons in a window into columns. This button is
equivalent to the “as Columns” command on the View menu.

The Thumbnail Images Button

If a directory contains image files, click this button and the file icon will be replaced with
a small snapshot of the image. This button is equivalent to the “as Thumbnail Images”
command on the View menu.

The Shelf Button

Click this button to display a virtual shelf along the bottom of the Icon View window. The
shelf is a place for you to put applications or other icons that you need to use frequently
while working in that directory. For example, if the directory contains many files, you
might want to place the files you use most frequently on the shelf. Or, if the directory
contains many color Showcase slides, you might want to place the icon for a color printer
onto the shelf.

This button is equivalent to the “Show Shelf” command on the Options menu.

The Content Viewer Button

Click this button to display a file content viewer along the bottom of the Icon View
window. After you open the Content Viewer, click on a file icon to display a read-only
version of the file in the viewer. This button is equivalent to the “Show Content Viewer”
command in the Options menu.

The Thumbwheel

Use the thumbwheel to change the size of icons in that window. Place the cursor over the
thumbwheel; then drag the cursor up to make the icons smaller or down to make the
icons larger. To revert to the original size, click the small box below the thumbwheel. If
the thumbwheel is not visible, drag the bottom of the window to expand it—the
thumbwheel appears.
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The Path Finder

The Drop Pocket

The Pathname Field
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The pathfinder is the area of an Icon View window that contains:
e “The Drop Pocket”

® “The Pathname Field”

¢ “The Path Bar”

The drop pocket is the small blue square to the left of the type-in field. When you place an
icon in the drop pocket, the Icon View window changes. For example, when you drag a
folder icon and place it in the drop pocket, the window displays the contents of that
folder.

You can also drag icons out of the drop pocket and place them onto the desktop, onto a
shelf, or into the Icon Catalog.

The pathname field shows the list of directories that leads you from the root (/) directory
to the directory whose contents are displayed in the window. You can type a new name
in this field to display the contents of a different directory. See “Opening a Directory
Using the Path Finder.”

If your system is on a network, you can type the name of a remote directory. To do so,
type / host s/ r enot esyst emnane followed by the name of the directory you want to
open. If the system is in a different domain of the network, include the domain name after
the hostname. For example, to open the / usr/ t np directory on a system named

wi zar d. bl dg2, type: / host s/ wi zar d. bl dg2/ usr/t np.

Note: In order for “/hosts” to work, either AutoFS or Automount should be enabled. To
set this up, choose System > System Manager from the Toolchest, go to Network and
Connectivity, then click Set Up and Start NFS to open an Interactive Guide. Also, the
other system’s directory must have read permission.

You can also type a URLs or FTP site into the pathname field to display all files associated
with that URL or FTP site.
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The Path Bar

The path bar is the thin gray bar above the pathname field. It lets you move from one
directory to another, without typing. It contains a small button representing each
directory in the pathname. Click a button to display the contents of that directory. See
Figure 13-3.

Click here to display the / directory.
— Click here to display the A directory.

Figure 13-3  Using the Path Bar

The Match Name Field

The “Show files that match name” field appears when you choose “Search /Filter Files”
from the Actions menu. Use it to limit the number of icons you see in the Icon View
window. For example, to display only files that begin with “d,” type d. To display only
files that end in “.rgb,” type *. r gb.

The Match Content Field

The “Show files containing text” field appears when you choose “Search /Filter Files”
from the Actions menu. Use it to display text files that contain a string of text. ASCII text
files and mail files are searched; other document types are not searched.

The Show All Checkbox

The Scroll Bars
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The Show All checkbox appears when you choose “Search /Filter Files” from the Actions
menu. Click it if you want to display or hide all filtered-out icons.

Scroll bars appear when a window is too small to display all of its contents. Drag the
scroll bar to view the portions of the window that are hidden.
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The Window Sash

The Shelf

The Content Viewer

The Recycle Button
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The window sash appears when you display the shelf on an Icon View window. It splits
the window into two panes. Use the sash to make the shelf larger or smaller.

1. Place the cursor over the small box; then press the left mouse button and drag the
cursor up and down.

A line shows how you are resizing the window panes.

2. Release the mouse button. The window panes change size.

The shelf is a place for you to put icons that you need to use frequently while working in
a particular directory. For example, if the directory contains many files, you might want
to place the files you use most frequently on the shelf. Or, if the directory contains many
color Showcase slides, you might want to place the icon for a color printer onto the shelf.
Drag and drop frequently used applications on the shelf. This creates reference icons to
those applications. When you launch applications from that shelf, new files you create
are automatically stored in that directory. See “Using a Shelf for Convenient Icon Access”
for more details.

Click on an icon to display a read-only version of the selected file in this area. this is
useful when you trying to determine which icon contains the contents you are looking
for.

Place the cursor over the Recycle button; then press the left mouse button to see a list of
directories whose contents you have displayed in the window since it was most recently
opened. Choose an item from this list and the window changes to display the contents of
that directory.
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About Icon View Menus
This section provides basic information on each menu and its commands. Click an item
in the list to get information on a particular menu.
e “The Actions Menu on an Icon View Window”
e “The Selected Menu on an Icon View Window”
e “The Sort Menu on an Icon View Window”
e “The View Menu on an Icon View Window”
e “The Options Menu on an Icon View Window”

e “The Internet Menu on an Icon View Window”

The Actions Menu on an lcon View Window

The “Add New Directory” Command
The “Add New Directory” command creates a new directory labeled enpt y. di r. The
folder icon appears in the window from which you choose the “Add New Directory”
command. If you choose “Add New Directory” from the Selected toolchest, the folder

icon appears on the desktop and is stored in your home directory. See also “Creating and
Opening Directories.”

The “Search/Filter Files” Command
The “Search/Filter Files” command reveals a new set of controls in the Icon View
window. Use it to specify certain file characteristics and to limit the number of icons you

see in the Icon View window. For example, to display only files that begin with “d,” type
d. To display only files that end in “. r gb,” type *. r gb.

The “Select All” Command
The “Select All” command selects all icons on your desktop.

The “Access Files” Command
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This menu contains the following;:

In Automounted Directory
When you select “In Automounted Directory,” the Icon View window
changes to display / host s/ in the path finder. For more information on
accessing files using automount, see “Accessing Remote Files Using
Automount.”

In My Home Directory
Use the “In My Home Directory” command to return the view to your
home directory.

The Selected Menu on an Icon View Window

The “Open” Command

Commands on the Selected menu affect the icons in the window that are selected. The
selected icons are highlighted yellow. You can also access this menu by placing the cursor
over the Icon View window, and then pressing the right mouse button.

The “Open” command opens a selected icon and displays its contents in a window. If you
open a folder icon, you see a window that shows the contents of that directory. If you
open a file icon, you can edit or view the file.

The “Make Copy” Command

The “Make Copy” command makes a copy of the selected icon. The copy is named
copy_of _fi | enamne. If the selected icon is on a shelf, the copy appears on the shelf and
in the directory to which the shelf is attached.

The “Make Reference” Command
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The “Make Reference” command makes a reference to the selected icon. A reference lets
you access an icon from several different places, and give it a unique name in each place.
When you make a reference, a copy of the icon appears next to the original one. It has the
same name as the original, but the name appears italicized and has _r ef attached to
the end of the name.
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Note: When you place an icon on the desktop, on a shelf, or on a page in the Icon Catalog
a reference is automatically created for you. See “Giving Yourself Easy Access to Icons.”

The “Remove” Command

The “Remove” command removes the selected icon from a directory and places it in the
dumpster directory. Once an icon is in the dumpster, you can delete it by choosing “Empty
Dumpster” from the Desktop toolchest.

Note: You can change the behavior of the “Remove” command so that it deletes files
rather than moving them into the dumpster. See “Making “Remove” Delete Instantly.”

The “Print” Command

The “Print” command sends the contents of the selected icon to your default printer. If you
select a folder icon, you print a list of the files in that directory. If you select a file, you
print the contents of the file (text or images, for example).

See also “Printing Files.”

The “Share” Menu

The “Share” menu appears on the menu when you select a folder icon. It includes “Share
With Network”—choose this command if you want to let people who are logged in to
other systems on the network access the selected directory from their own desktops. The
Share a Directory guide appears (after you are asked to log in as root). “Stop Sharing”
reverses the “Share With Network” command if the selected folder icon is currently
shared. The “Publish to OutBox” command publishes a selected file on your OutBox web

page.
The “Change Permissions” Command
The “Change Permissions” command opens the Permissions tool. Refer to the

Permissions tool Help for instructions. For basic background information about
permissions, see “Understanding and Changing Permissions.”
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The “Get Info” Command
The “Get Info” command displays a form that shows detailed information about the

selected file, folder, or application icon. The command is gray and inaccessible if you
have selected another type of icon.

The “What Is This?” Command

This command appears if an icon currently selected in the Icon View window. If the icon
has an overview description, it is launched when you choose “What Is This?”

The Sort Menu on an Icon View Window

The Sort menu contains commands that change the way icons are sorted, or arranged, in
the window.

The “by Name” Command

The “by Name” command arranges icons alphabetically; numerals, then capital letters,
then lowercase letters.

The “by Date” Command

The “by Date” command arranges icons in the window according to the date on which
they were last modified.

The “by Size” Command

The “by Size” command arranges icons in the window according to size (in bytes, from
smallest to largest).

The “by Type” Command

The “by Type” command arranges icons by type.
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The View Menu on an Icon View Window

The View menu contains commands that change the way icons are placed in the window.

The “as lcons” Command

Choose the “as Icons” command to display the contents of a directory as icons scattered
throughout the window.

When “as Icons” is selected, you can also choose to enable or disable the following two
options:

Align To Grid A state that causes icons to automatically align with an invisible grid
when they appear or are placed somewhere—this helps them display in
an orderly manner.

Align All Now A “one time” command that aligns all icons to an invisible grid.

The “as List” Command
When you open a folder icon, the contents of the directory appear as icons. Choose the
“as List” command to view the contents as a sorted list. The list includes

® Theicon name. Tape and disk drive icons include the name of the system to which
the device is connected. File icons include the full pathname so you know the
directory in which the icon is stored.

® The size of the icon in bytes

e The date and time at which the icon was modified

When viewing icons in list format, you can choose “Directory Sizes,” a command that
calculates the current directory sizes.

The “as Columns” Command
Choose “as Columns” from the View menu to organize the icons in a window into

columns. Only the icon name appears. Choose “as List” to see the size and modification
date and time.
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The “as Thumbnail Images” Command

If an Icon View window contains image files, choose “as Thumbnail Images” and each
image file icon is replaced with a small snapshot of the image.

The “Truncate Names” Command

Shortens long file and directory labels so that there is more room in the Icon View
window. Note that does not affect the actual filename, it only affects they way the icon
labels are displayed in the current Icon View window.

The “Hidden Files” Command

Many IRIX configuration files are hidden by default. You do not see them in an Icon View

window. These files are commonly called dot files because a “.” appears as the first
character in the filename. Your . | ogi n and . cshr c files are examples of hidden files.
You can choose to view or hide these files using the “Hidden Files” command. A
checkmark next to the command indicates that the files are displayed in that Icon View
window.

The Options Menu on an Icon View Window

The “Show Shelf” Command

Opens or closes the Icon View shelf. See “Using a Shelf for Convenient Icon Access” for
details.

The “Show Content Viewer” Command

Displays a new area of the Icon View window. When you select a file icon in the window,
the Content Viewer displays a read-only version of a selected file. This allows you to
quickly view file contents without opening the file.

The “Default Layout..” Command

Launches the Default Layout for Icon Views panel. See “Setting Default Icon View
Preferences” for details on this panel.
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The “Apply Default Layout” Command

Instantly applies the default Icon View layout, as defined by the Default Layout for Icon
Views panel.

The “Preserve Layout” Command

Select “Preserve Layout” if you want to maintain the same view of icons when you
switch from one directory to another in a particular window. A red checkmark indicates
it is activated. For example, suppose you are viewing the contents of your home directory
as a list of icons. By default, if you change directories and view the / usr/ peopl e
directory, you revert to the default view of icons. To retain the list view, choose “Preserve
Layout.”

The Internet Menu on an lcon View Window

The “Icon View of a Web Site” Command

Allows you an easy way to display and access the contents of web page in the Icon View.
See “Accessing Files on the Web Using an Icon View Window.”

The “Icon View of an FTP Site” Command
Allows you an easy way to display and access the contents of an FTP site in the Icon View.
See “Accessing Files Using the FTP Command in a Shell.”

Keyboard Shortcuts for Icon View Windows
Many commands in an Icon View window have both a keyboard and a mnemonic
shortcut. Standard keyboard shortcuts are listed on the right side of the menu; mnemonic

shortcuts are indicated by an underlined letter. The following table lists the keyboard and
mnemonic shortcuts.
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Table 13-1 Shortcuts for Commands on Icon View Windows
Command Keyboard Shortcut Mnemonic
“Add New Directory”  Ctrl +n Alt+a;n
“Select All” Ctrl + a Alt+a;a
“File QuickFind” Ctrl + f Alt+a; f
“Close” Ctrl + w Alt+a;w
“Open” Ctrl + o Alt +s;0
“Make Copy” Ctrl + ¢ Alt+s;c
“Make Reference” Alt+s;1
“Remove” Alt +s;r
“Print” Ctrl +p Alt+s;p
“Permissions” Ctrl + e Alt +s;s
“Get Info” Ctrl +1 Alt +s;1i
“by Name” Alt+a;n
“by Date” Alt+a;d
“by Size” Alt +-a; s
“by Type” Alt+a;t
“to Grid” Alt+a; g
“as Icons” Alt+v;i
“as List” Alt+v;1
“as Columns” Alt+v;c
“as Thumbnail Images” Alt+v; g
“Show Shelf” Alt+v;s
“Ignore Layout” Alt+v;i
“Click for Help” Shift + F1 Alt+h;c
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The following techniques also serve as shortcuts:
e Pressthe Ctrl key while dragging an icon to make a copy of the icon.

® Press the Al t key while double-clicking a folder icon to display the contents of the
directory in the current window.

® Press the Al t key while double-clicking on the Icon View window background to
view the parent directory.

* Instead of double-clicking folder icons, enter the pathname of the directory you
want to open in the pathname field at the top of an Icon View window.

* To move backward in the directory path, click on the pathbar above the pathname
field (see “The Path Bar”).

The Desks Overview Window: An Overview

212

The Desks Overview window provides the controls you need to use multiple desks.
Using multiple desks can be helpful in situations such as the following (for example):

¢ From your system, you regularly log on to other systems for certain daily tasks. For
convenience, and to avoid confusion, you can create a different desktop for each
other system you regularly log on to.

* Suppose you spend a portion of your day creating marketing presentations and a
portion of your day reading mail. You can create a desk for each. One desk displays
the windows that you use while you are creating a presentation. The other desk
displays the windows that you use while you are reading and sending mail.

On using the Desks Overview tool:

¢ The Desks Overview window displays a miniature image that represents each desk.
Double-click these to go from one desk to another; drag items between the
miniature desk images to move or copy windows and icons from desk to desk.

¢ Use commands on the Overview window to change the way that desks are
displayed in the window.

e Use commands on the Desks menu to create, rename, and delete desks.

¢ Use commands on the Window menu to manipulate windows on the desk.
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Anatomy of the Desks Overview Window

This section explains each portion of the Desks Overview window.

The Desk Display Area

This area of the Desks Overview window displays a snapshot or button for each of your
desks. Double-click a snapshot or button to go to that desk.

By default, desks are displayed as snapshots. The snapshot shows a miniature version of
each window and icon on the desk. You can drag windows between the snapshots to
move them from desk to desk. Additionally, you can move items on the screen by
moving the miniature window in the snapshot.

The buttons are smaller than the snapshots. You can only use them to go from one desk
to another. To display the desks as buttons, choose “Hide Snapshots” from the Overview
menu.

You can resize the buttons or snapshots using the “Scaling” command on the Desk menu.
See “Resizing Snapshots or Buttons” for details.

The Global Desk

The global desk acts as a template for all other desks. Any windows that you place on the
global desk will automatically appear on all of your desks. See “Placing a Window in All
Desks” for details.

You can hide the global desk if you do not need to work with it frequently. To do so,
choose “Hide Global Desk” from the Overview menu. To display it again, choose “Show
Global Desk.”

About Menus on the Desks Overview Window

This section provides basic information on each menu and its commands. Click an item
in the list to get information on a particular menu.

e  “The Overview Menu”
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e  “The Desk Menu”
e  “The Window Menu”

The Overview Menu
The Overview menu contains commands for changing the appearance of the Desks
Overview window. Click an item in the list for details on that command.
e  “The “Hide Menubar/Show Menubar” Command”
e “The “Hide Global Desk/Show Global Desk Command”
e “The “Show Snapshots/Hide Snapshots” Command”
e “The “Display Window Name” Command”
e “The “Display Icon Name” Command”
e “The “Display No Names” Command”

e “The “Exit” Command”

The “Hide Menubar/Show Menubar” Command

¢ Choose the “Hide Menubar” command to make the menu bar disappear. When the
menu bar is hidden, you can make the Desks Overview window slightly smaller.

You can still access the menus via a pop-up menu. Place the cursor in the window;
then press the right mouse button to reveal a pop-up menu.

¢ Choose the “Show Menubar” command to show the menu bar again.

The “Hide Global Desk/Show Global Desk Command

By default, a snapshot of the global desk appears in the Desks Overview window. If you
do not need to use this desk frequently, choose “Hide Global Desk.” To show the global
desk again, choose “Show Global Desk.”

The “Show Snapshots/Hide Snapshots” Command

* Choose “Hide Snapshots” to display each desk as a button in the Desks Overview
window.
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® Choose “Show Snapshots” to display each desk as a snapshot in the Desks
Overview window. A snapshot is a small picture that contains a miniature version
of each window on the desk. You can drag windows from one snapshot to another
to copy and move windows from desk to desk.

The “Display Window Name” Command

By default, a snapshot for each desk appears in the Desks Overview window. When you
pass the cursor over a window in the snapshot, the name of the window appears. Choose
“Display Window Name” if you want to display the name that appears in the title bar of
the window.

The “Display Ilcon Name” Command

By default, a snapshot for each desk appears in the Desks Overview window. When you
pass the cursor over a window in the snapshot, the name of the window appears. Choose
“Display Icon Name” if you want to see the name that appears on the window when it
is minimized or stowed.

The “Display No Names” Command

The “Exit” Command

The Desk Menu
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By default, a snapshot for each desk appears in the Desks Overview window. When you
pass the cursor over a window in the snapshot, the name of the window appears. Choose
“Display No Names” if you do not want these names to appear.

Choose the “Exit” command when you are finished using the Desks Overview window.
The window disappears from all of your desks.

The Desk menu contains commands that let you create new desks, copy, rename, and
delete desks, and make the contents of the Desks Overview window smaller or larger.
Click an item in the list for details on that command.

e  “The “New Desk” Command”

¢ “The “Copy Selected” Command”
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e  “The “Rename Selected” Command”
e “The “Goto Selected” Command”
e “The “Delete Selected” Command”

* “The “Scaling” Command”

The “New Desk” Command

Choose the “New Desk” Command when you want to create a new desk. A new desk
appears in the Desks Overview window; it is labeled “Desk #.” For instance, suppose you
have three existing desks. Create a new desk and it is named “Desk 4.”

See “Renaming a Desk” to learn how to rename the desk. See “Creating a Desk” to get
step-by-step instructions for creating a new desk.

The “Copy Selected” Command
Select a desk in the Desks Overview window; then choose the “Copy Selected” command
to copy an existing desk. Step-by-step instructions follow.

1. Place the cursor over a desk in the Desks Overview window; then click the left
mouse button to select it. A yellow outline surrounds the selected desk.

2. Choose “Copy Selected” from the Desks menu. A copy of the desk appears in the
Desks Overview window. The label “Copy of” is added to the beginning of the desk
name.

See “Renaming a Desk” to learn how to rename the desk.

The “Rename Selected” Command

Select a desk in the Desks Overview window; then choose the “Rename Selected”
command to rename a desk. “Renaming a Desk” provides step-by-step instructions.

The “Goto Selected” Command

Select a desk in the Desks Overview window; then choose the “Goto Selected” command
to switch to that desk. See “Switching Between Desks” for more details.
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The “Delete Selected” Command

Select a desk in the Desks Overview window; then choose the “Delete Selected”
command to delete the desk. The desk disappears from the Desks Overview window.

The “Scaling” Command

The commands on the Scaling rollover menu let you make the snapshots or buttons in
the Desks Overview window smaller or larger. The first five commands—6%, 7%, 8%,
9%, and 10%—are pre-defined. The last command, “Custom,” lets you choose a custom
setting. The percentage you choose appears next to the “User defined” command.
“Resizing Snapshots or Buttons” provides step-by-step instructions.

The Window Menu

The commands on the Window menu let you manipulate windows—get a list of all the
windows, minimize the windows, and more. Click an item in the list for details on that
command.

e “The “List AlL..” Command”

e “The “Restore All” Command”

e “The “Minimize All” Command”

e “The “Add to Global” Command”

e “The “Remove from Desk” Command”
e “The “Minimize” Command”

e “The “Restore” Command”

e “The “Raise” Command”

e  “The “Lower” Command”

The “List All..."” Command

Choose the “List All...” command to get a list of all the windows that are open. You can
use this list to copy a window to your current desk. See “Listing All the Windows in Your
Desks” for details
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The “Restore All” Command

Choose “Restore All” to open all of the minimized windows in the current desk.

The “Minimize All” Command
Choose “Minimize All” to minimize all of the windows in your current desk. When you

minimize a window, you turn it into a small square that takes up little screen space. To
return the windows to their original size, choose “Restore AlL”

The “Add to Global” Command
Select a window on one of the desks in the Desks Overview window; then choose the
“Add to Global” command to place the selected window on the global desk. Placing a

window on the global desk makes it appear on all desks. See “Placing a Window in All
Desks” for details.

The “Remove from Desk” Command
“Copying Windows Between Desks” explains how you can copy a window from one
desk to another. To remove the window from one desk, select the window in the Desks

Overview display; then choose “Remove from Desk.” If you close the window, you make
the window disappear from all desks.

The “Minimize” Command
Select a window on one of the desks in the Desks Overview window; then choose the

“Minimize” command to turn the window into a small square that takes up little screen
space.

The “Restore” Command

Select a minimized window on one of the desks in the Desks Overview window; then
choose the “Restore” command to open the window again.

The “Raise” Command

Select a window on one of the desks in the Desks Overview window; then choose the
“Raise” command. This pops the window to the top; the entire window is visible.
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The “Lower” Command

The List All Window
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Select a window on one of the desks in the Desks Overview window; then choose the
“Lower” command. The window jumps to the bottom of the stack of windows and
exposes the windows that were beneath it.

The List All window shows you a list of open windows. Double-click an item in the list
to move that window onto your current desk.

“Window Names” and “Icon Names” determine what name appears in the list of open
windows. Click “Window Names” to display the name that appears in the title bar of the
window; click “Icon Names” to display the name that appears on the window when it is
minimized.

The list contains all open windows. Use the scroll bars to view portions of the list that are
hidden. Click an item in the list to select it; double-click an item to display that window

in your current desk.

The Selection area displays the name of the item in the selected item in the list. If you
know the name of the window you want to open, you can type it here.

Press the OK button to copy the selected window to your current desk, and close the List
All window.

Press the Apply button to copy the selected window to your current desk, and keep the
List All window open.

Press the Cancel button to close the window without making any changes.

Note: The List All window provides a list of the windows that are open when you choose
the “List All...” command. The list does not change if you open and close windows while
the List All window is open.
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Keyboard Shortcuts for Desks Overview Commands

Most commands in the Desks Overview window have both a keyboard and a mnemonic
shortcut. Standard keyboard shortcuts are listed on the right side of the menu; mnemonic
shortcuts are indicated by an underlined letter. The following table lists the keyboard and
mnemonic shortcuts for the Desks Overview window.

Table 13-2 Shortcuts for Commands on the Desks Overview Window
Command Keyboard Shortcut Mnemonic
“Hide Menubar/Show Alt+ o, m
Menubar”

“Show Global Alt+o; g
Desk/Hide Global

Desk”

“Show Snapshots/Hide Alt+o;s
Snapshots”

“Display Window Alt+o,w
Name”

“Display Icon Name” Alt +o0;i
“Display No Names” Alt+o;n
“Exit” Ctrl + q Alt+o0; q
“New Desk” Ctrl +n Alt+d;n
“Copy Selected” Ctrl + ¢ Alt+d;c
“Rename Selected” Ctrl +r Alt+d;r
“Goto Selected” Ctrl + o Alt+d; g
“Delete Selected” Alt+d; d
“Scaling” Alt+d;s
“6%" Alt+d;s; 6
“T%" Alt+d;s;7
“8%" Alt+d;s; 8
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Table 13-2 (continued)

Shortcuts for Commands on the Desks Overview Window

Command Keyboard Shortcut Mnemonic
“9%" Alt+d;s; 9
“10%"” Alt +d;s; 10
“User defined” Alt+d;u
“Custom” Alt+d;s; c
“List All...” Ctrl +1 Alt+w; 1
“Restore All” Shift Ctrl + m Alt+w;r
“Minimize All” Ctrl + m Alt+w;n
“Add to Global” Ctrl+g Alt+w; g
“Remove from Desk”  Ctrl +d Alt+w;d
“Minimize” Ctrl + e Alt+w; m
“Restore” Shift Ctrl + e Alt+w;e
“Raise” Alt+w;a
“Lower” Alt+w; 0
“Click for Help” Shift + F1 Alt+h;c

The Launch Window
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The Launch window appears when you press the Alt key while double-clicking an
application icon. Use this window to specify a command line option for an application. See
“Starting Applications with Command Line Options” for a step-by-step example.
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The Search Tool: An Overview

The Search tool helps you find files on your system and on remote systems that you
name. You can find files matching a particular name, size, icon, owner, permissions
setting, or content.

To open the Search tool, select “Search for Files” from the Find toolchest.

Anatomy of the Search Tool

This section describes the main features in the Search tool interface.

The Results Area

The lower portion of the Search Catalog window displays icons that meet the search
criteria. Double-click to open an icon. If you want easy access to any of these icons, drag
them onto the desktop, onto a shelf, or onto a page in the Icon Catalog.

Use commands on the Sort and View menus to change the way these icons are sorted and
displayed. Use commands on the Selected menu to manipulate these icons—copy them
or print them, for example.

The Page Display Area

The page display area shows a tab for each page in the Search tool. You can click a tab to
move from one page to another. Some of the tabs might not fit in the space provided.
When this happens, a stack of unnumbered tabs appears at the left or right edge of the
tab display area. To turn to a page whose tab is hidden:

1. Place the cursor over the stack of unnumbered tabs; then press the left mouse
button.

2. Choose a page number from the menu that appears.
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The Display as Icons Button

Click this button to display the results of a search as icons. This button is equivalent to
the “as Icons” command on the View menu.

The Display as List Button
The results of a search are displayed as icons by default. Click this button to view the

icons as a sorted list. This button is equivalent to the “as List” command on the View
menu.

The Display in Columns Button
Click this button to organize the icons in a window into columns. This button is
equivalent to the “as Columns” command on the View menu.

The Thumbnail Images Button
If the search results contain image files, click this button and the file icon will be replaced

with a small snapshot of the image. This button is equivalent to the “as Thumbnail
Images” command on the View menu.

The Thumbwheel

Use the thumbwheel to change the size of icons in that window. Place the cursor over the
thumbwheel; then drag the cursor up to make the icons smaller or down to make the
icons larger. To revert to the original size, click the small box below the thumbwheel.

About the Search Tool Menus

This section provides basic information on each menu and its commands. Click an item
in the list to get information on a particular menu.
¢ “The Page Menu on the Search Tool”

¢ “The Arrange Menu on the Search Tool”
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e “The View Menu on the Search Tool”
e “The Match Menu on the Search Tool”

The Page Menu on the Search Tool

The “New” Command

The “Rename” Command

224

You can save searches on individual pages. Use commands on the Page menu to move
from page to page, remove pages, and create and save custom searches.

Choose a command name from the list below for more details:

e  “The “New” Command”

¢  “The “Rename” Command”

e  “The “Remove” Command”

e “The “Page up” Command”

e “The “Page down” Command”

e “The “Exit” Command”

The New command returns the Search tool to its default state —a new Search page
appears.

Turn to a page in the Search tool; then choose the “Rename” command to rename a page.
A window appears into which you type the new page name. The title bar and tab change
to display the new name.

The name you choose must be a valid file name. Use only letters, numbers, and
underscores. Avoid inserting blank spaces between words or use characters.

Note: You cannot change the name of default pages.
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The “Remove” Command

Choose the “Remove” command to delete the page you are currently displaying. A
notifier appears asking if you are certain that you want to delete the page.

The “Page up” Command

Choose the “Page up” command to display the previous set of search controls.
The “Page down” Command

Choose the “Page down” command to display the next set of search controls.
The “Exit” Command

Choose the “Exit” command when you are finished using the Search tool. The window
disappears.

The Arrange Menu on the Search Tool
The Arrange menu contains commands that change the way icons are sorted, or
arranged, in the window. Choose a command name from the list below for more details:
“The “by Name” Command”
e “The “by Date” Command”

* “The “by Size” Command”
e “The “by Type” Command”
¢ “The “Align to Grid” Command”

The “by Name” Command

The “by Name” command arranges icons alphabetically: numerals, then capital letters,
then lowercase letters.
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The “by Date” Command

The “by Date” command arranges file icons in the window according to the date on
which they were last modified.

The “by Size” Command

The “by Size” command arranges file icons in the window according to size (in bytes,
from smallest to largest).

The “by Type” Command

The “by Type” command arranges file icons by type.

The “Align to Grid” Command

The “Align to Grid” command snaps the icons to an invisible grid so they are in neat
rows and columns.

The View Menu on the Search Tool
The View menu contains commands that change the way icons are placed in the window.
Choose a command name from the list below for more details:
e “The “as Icons” Command”
e “The “as List” Command”
e “The “as Columns” Command”

¢ “The “as Thumbnail Images” Command”

The “as lcons” Command

Choose the “as Icons” command to display the contents of a directory as icons scattered
throughout the window.
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The “as List” Command

By default, the results of a search are presented as a list of icons. The list includes

¢ Theicon name. Tape and disk drive icons include the name of the system to which
the device is connected. File icons include the full pathname so you know the
directory in which the icon is stored.

* The size of the icon in bytes

e The date and time at which the icon was modified

Choose the “as Icons” command if you have changed the display and want to return to
the default.

The “as Columns” Command

Choose “as Columns” from the View menu to organize the icons in a window into
columns. Only the icon name appears. Choose “as List” to see the size and modification
date and time for files.

The “as Thumbnail Images” Command

Choose “as Thumbnail Images” to replace the standard image file icon with a small
snapshot of that image.

The “Show Query” Command

When you choose “Show Query,” the search controls disappear; you see only the results
area. To display the search controls, choose “Show Query” again.

The Match Menu on the Search Tool

When you choose a command from the Match menu, a new set of search controls appears
in the window. You use these to narrow your search.
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Keyboard Shortcuts for the Search Tool
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Many commands on Search tool menus have both a keyboard and a mnemonic shortcut.
Standard keyboard shortcuts are listed on the right side of the menu; mnemonic
shortcuts are indicated by an underlined letter. The following table lists the keyboard and

mnemonic shortcuts.

Table 13-3 Shortcuts for Commands on the Search Tool
Command Keyboard Shortcut Mnemonic
“New” Alt+p;n
“Rename” Ctrl +r Alt+p;r
“Remove” Alt+p;e
“Page Up” Page Up Alt+p;u
“Page Down” Page Down Alt +p; d
“Exit” Ctrl +q Alt+p; q
“by Name” Alt+r;n
“by Date” Alt+r1;d
“by Size” Alt+1;s
“by Type” Alt+1;t
“Align to Grid” Alt+1; g
“as Icons” Alt+v;i
“as List” Alt+v;1
“as Columns” Alt+v;c
“as Thumbnail Images” Alt +v; gu
“Show Query” Alt+v; q
“Click for Help” Shift + F1 Alt+h;c
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The Icon Catalog: An Overview

The Icon Catalog shows collections of applications and tools that are available on your
system. You can

* Browse through the icons to see what applications are available
¢ Run applications by double-clicking their icons

¢ Find icons you want to use; then drag them onto the desktop or onto a shelf so they
are easily accessible

* Create your own collection of icons. For example, suppose you use a combination of
programs to create and edit movies. You can create a new page; then place icons for
these tools onto that page.

Each collection is stored on a separate page. If you want to create your own collection of
icons, you can add pages to the Icon Catalog.

Reference to the Icon Catalog Controls

This section provides basic information on each Icon Catalog feature.

The Page Display Area

The page display area shows a tab for each page in the Icon Catalog. You can click a tab
to move from one page to another. Some of the tabs might not fit in the space provided.
When this happens, a stack of unnumbered tabs appears at the left or right edge of the
tab display area. To turn to a page whose tab is hidden:

1. Place the cursor over the stack of unnumbered tabs; then press the left mouse
button.

2. Choose a page number from the menu that appears.
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The Display as Icons Button
Click this button to display the contents of the Icon Catalog as icons. This button is
equivalent to the “as Icons” command on the View menu.

The Display as List Button
When you open the Icon Catalog, the contents of the window appear as icons. Click this
button to view the icons as a sorted list. This button is equivalent to the “as List”
command on the View menu.

The Display in Columns Button
Click this button to organize the icons in a window into columns. This button is
equivalent to the “as Columns” command on the View menu.

The Thumbnail Images Button
If the Icon Catalog contains image files, click this button and the file icon will be replaced

with a small snapshot of the image. This button is equivalent to the “as Thumbnail
Images” command on the View menu.

The Thumbwheel
Use the thumbwheel to change the size of icons in that window. Place the cursor over the
thumbwheel; then drag the cursor up to make the icons smaller or down to make the
icons larger. To revert to the original size, click the small box below the thumbwheel.

The Page Menu on the Icon Catalog

Each page in the Icon Catalog contains a collection of icons. You use commands on the
Page menu to move from page to page and to create and remove pages.

Choose a command name from the list below for more details:

e “The “New” Command”
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The “New” Command

The “Rename” Command

The “Remove” Command

The “Up” Command

The “Down” Command
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e “The “Rename” Command”
e “The “Remove” Command”
e “The “Up” Command”

e “The “Down” Command”

e  “The “Exit” Command”

The “New” command adds a new, empty page to the Icon Catalog.” Use the dialog that
pops up to specify a name for the new page. The new page is listed on the Find toolchest
menu.

Turn to a page in the Icon Catalog; then choose the “Rename” command to rename a page
in the Icon Catalog. A window appears into which you type the new page name. The title
bar and tab change to display the new name and this name appears on the Find toolchest.

Note: You cannot rename the system’s default Icon Catalog pages, you can only rename
pages that have been added.

Choose the “Remove” command to delete the page you are currently displaying. A
notifier appears asking if you are certain that you want to delete the page. You cannot
remove the default pages. Turn to a default page, choose the “Remove” command, and
you make any icons that you added to the page disappear.

Choose the “Up” command to display the previous page in the Icon Catalog.

Choose the “Down” command to display the next page in the Icon Catalog.
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The “Exit” Command

Choose the “Exit” command when you are finished using the Icon Catalog. The window
disappears.

The Selected Menu on the Icon Catalog

The “Open” Command

Commands on the Selected menu affect the icons in the catalog that are selected. You can
also access this menu by placing the cursor over background of the Icon Catalog, then
pressing the right mouse button.

Choose a command name from the list below for more details:

“The “Open” Command”

“The “Make Reference” Command”
“The “Remove” Command”

“The “Print” Command”

“The “Get Info” Command”

“The “Select All” Command”

“The “File QuickFind” Command”
“The “What Is This?” Command”

The “Open” command opens the currently selected icon.

The “Make Reference” Command
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The “Make Reference” command creates a a referenced copy of a selected icon. The
reference icon is a pointer to the original. You can drag it into an Icon View window, or
onto a different page in the Icon Catalog, allowing you to access the icon from different
places. See also “Making a Referenced Copy of an Icon.”
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The “Remove” Command

The “Print” Command

The “Get Info” Command

The “Remove” command removes the selected icon and places it in the dumpster
directory. Placing a file in the dumpster is the first step to deleting the file from your
computer’s disk. See “Removing Files and Reference Icons.”

Note: You can change the behavior of the “Remove” command so that it deletes files
rather than moving them into the dumpster. See “Making “Remove” Delete Instantly.”

The “Print” command sends the contents of the selected icon to your default printer. If you
select a folder icon, you print a list of the files in that directory. If you select a file, you
print the contents of the file (text or images, for example).

The “Get Info” command displays a form that shows detailed information about the
selected file, folder, or application icon. The command is gray and inaccessible if you
have selected another type of icon.

The “Select All” Command

The “Select All” command selects all icons on your in the display.

The “File QuickFind” Command
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The “File QuickFind” command opens a window into which you can type the name of
anicon you want to find. For example, suppose you want to place the IRIS Showcase icon
on the shelf for a a particular Icon View window. Choose “File QuickFind”; then type
showcase in the type-in field. The icon appears. For further details, see “Finding Files,
Applications, or Directories Using File QuickFind.”
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The “What Is This?” Command

Some icons contain overview descriptions. To see if an icon has a description, select the
icon, then choose “What Is This?” from the Selected menu.

The Sort Menu on the Icon Catalog

The Arrange menu contains commands that change the way icons are sorted, or
arranged, in the window. Choose a command name from the list below for more details:

e “The “by Name” Command”
e “The “by Date” Command”
e “The “by Size” Command”

e “The “by Type” Command”

The “by Name” Command

The “by Name” command arranges icons alphabetically; numerals, then capital letters,
then lowercase letters.

The “by Date” Command

The “by Date” command arranges file icons in the window according to the date on
which they were last modified.

The “by Size” Command

The “by Size” command arranges file icons in the window according to size (in bytes,
from smallest to largest).

The “by Type” Command

The “by Type” command arranges icons by type.

234 007-1342-170



Reference to the Icon Catalog Controls

The View Menu on the Icon Catalog

The “as lcons” Command

The “as List” Command
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The View menu contains commands that change the way icons are placed in the window.
Choose a command name from the list below for more details:

“The “as Icons” Command”
“The “as List” Command”
“The “as Columns” Command”

“The “as Thumbnail Images” Command”

Choose the “as Icons” command to display the contents of a directory as icons scattered
throughout the window.

When “as Icons” is selected, you can also choose to enable or disable the following two
options:

Align To Grid: A state that causes icons to automatically align with an invisible
grid when they appear or are placed somewhere—this helps them display in an
orderly manner.

Align All Now: A “one time” command that aligns all icons to an invisible grid.

When you open a folder icon, the contents of the directory appear as icons. Choose the
“as List” command to view the contents as a sorted list. The list includes:

The icon name. Tape and disk drive icons include the name of the system to which
the device is connected.

The size of the item in bytes.
The date and time at which the item was last modified.
The permissions description.

The type of item it is, such as “directory” or “Web jumpsite.”

When viewing icons in list format, you can choose “Directory Sizes,” which is a
command that calculates the current directory sizes.
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The “as Columns” Command
Choose “as Columns” from the View menu to organize the icons in a window into

columns. Only the icon name appears. Choose “as List” to see the size and modification
date and time.

The “as Thumbnail Images” Command

If an Icon View window contains image files, choose “as Thumbnail Images” and each
image file icon is replaced with a small snapshot of the image.

Keyboard Shortcuts for the Icon Catalog

Many commands on Icon Catalog menus have both a keyboard and a mnemonic
shortcut. Standard keyboard shortcuts are listed on the right side of the menu; mnemonic
shortcuts are indicated by an underlined letter. The following table lists the keyboard and
mnemonic shortcuts.

Table 13-4 Shortcuts for Commands on the Icon Catalog

Command Keyboard Shortcut Mnemonic
“New Page” Ctrl +n Alt+p;n
“Rename” Ctrl +r Alt+p;r
“Remove” Alt+p;e
“Up” Page Up Alt+p;u
“Down” Page Down Alt +p; d
“Exit” Ctrl + q Alt+p; q
“Open” Ctrl + o Alt+s;0
“Remove” Alt+s;e
“Print” Ctrl +p Alt+s;p
“Get Info” Ctrl +1 Alt+s;i
“File QuickFind” Ctrl + f Alt +s; f
“by Name” Alt+1;n
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Table 13-4 (continued)

Shortcuts for Commands on the Icon Catalog

Command Keyboard Shortcut Mnemonic
“by Date” Alt+r1;d
“by Size” Alt+1;s
“by Type” Alt+1;t
“Align to Grid” Alt+v; g
“as Icons” Alt+v;i
“as List” Alt+v;1
“as Columns” Alt+v;c
“as Thumbnail Images” Alt+v;u
“Click for Help” Shift + F1 Alt+h;c

Anatomy of the Color Scheme Browser Window

The Schemes List

The Sample Images
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The schemes list contains a list of schemes available on your system. You can choose a
scheme you like and apply it to your desktop. You can also edit colors in a scheme and
save these changes to the current scheme or to a scheme you create.

Every item in a window is assigned a color. The Color Scheme Browser contains several
sample images that display a scheme’s assigned colors for each of these items. These

sample images include:

¢ “Basic Colors” displays a scheme’s colors for the most frequently used items in a
window, including buttons, scroll bars, and text input areas.

e “Additional Colors” displays a scheme’s colors for any additional items in a
window, including scrolled list items, accent colors, and errors.
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e “Window Manager Colors” displays a scheme’s colors for window borders.

® “Graphics Colors” displays fixed colors that applications assign to specific items
when they want a color to have a consistent and recognizable meaning. These colors
do not change color as schemes change. They merely darken or lighten in color,
depending on the scheme.

The Color Palette

The Color Palette contains a colored square for each color used in the displayed scheme.
To find the assignment of a color, choose “Quick Help” from the Help menu, then move
your cursor on top of a colored square to see the assignment. Click on a colored square
to edit or change a color.

The Shade Wheel

Move the shade wheel back and forth to lighten or darken the colors in a scheme. Click
the button to the right of the shade wheel to return to the default shade.

The Color Scheme Browser Menus

The Color Scheme Browser contains the following menus:
¢ “The Application Menu”

* “The Sample Image Menu”

e “The Help Menu”

The Application Menu

The application menu contains the following commands:
e “The Save As Command”
e “The Remove Local Schemes Command”

e “The Remove Selected Scheme Command”
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e “The Edit Mode Command”

e  “The Exit Command”

The Save As Command
Use the “Save As” command when you want to save edits to a new scheme file rather

than to the original scheme. When you save the file to the new name, the new scheme
name appears in the schemes list.

The Remove Local Schemes Command
Use the “Remove Local Schemes” command to delete all edits made to schemes and
return all schemes to their default colors. When you remove local schemes, names of

schemes that contained edits change back from italic to the default font. Removing local
schemes removes edits made to schemes on your account only.

The Remove Selected Scheme Command

Use the “Remove Selected Scheme” command when you want to remove local edits
made to a selected scheme or when you want to remove a scheme you created.

The Edit Mode Command
Choose “Edit Mode” when you want to change colors in a chosen scheme. Click on a

color in the Color Palette to open the Scheme Editor Color Browser and change the color.
Use “Quick Help” to find color assignments for colors in the scheme.

The Exit Command

Choose “Exit” when you finish using the Color Scheme Browser. The window closes.

The Sample Image Menu

The sample images menu contains the following:
e “The Basic Colors Command”

e “The Additional Colors Command”
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* “The Window Manager Colors Command”
¢ “The Graphics Colors Command”

e “The Active Guides Colors Command”

The Basic Colors Command

“Basic Colors” displays a scheme’s colors for the most frequently used items in a
window, including buttons, scroll bars, and text input areas.

The Additional Colors Command

“Additional Colors” displays a scheme’s colors for any additional items in a window,
including scrolled list items, accent colors, and errors.

The Window Manager Colors Command

“Window Manager Colors” displays a scheme’s colors for window borders.

The Graphics Colors Command

“Graphics Colors” displays fixed colors that applications assign to specific items when
they want a color to have a consistent and recognizable meaning. These colors do not
change color as schemes change. They merely darken or lighten in color, depending on
the scheme.

The Active Guides Colors Command
“Active Guides Colors” displays a scheme’s link colors. Links appear in Active Guides,

such as many of the personal system administration programs you can launch from the
System Manager.

The Help Menu

The Help menu provides help on the Color Scheme Browser.

® Use “Click for Help” when you want information on an item in the Color Scheme
Browser window. Choose “Click for Help.” The cursor changes into a question
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mark. Move the question mark on top of an item, then click on the item for
information.

Use “Quick Help” when you want to know the assignments of colors in a chosen
scheme. Choose “Quick Help,” then move your cursor over items in the sample
scheme display and the Color Palette. The assignment for each color appears next to
the cursor and at the bottom of the Color Scheme Browser window.

Use the other menu items for information on how to use the Color Scheme Browser.

Understanding the makeDotDesktop Window

This section includes:

“When makeDotDesktop Appears”
“The Purpose of makeDotDesktop”
“How to Use makeDot Desktop”

When makeDotDesktop Appears
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The makeDotDesktop window automatically appears under the following
circumstances:

You have login accounts on several systems; you have mounted your home directory
so that you use the same home directory on all systems; and you are logging in to
one of the systems for the first time.

You have changed the name of your system.

You can access this window from the Toolchest if you want to change a previous setting.
Choose Desktop > Customize > Environment Setup.

Note: Changes made to makeDotDesktop at login take effect right away, whereas
changes made after you are already logged in take effect the next time you log in to any
of the systems that have mounted your home directory.
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The Purpose of makeDotDesktop

The makeDotDesktop window lets you choose whether you want your desktop to be the
same as or different from the desktop on the other systems you use. This is controlled via
the ~/ . deskt op- <host name> directory, where the “session state” is remembered,
which includes desktop configurations such as:

e Which applications were running when you logged out

e Which screen saver you had chosen

e What backgrounds and customized color schemes you were using
e  Where windows were placed

e Which directories were open

e Status of any extra desks you have set up

How to Use makeDot Desktop

You have the following choices:

¢ Create a new environment
If you want the desktop on the current system to be unique, check the box next to
“Create a new environment.” Your working environment will be unique to that
system. This option desirable if, for example, only one of the systems you work on
runs a specific application and you want that particular desktop tailored in some
way to that application. In such a case, you should check “Create a new
environment” when the makeDotDesktop window appears on that system.

¢ Copy the environment from the selected machine
If you want to use another system’s current desktop as a starting point, select a
system from the list at the top of the window; then check the box next to “Copy the
environment from the selected machine.” This allows you to start with the same
desktop environment attributes, but any further changes you make are only applied
to the system you are currently working on.

* Share (link) the desktop environment with the selected machine
If you want the desktop on all systems to be the same, every time you log in to any
of the systems, select a system from the list at the top of the window; then check the
box next to “Share (link) the desktop environment with the selected machine.” In
this case, if you make changes to the desktop environment on SystemA, then when
you log in to your account on SystemB, those changes will be on SystemB as well.
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Likewise, when you make changes to the desktop environment on SystemB, then
log in to your account on SystemA, those changes also appear on SystemA.

Tip: The “Share (link) the desktop environment with the selected machine” option
is recommended because it conserves disk space and maintains a consistent
environment for all your login accounts.

If you frequently log in to different systems that share the same home directory and you
do not want to have to make this choice each time, you can check “Always create, copy,
or share as chosen above.” In this case, the makeDotDesktop window will not appear
again, unless you select it from the Toolchest.

About the Error Message Window

By default, many applications display error messages in dialog boxes. On occasion, an
application displays an error message in the console window. You can change this
behavior so that hidden error messages are displayed in this pop-up window. To disable
the output window, open the Desktop Settings control panel, then click Display
Application Errors. The window is disabled when the checkmark disappears.

007-1342-170 243






Appendix A

007-1342-170

Using IRIX Commands

The IRIX Interactive Desktop allows you to work with the IRIX operating system by
pointing at and clicking on icons. You can also use the traditional interface to IRIX — the
shell.

This Appendix explains how to start and stop IRIX shells and teaches you how to use
some basic IRIX commands. It contains these sections:

¢ “Opening a Shell Window”

e “Using IRIX Commands: A Few Basics”

e “A Quick Reference to IRIX Commands”

¢ “A Quick Reference to IRIX Shortcuts”

¢ “Determining Your Current Working Directory”

* “Moving to a Different Directory Using the cd Command”

¢ “Viewing the Contents of a Directory Using the Is Command”

® “Creating Directories Using the mkdir Command”

¢ “Viewing the Contents of a Directory Using the dirview Command”

¢ “Copying a File or Directory Using the cp Command”

*  “Accessing an Icon from Several Different Directories Using the In Command”
¢ “Renaming and Moving Files Using the mv Command”

¢ “Deleting Files Using the rm Command”

¢ “Deleting Directories Using the rm and rmdir Commands”

¢ “Printing Using IRIX Commands”

® “Setting Permissions Using the chmod Command”

* “Getting Reference Information on IRIX Commands”
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Opening a Shell Window

The shell is the traditional interface to UNIX workstations. It is a window in which
you type IRIX commands, and it is identical in structure to other windows. You can
start additional shells by choosing “Open Unix Shell” from the Desktop toolchest.
The shell window appears. Its fixtures look like those on other windows, but inside
the body is a prompt (often a # or % sign) and a square cursor. See Figure A-1.

|=|. winferin o |:I

You hay

Figure A-1 A Shell Window
Move the cursor inside the window. Notice that the title bar highlights and the small

green rectangle becomes solid. This indicates that the window is active; you can begin
typing commands.
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Using IRIX Commands: A Few Basics

This section provides information on pathnames and background processes.

Understanding Pathnames

There are two types of pathnames: absolute pathnames and relative pathnames. An
absolute pathname provides complete directions to a location in the IRIX file system,
starting from the topmost directory. / usr/ peopl e/ j oe/ reports and

[ usr/ peopl e/ j oe/ Budget s/ budget 92 are examples of absolute pathnames.

A relative pathname is based on the directory in which you are currently working. For
example, if youarein / usr/ peopl e/ j oe and want to open a filenamed r eport s, you
type: jot reports. If you want to open a file in a subdirectory called Budget s, you

type:

j ot Budget s/ filename

Using Background Processes

When you use IRIX commands to run an application, you can end the command line
with the ampersand sign (&). This runs the application in the background so you can
type other commands in the shell window and minimize the shell without quitting from
the application.

Certain commands probably should not be run as background processes — the vi text
editor for example. vi lets you create or edit a text file within the shell window. If you
typevi & Vi runs the but the text never appears in the shell window; you cannot read
or edit the text.
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A Quick Reference to IRIX Commands
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See Table A-1 lists the IRIX commands discussed in this chapter and provides a quick
summary and example for each.

Table A-1 Summary of IRIX Commands
Command Use Example
pwd To determine your pwd
current working This displays the name of the directory in which you
directory. are working.
cd To change (move)toa cd /usr/tnp
different directory. This moves you to the / usr/ t np directory.
I's To list the contentsofa |'s /usr/tnp
directory. This lists the contents of the / usr/ t np directory.
di rvi ew To open a Directory dirview /usr/tnp
View window that This opens a Directory View window for the
displays the contents of / usr/t np directory.
a directory.
nkdi r To create new nkdir reports
directories. This creates a r epor t s directory in your current
working directory.
cp To copy a file or cp oldfile oldfile.copy
directory. This creates a copy of ol df i | e and names it
oldfile.copy.
I'n To create a linked copy I n i mages novi es/i mages
of a file. This lets you  This lets you access the file i mages from a directory
access one file from called movies.
several different places.
nv To move and rename mv ol dfi |l ename newfil ename
files and directories. This renames ol df i | enane.
rm To delete files. rmoldfile

This deletes ol df i | e.
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Table A-1 (continued) Summary of IRIX Commands
Command Use Example
rm-r To delete all the filesina rm -r /usr/peopl e/joe/reports
directory before This deletes all of the files in the r epor t s directory;
deleting the directory  then deletes the r epor t s directory.
itself.
rdir To delete empty rmdir /usr/people/joe/reports
directories. This deletes the r epor t s directory.
I p To print files. | p i mages
This prints the file i mages.
| pstat To check the print | pstat -s
queue. This provides a summary of your print requests.
chrod To change permission ~ chnod go-wx i mages
settings for a file. This takes away write and execute permissions for
Group and Other.
man To open the man page man | p
for an IRIX command.  This opens the man page for the | p command.
man -t This lets you print the  man -t |p

specified man page.

This prints the man page for | p on your default
printer.

A Quick Reference to IRIX Shortcuts
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Certain special characters act as shortcuts.See Table A-2 contains a list of these characters
and an explanation of their use.

Table A-2 IRIX Shortcuts
Character Use Example
*(wildcard) A substitute for any I's *.doc

number of characters.

A substitute for one
character.

This lists all files in the current directory ending in .doc.

I's ch?.doc

This lists all files in the current directory that begin
with ch followed by one other character, and end with
. doc. For example, chl. doc, ch2. doc, and so on.
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Table A-2 (continued)

IRIX Shortcuts

Character

Use

Example

An abbreviation for the
current working
directory

An abbreviation for the
parent directory

An abbreviation for your
home directory

A command to repeat the
last command you typed.

A symbol for replacing
characters.

dirview .
This opens a Directory View window for your current
directory.

cd ..
This moves you up one directory.

cd ~/reports
This moves you to the r epor t s directory in your
home directory.

cp chl.doc /usr/tnmp
NIN2
This reissues the command using ch2. doc.

Determining Your Current Working Directory
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The title bar of a Directory View windows lists the name of the directory whose contents
it displays. When you are typing commands in a shell window, you use the pwd
command to find out the name of the directory in which you are located. pwd stands for
print working directory, or loosely translated, “Where am I?”

1. Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page A-246 for step-by-step instructions.

2. At the prompt, type:

pwd

Then press Ent er.

The IRIX shell responds with a pathname.
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Moving to a Different Directory Using the cd Command

cd is the IRIX command for changing from one directory to another. To use it:

1.

Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page A-246 for step-by-step instructions.

Type cd, followed by the name of the directory to which you want to switch. For
example, to switch to a directory named / usr/t np, type:

cd /usr/tnp

Then press Ent er.

Shortcut: Two periods (..) is an abbreviation for the name of the parent directory. In other
words, it says to go up one directory. Suppose you are working in

[ usr/ peopl e/ j oe/ Report s and want to move to/ usr/ peopl e/ j oe/ | mages.
You can type:

cd ../l mges

cd alone takes you to your home directory.

Viewing the Contents of a Directory Using the Is Command
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I's is the IRIX command for opening and displaying the contents of a directory. To use
the | s command:

1.

2.

Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page A-246 for step-by-step instructions.

Use the cd command to move to the directory whose contents you want to view.
For example, type:

cd /usr/ peopl e/ <loginname>

Then press Ent er.
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3. Type:

I's
Then press Ent er.
The contents of your home directory appear as a list.
IRIX can give you a more informative listing when you use an option with the | s
command.
¢ The -a option lists all of the files, even those that begin with a period (.)
¢ The -F option with | s:
—  Puts an asterisk (*) next to all programs
— Puts a trailing slash (/) after all directories

— Does not add any characters to plain text files

Viewing the Contents of a Directory Using the dirview Command

di r vi ewis the IRIX command to open a Directory View window. Directory View
windows display the contents of a directory graphically. To use the di r vi ewcommand:

1. Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page A-246 for step-by-step instructions.

2. Typedi rvi ew followed by the name of the directory whose contents you want to
display in a Directory View window. For example, to open a Directory View
window for / usr/ sbi n, type:

dirview /usr/shin

Shortcut: To open a Directory View window for the directory you are currently working
in, type:

dirview .

A period (.) is an abbreviation for the name of your current working directory.
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Creating Directories Using the mkdir Command

nkdi r is the IRIX command for making a new directory. This example shows how to
make a new directory called sub in your home directory.

1.

2.

3.

Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page A-246 for step-by-step instructions.

Use the cd command to move to the directory in which you want to create a new
directory. For example, type:

cd /usr/peopl e/ <loginname>

Then press Ent er.

Type:

nkdir sub

Then press Ent er.

This command creates a directory called sub in your home directory.

See “Creating a Directory” in Chapter 4 to learn how to create new directories using
the graphical interface.

Copying a File or Directory Using the cp Command
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cp is the IRIX command for copying files and directories. This example shows how to to
copy a file called ol df i | e.

1.

Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page A-246 for step-by-step instructions.

Type:
cp oldfile oldfile.copy

Then press Ent er.

This command means “copy ol df i | e from my current working directory into a file
named ol df i | e. copy in my current working directory.” To place the copy in a
different directory, add a pathname before the new file name.
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See “Copying Files or Directories” in Chapter 4 to learn how to copy files using the
graphical interface.

Accessing an Icon from Several Different Directories Using the In
Command

| nis the IRIX command for creating linked copies. A linked copy lets you create different
names for one file. Suppose you have a file named i mages in/ usr/ peopl e/ j oe. You
work in/ usr/ peopl e/ j oe/ movi es quite frequently and want to easily access the

i mages file.

1. Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page A-246 for step-by-step instructions.

2. Use the cd command to move to the / usr/ peopl e/ j oe directory. Type:
cd /usr/ people/joe
3. Then type:

I'n -s images novi es/inages

Note: You could also give the file a different name.

See “Making a Referenced Copy of an Icon” in Chapter 4 to learn how to make linked
copies using the IRIX Interactive Desktop.

Renaming and Moving Files Using the mv Command

nv is the IRIX command for renaming and moving files and directories.

To rename a file using the mv command:
1. Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page A-246 for step-by-step instructions.
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2. Type:
mv ol dfi | enane newfil enane

ol df i | enane is now named newf i | enane.

Note: Do not use blank spaces when renaming files using IRIX commands. IRIX
does not replace blank spaces with underscores, so you'll have problems accessing
the file later.

Tomove ol dfi | e from / usr/ peopl e/ j oe to/ usr/tnp:
1. Place the cursor in the shell window.
2. Type:
nmv ol dfi |l enarme /usr/tnp/ol dfil ename
See “Renaming Files and Directories” in Chapter 4 to learn how to rename files using the

graphical interface; see “Moving and Copying Files and Directories” in Chapter 4 to
learn how to move files using the graphical interface.

Deleting Files Using the rm Command
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r mis the IRIX command for deleting files. You type r mfollowed by the name of the file
you want to delete. For example, to delete a file named ol df i | e:

1. Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page 246 for step-by-step instructions.

2. Type:
rmoldfile
This deletes the file named ol df i | e in your current working directory.

See “Removing Files and Reference Icons” in Chapter 4 to learn how to delete files using
the “Remove” command.
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Deleting Directories Using the rm and rmdir Commands
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r mdi r is the IRIX command for deleting an empty directory; an option to the r m
command lets you delete a directory and all of the files it contains.

To delete an empty directory:

1.

Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page 246 for step-by-step instructions.

Use the cd command to move to the directory that contains the empty directory
you want to delete. For example, if you want to delete a directory named ol df i | es
in /usr/ peopl e/ j oe, type:

cd /usr/ peopl e/joe
Then press Ent er.
Type:

rodir oldfiles
Then press Ent er.

The ol df i | es directory is deleted.

To delete a directory and all of the files it contains:

1.

Use the cd command to move to the directory that contains the directory you want
to delete. For example, if you want to delete a directory named ol df i | es in
[ usr/ peopl e/ j oe, type:

cd /usr/ peopl e/ joe
Then press Ent er.
Type:

rm-r oldfiles
Then press Ent er.

This deletes all of the files in the directory then deletes the ol df i | es directory
itself.
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Printing Using IRIX Commands

You can easily print from your IRIS workstation using the graphical tools and menu
commands. This section describes an alternative — printing using the | p command and
checking the status of a print request using the | pst at command.

Printing Using the Ip Command

| p is the IRIX command for printing a file. You type | p followed by the name of the file
you want to print. The file prints on your default printer. For example, to print a file
named i mages:

1. Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page 246 for step-by-step instructions.

2. Type:
| p i nages
Then press Ent er.
To print to a printer other than the default, you can use the - d option to | p. For example,
to print i mages to a printer named printer2, you would type:
Ip -dprinter2 images

See the Personal System Administration Guide for instructions on installing the printer. See
the | p man page for a list of all the available options and capabilities.

Checking the Print Queue Using the Ipstat Command
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| pst at is the IRIX command for displaying the list of print requests that have been sent
to a printer. The - s option provides a summary of your print requests.

1. Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page 246 for step-by-step instructions.
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2. Type:
| pstat -s
Then press Ent er.
See “Viewing the Queue of Print Jobs” in Chapter 5 to learn how to use the Print Manager

to check the status of your print requests. See the | pst at man page for a list of all the
available options and capabilities.

Setting Permissions Using the chmod Command
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chnod is the IRIX command you use to change permission settings for a file. You can
specify Read (r), Write (w), and Execute (x) permissions for the file’s owner (u), the group
(g), and others (o).

You type chnod followed by the permission setting information followed by the file
name whose settings you are changing. The permission setting information has several
parts. You specify:

* Who is affected by the change (u, g, 0)

®  Whether you are adding or taking away permissions

e  Which permissions are affected (r, w, x)

For example, suppose you have a file named i mages that everyone can read, write, and
execute. You decide you want to prevent all others from writing and executing the file.
1. Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page 246 for step-by-step instructions.

2. Type:
chnod go-wx i nages

Then press Ent er.

See “Changing Permissions” in Chapter 9 to find out about an easy-to-use interface for
changing permissions.
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Getting Reference Information on IRIX Commands

By default, your IRIS workstation contains online man pages that have information on
all IRIX commands. For example, to access a man page for the | s command:

1. Place the cursor in the shell window.

To open a shell window, choose “Shell” from the Tools toolchest. See “Opening a
Shell Window” on page 246 for step-by-step instructions.

2. Type:
man |'s
Then press Ent er.

After a few moments the man page is displayed.

Note: The -t option lets you print a man page. For example, to print the man page for
the | p command, you type:
man -t Ip
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NEdit and jot

NEdit and jot are two commonly used text editors that run on Silicon Graphics
workstations. Although NEdit is the default editor for IRIX, both editors are described in
this appendix.

To start NEdit or jot, open the Find menu in the Toolchest, select Applications, and click
on the appropriate icon. To start either editor from a shell window, type the name of the
editor (use all lowercase characters).

Tip: When you run NEdit or jot from a shell, you can run it in the background so that
your cursor is returned to you. For example, to run NEdit in the background, enter
nedi t &

Whether you are using NEdit or jot, to protect your work, save your file periodically. To
save your document, use the following procedure:

1. Choose “Save” from the File menu.

If your document is untitled, the first time you choose “Save,” the “Save As...”
dialog box appears. Enter a filename, or a complete pathname, for your new jot
document. Using the Save command thereafter simply saves any modifications you
have made to your document, and no dialog box appears.

Remember that capitalization is important: file and File are two different files.

2. PressEnter.

Choose the “Save As...” command to save a copy of your document under a different
filename.
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About NEdit

NEdit is a standard graphical user interface (GUI) text editor for programs and plain text
files. NEdit offers the following features:

e NEdit provides standard menu, dialog, editing, and two-button mouse support.
e NEdit offers standard keyboard shortcuts and menu accelerators.

¢ In NEdit you can have any number of files open at the same time.

e NEdit offers several methods for copying and moving text.

¢ NEdit offers a search function that includes finding and replacing selectively,
case-sensitive searching, use of regular expressions, and forward and backward
searching.

¢ NEdit allows you to shift blocks of text or align text
¢ NEdit offers a number of print options

e NEdit allows you to customize your editing environment through the use of the
Preferences menu and through the use of macros. Advanced features include
execution of UNIX shell commands from within NEdit.

e NEdit offers special features for programmers, including indentation, matching
characters, and the use of tags files.

NEdit contains the following pulldown menus:

* The File menu contains operations to let you work in NEdit files.1

¢ The Edit menu lets you modify text in NEdit file.

® The Search menu lets you identify a search target by highlighting text or by typing a
string, singly or globally replace text, go to specified line numbers or selected text,
mark locations, go to marked locations, and match characters (such as parentheses).

® The Preferences menu lets you customize your NEdit environment.
® The Shell menu lets you execute UNIX shell commands.

® The Macro menu lets you map program keys and perform other advanced
functions.

* The Windows menu lets you customize the panes to split or full.

¢ The Help menu contains files that explain how to work with NEdit.

262 007-1342-170



About NEdit

NEdit operates in two different modes-Short Menus mode (the default) and Full Menus
mode. In Short Menus mode, some commands are restricted (mostly shell scripts,
macros, and some special features for programmers). These features are marked "Full
Menus mode" in the help text.

To switch between the two modes, choose Preferences > Short Menus. You can find more
information about Short Menus and Full Menus modes by clicking on the Help menu at
the far right of the NEdit menu bar and selecting Customizing NEdit.

The remainder of this section contains the following topics:

e “Working with NEdit Files”

* “Using Keyboard Shortcuts”

e “Moving Around in a NEdit File”

*  “Setting Print Options”

* “Moving Around in Your Filesystem”

* “Using Advanced Features in NEdit”

Working with NEdit Files
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With NEdit you can edit as many files at the same time as you wish. The File menu
contains the following menu items:

New Opens a new file.

Open Opens an existing file.

Open Selected Opens a file whose name you have selected in your current window
(Full Menus mode only).

Save Saves the file.

Save As Renames the file before saving it.

Revert Reverts to a previously saved version of the file.

Include File Inserts a specified file into the file you are editing.

Load Tags File Loads a tags file that was generated using the UNIX ct ags command.
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Print Prints the file to your default printer or any other specified printer. You
can specify options such as number of copies, nondefault banner, paper
size, and so on.

Close Closes the file.
Exit Exits NEdit.

The Edit menu lets you copy and paste and perform other functions that modify text.
This menu contains the following items:

Undo Reverses any modifications that you make.

Redo Lets you change back to what you just undid.

Cut Lets you delete highlighted text and retains it in the paste buffer.
Copy Copies highlighted text to the paste buffer.

Paste Pastes text from the paste buffer.

Paste column Performs the same function as Paste.

Delete Lets you delete highlighted text by using the Del et e key. Text is not
retained in the paste buffer.

Select All Highlights all of the text.

Shift Left Shifts text to the left.

Shift Right Shifts text to the right.
Lower-Case = Changes highlighted text to all lowercase.
Upper-Case  Changes highlighted text to all uppercase.
Fill Paragraph Fills leading spaces within a paragraph.
Insert Form Feed
Inserts a form feed character.
Insert Ctrl Code
Insertsa Ctrl code.
Overtype Lets you type in overtype mode instead of insert mode.

Read Only Locks the file in read-only mode.
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Tip: Pressing the right mouse button anywhere in the window opens a popup menu that
contains the Undo, Redo, Cut, Copy, and Paste commands.

You can obtain more information on NEdit features from the Help menu at the far right
of the NEdit menu bar.

Using Keyboard Shortcuts

NEdit lets you use control and function keys instead of pulling down menus with the
mouse.The menu shortcuts are shown on the right side of the menus. For example, under
the File menu, the “New” command is followed by Ct r | + N. Hold down the Ct r| key
and type N to invoke the “New command.” The letter you type is not case-sensitive, so
you can type N or n.

There are other NEdit shortcuts that are not as obvious. With these, some of the letters
you type are case-sensitive. You can find information about the following shortcuts by
clicking on the Help menu at the far right of the NEdit menu bar and selecting Keyboard
Shortcuts:

e Menu Accelerators

¢ Menu Mnemonics

e Keyboard Shortcuts Within Dialog Boxes
e Labeled Function Keys

e Modifier Keys

e PC Standard Keyboard

Moving Around in a NEdit File
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The following topics describe procedures for moving around in a NEdit file:
¢ “Selecting Text with the Mouse”

¢ “Cutting and Pasting Text”

e “Copying Text with Menu Commands”

e “Copying Text With Mouse Buttons”
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¢ “Moving and Copying Text By Dragging”
* “Replacing Text”

*  “Deleting Text”

¢ “Finding and Replacing Text”

¢ “Finding a Location in a Document”

Tip: Pressing the right mouse button anywhere in the NEdit window opens a popup
menu with the Undo, Redo, Cut, Copy, and Paste commands.

Selecting Text with the Mouse

Cutting and Pasting Text

You can select text with either the left mouse button or the middle mouse button. In
general, you use the left mouse button to position the cursor and make primary
selections, and the middle mouse button to make secondary selections and to copy and
drag the primary selection. Use the modifier keys (Shift, Ctrl, and Alt) to modify the
actions. You can obtain details of the use of these buttons for selecting text from the Help
menu at the far right of the NEdit menu bar and choosing Creating and Editing Text >
Selecting Text With the Mouse.

To move text to a new location and delete it from the original site, use the following
procedure:

1. Select the text you want to delete.

2. Choose Edit > Cut (Ctrl+X). The selection is moved to the clipboard (an invisible
area that temporarily stores text and data).

3. Place the cursor at the location at which you want the deleted text to appear and
click the left mouse button.

4. Choose Edit > Paste (Ctrl+V).

Copying Text with Menu Commands
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To copy text to another location and leave the text at the original site, use the following
procedure:
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Select the text you want to copy.

Choose Edit > Copy (Ctrl+C). The selection is copied to the clipboard (an invisible
area that temporarily stores text and data).

Place the cursor at the new location at which you want the text to appear and click
the left mouse button.

Choose Edit > Paste (Ctrl+V).

Copying Text With Mouse Buttons

To copy text without using menu commands, use the following procedure:

1.

Position the cursor in the window in which you want the text to be copied
(destination window) and click the left mouse button. This can be in any NEdit
window. When you move the mouse outside the destination window, the cursor in
the destination window changes to a caret sign.

Position the cursor at the beginning of the text you want to copy, press the middle
mouse button, and drag to the end of the text. The text is underlined as you drag.
When you release the mouse button, the contents are copied to the location at which
you clicked the mouse in step 1.

Moving and Copying Text By Dragging

To drag selected text to a new location in the file and leave the original text in place, use
the following procedure:

1.

Select the text you want to copy.

2. Place the cursor over the selected text, hold down the Shi f t key, press the middle

mouse button, and drag the text to its new location.

To drag selected text to a new location in the file, removing it from the original location
and overlaying the new location with the dragged text, use the following procedure:

1.

Select the text you want to copy.

2. Place the cursor over the selected text, hold down the Ct r | key, press the middle
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mouse button, and drag the text to its new location.
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Replacing Text

Deleting Text

To replace text in a primary location with text from a secondary location and retain the
text in the secondary location, use the following procedure:

1. With the left mouse button, select the text you want to replace (primary selection).

2. Move the cursor to the beginning of the text you want to insert (secondary selection)
and select it by pressing the middle mouse button and dragging it to the end of the
text. The text is underlined as you drag. When you release the mouse button, the
secondary selection replaces the primary selection.

To replace text in a primary location with text from a secondary location and delete the
text in the secondary location, use the following procedure:

1. With the left mouse button, select the text you want to replace (primary selection).

2. Move the cursor to the beginning of the text you want to insert (secondary
selection), hold down the Shi ft key, and select the text by pressing the middle
mouse button and dragging it to the end of the text. The text is underlined as you
drag. When you release the mouse button, the secondary selection replaces the
primary selection and the text in the secondary location is deleted.

To delete text, select the text you want to delete and press Delete or Backspace, or choose
Cut (Ctrl+X) from the Edit menu.

To delete text and replace it at the same time, select the text you want to replace and then
begin typing. The text you enter replaces the selected text.

Finding and Replacing Text

268

NEdit has a number of commands for finding and replacing text. When you select either
Find (Ctrl+F) or Replace (Ctrl+R), a dialog box pops up, in which you enter the text you
want to search for or replace. You can choose whether you want the search to be sensitive
to uppercase and lowercase or whether you want to use the standard UNIX pattern
matching characters. You can also choose whether you want to search forward or
backward in the document. The search begins at the cursor location. You can obtain
details of finding and replacing text from the Help menu at the far right of the NEdit
menu bar and choosing Creating and Editing Text > Finding and Replacing Text and
Creating and Editing Text > Finding and Replacing Using Regular Expressions.
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Finding a Location in a Document

Setting Print Options
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You can find a location in a document from the Search menu by using one of the
following methods:

Goto Line Number (Ctrl+E) (Full Menus mode). Locates the line number you enter
in the dialog box. To show line numbers, click Statistics Line in the Preferences
menu.

Goto Selected (Shift+Ctrl+E) (Full Menus mode). Locates a line number that you
have selected in the text with the left mouse button. Goto Selected does not locate
text. It expects a line number to be selected.

Mark (Ctrl+M a-z) (Full Menus mode). Marks the current selection or cursor
position with a single letter that you enter in the dialog box. You then use the
GotoMark command to recall the location.

Goto Mark (Ctrl+T a-z) (Full Menus mode). Locates the position of the letter marker
that you set with the Mark command.

Match (..) (Shift+Ctrl+M) (Full Menus mode). Finds a matching character anywhere
in the file. Matches {, (, [, <, ", /, /, /, and ~ characters. NEdit does not match words.

Find Definition (Ctrl+D)(Full Menus mode). Finds function definitions in the code,
based on information in a loaded tags file.

To print a file, choose File > Print. A Print dialog box appears. You can set the following
general printing options in the Print Panel dialog box:

Choose a printer from the list of available printers. The default printer is
highlighted.

Choose the number of copies.

Choose what you want printed on the banner page. A banner page is the first sheet
of paper that the printer prints for each print job.

Choose whether you want to be notified when your job has finished printing.

For additional print options, click on the Help menu at the far right of the NEdit menu
bar and select Printing.

269



B: NEdit and jot

Moving Around in Your Filesystem

When you are ready to open a file, you should use the Open option in the File menu.
Using Open in the File menu gives you quick access to previously opened files. (Retyping
the NEdit command in a shell and running additional copies of NEdit takes longer.)
Using the File menu also ensures that you do not accidentally open the same file twice.
It runs as long as at least one editor window is open.

When you choose File > Open (Ctrl+O) to open a file, the "File to Edit:" dialog box
displays the directories and files in the current directory.

Select the file to open in the dialog box and click OK or simply double-click the filename.
The file appears in another NEdit window.

Tip: In file selection dialog boxes, you can type the beginning characters of the
filename or directory in the list and NEdit completes the filename. How much of the
filename you need to enter is determined by the other filenames in the directory.

You can move around the filesystem in any of the following ways:

¢ To move to a different directory, double-click the directory name or select it and
press OK.

¢ Tonavigate upward in the filesystem without typing the directory name, click the
pathbar above the Selection field. Each bar represents a directory level.

e To recall previously selected directories, click the button with the circular arrows to
the right of the Selection field. It displays the directories whose contents you have
previously displayed in the window.

¢ To move directly to a directory, choose the File > Save As option and type the
pathname in the Save File As: field. Pressing the space bar completes a partial
directory or filename. If nothing matches, it beeps. Alternatively, you can drag an
icon from the desktop and drop it in the drop pocket (small square) to the left of the
Selection field.

Using Advanced Features in NEdit

NEdit offers a number of features especially designed for programmers, such as loading
tags files, opening included files, and matching characters. Also offered are a number of
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advanced features, such as using X Window System resources, execution of UNIX shell
commands from within NEdit, and running in server mode or through the NEdit client
program, nc.

You can find more information about features for programmers and advanced features
by clicking on the Help menu at the far right of the NEdit menu bar and selecting
Features for Programmers or Advanced Features.

The jot editor is a fast, mouse-based, ASCII text editor tuned to run on Silicon Graphics
workstations. jot offers the following features:

jot can edit very large files.
jot documents are saved as standard ASCII text files.

jot allows you to use the mouse to cut, copy, and paste text throughout the file. In
addition, text can be cut and pasted between mail utilities and shell windows.

Any ASCII text file can be opened with jot, regardless of how it was created.
An entire text file can be inserted into a jot document.

jot has many features to help with C and C++ source code editing.

A row of five pulldown menus (plus a help menu) contain most of the commands you
use every day.

The File menu contains operations to change the file you are editing, insert text from
another file, print, save, and quit.

The Edit menu contains commands that copy and paste, and perform other
commands that modify text.

The View menu contains commands that let you show line numbers and move
around in your file.

The Select menu contains commands that make it easy to select, mark, and search
text.

The Options menu contains commands that let you change the layout of your jot
file.
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The Help menu contains files that explain how to work with the jot editor. It also
contains a very useful tutorial for jot users.

The remainder of this section contains the following topics:

Working with jot Files

“Working with jot Files”
“Using Keyboard Shortcuts”
“Printing Files”

“Moving Around in a jot File”
“Editing a jot File”

“Using Advanced Features in jot”

The File menu contains most of the commands you need to change the file you are
editing, insert text from another file, print, save, and quit. The File menu contains these

choices:
New Opens a new file.
Open Opens an existing file.

Insert from file Inserts text from another file, such as another jot document, at the

current text cursor location.

Save Saves your file.

Save as Lets you save your file as a new file with a different name.
Print Prints the file.

Quit Quits jot.

Using Keyboard Shortcuts
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Most of jot’s menu entries are followed by a special key name and then a letter. For
example, under the File menu, the “New” command is followed by Al t + N. This is the
keyboard shortcut. Hold down the Al t key and type n to invoke “New.” Do not
capitalize the n unless the jot menu shortcut indicates that you should. For example, if
the shortcut is Alt + capital N, jot lists the shortcut as Shift + Alt + N.
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Printing Files

To print a file, choose “Print” from the File menu. The entire file (or the portion you
select) is printed to your default printer.

Moving Around in ajot File

If the file is too long to be completely displayed in the window, a scroll bar appears on
the right side of the document window. The white section in the scroll bar indicates the
size and position of the selection. If your file contains fewer lines of text than there are
available lines in the jot window, only the white section appears, and there is no scroll

bar.

You can scroll your document several ways:

Use your left mouse button to drag the scroll bar up and down.
To scroll one line of text, click on a scroll arrow.
For a continuous scroll, press and hold a scroll arrow.

To scroll one full page of text, click on a scroll arrow while holding down the Shi f t
key.

To jump to a relative position in the document, click within the scroll bar.

The View and Select menus contain commands that let you move around in your file.

The View Menu Commands
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Top of File Moves the cursor to the top of the file.

Bottom of File Moves the cursor to the bottom of the file.

Page Up Moves up one page in the file.

Page Down Moves down one page in the file.

View Only Locks the file so it can be viewed but not edited.

Show Line Number

Shows the number of each line in the file.
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The Select Menu Commands

The Select menu commands make it easy to select, mark, and search text.
Select All Selects all of the text in the file.
Jump to Line  Moves the cursor to the line in the file that you specify.

Search Forward Searches forward in the file from the cursor’s location.

The Options Menu Commands

Editing a jot File
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Wordwrap Lines
Automatically breaks words and continues them on the next line.

Automatic Indent
Indents the current line of text to begin at the same place as the line
above it.

Search by Case
Allows you to search words with both initial and internal capitalization.

Long Menus
Changes the commands in the File, Edit, View, Select, and Options
menus to include advanced commands. See “Using Advanced Features
in jot” for information on the Long Menu features.

The Edit menu contains commands that copy and paste and perform other commands
that modify text. You can display the Edit menu as a pop-up menu any place within the
jot window by placing the cursor over the window and pressing the right mouse button.
These sections describe the other following functions available in jot:

*  “Selecting Text in jot”

¢ “Duplicating Text in jot”

e “Using the Undo and Redo Commands”

* “Using the Cut, Copy, and Paste Commands”

* “Using the Select All Command”

e “Using the Insert File... Command”
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Selecting Text in jot

You can select text three ways:
* Hold down the left mouse button and drag the cursor over the desired text.

* (lick to position the cursor at the beginning of the desired selection, hold down the
Shi ft key, and then click at the end of the selection.

* Double-click on a word to select only that word.

The selected text appears highlighted.

Duplicating Text in jot
You can duplicate selected text in another location by using the middle mouse button.
You can duplicate the selected text in either another jot document window or in a shell

window.

To duplicate text:
1. Select the text in the jot window.

2. Position the text cursor in the application window where you would like the copy to
appear.
3. Press the middle mouse button.

A copy of the entire selection appears at the text cursor.

Using the Undo and Redo Commands

Choose the “Undo” command to undo the effect of the last action you performed.
“Redo” reapplies the last action.

Using the Cut, Copy, and Paste Commands

Choose the “Cut” command to completely remove selected text and place it in a memory
buffer.

To cut text:
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1. Select the text.

2. Choose “Cut” from the Edit menu.

Choose the “Copy” command to copy selected text into the memory buffer. Copying text
creates a second, identical version of the text and has no effect on the original text.

To copy text:

1. Select the text.

2. Choose “Copy” from the Edit menu.

Choose the “Paste” command to paste the contents of the memory buffer at the position
of the text cursor. If the buffer is empty, choosing “Paste” has no effect. You may use the

Paste command to paste into the same jot document from which you cut or copied, or
into another jot document window.

You may also paste into a shell window by clicking the middle mouse button.

To cut or copy text and paste it into a new location:
1. Select the text.

2. Choose “Cut” or “Copy” from the Edit menu.
3. Position the cursor where you want the text.
4

Choose “Paste” from the Edit menu.

Using the Select All Command

Choose the “Select All” command to select the entire contents of your jot document.

Using the Insert File... Command
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Follow these steps to insert a file into your jot document:

1. Place the text cursor at the appropriate location within the jot document you are
working on.

2. Choose “Insert File...” from the File menu.
A dialog box appears.

3. Enter the pathname of the text file you want to insert.
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4. Click Insert.

The text file is pasted into your document at the text cursor location.

Using Advanced Features in jot

Choose “Long Menus” from the Options menu to access the advanced editing features
in jot. When you select “Long Menus,” more choices appear in each of the menus. What
follows is a basic reference to the features that are added with the “Long Menus” option,
including:

e “Thejot Long Menu File Commands”

e “Thejot Long Menu Edit Commands”

e “Thejot Long Menu View Commands”

e “Thejot Long Menu Select Commands”

e “Thejot Long Menu Options Commands”

For more programming-oriented information on jot, its advanced features, and
customization, see the jot reference page. You can also gain a better understanding of

these features by opening the Help menu in jot and selecting “Tutorial.” After you open
the tutorial, go to its “Advanced Topics” section.

Once you develop an awareness of the advanced menu commands you use often, you
will find the keyboard shortcuts to be a quick option to actually using the menu. See
“Using Keyboard Shortcuts” for more information.

The jot Long Menu File Commands
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The jot long menu option adds four File menu choices: “Reopen,” “Reopen Next,”
“Forget Reopen Entry,” and “Exit with no Save.”

Reopen Allows you to reopen recently opened files. This command triggers a
rollover menu of filenames for you to choose from.

Reopen Next  Reopens files in the order that you last opened them. For example, if you
opened file A, then file B, then file C, and you are currently in file C,
“Reopen Next” will reopen file A. If you choose “Reopen Next” again,
file B will be opened.
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Forget Reopen Entry
Allows you to select files from a rollover menu; by selecting a file, you
take it off of jot’s “Reopen” list.

Exit with no Save
Exits jot without saving your file. Unlike the “Exit” choice, this option
does not prompt you to save your document before exiting.

The jot Long Menu Edit Commands
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The jot long menu option adds nine Edit menu choices: “Append to Copy,” “Newline
and Indent,” “Indent,” “Exdent,” “Transpose,” “Uppercase,” “Lowercase,” “Initial
Caps,” and “Reformat.”

Append to Copy
Adds selected text to the current memory buffer. For example, if you
select a sentence in a jot file, choose “Copy,” then select another sentence
and choose “Append to Copy,” both sentences will appear when you
use “Paste”.

Newline and Indent
Inserts a newline and indents it to match the previous line’s indentation.

Indent Indents current or selected lines by four spaces.

Exdent Reverses indentation by four spaces.

Transpose Transposes the characters on opposite sides of the cursor, or reverses
selected characters.

Uppercase Tranforms all letters in a text selection to uppercase.

Lowercase Tranforms all letters in a text selection to lowercase.

Initial Caps Capitalizes the first letter of a selection of text.

Reformat Reformats block of selected text to the right margin. This command

cleans up the ragged paragraphs that can develop as a result of having
the “Wordwrap” feature turned off. Note that this feature does not align
the text to the right margin, the text alignment will still be with the left
margin.
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The jot Long Menu View Commands

The jot long menu option adds two View menu choices: “Show Cut Buffer” and “Split
Window.”

Show Cut Buffer
Shows you the material you last selected for the “Cut” command.

Split Window Creates another jot session of the file you are currently using. The
original window is reduced to half size and the new jot window is
started directly below it. The new session is a “View Only” mode
duplicate of the first one. You can cut from the “View Only” session and
paste into the original session. Changes made to one window will not be
reflected in the other.

The jot Long Menu Select Commands
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The jot long menu option adds ten Select menu choices: “Select Line,” “Select
Paragraph,” “Get Selection Info,” “Search Back,” “Search and Replace,” “Paste and
Search,” “Set Mark,” “Delete Mark,” “Jump To Mark,” and “Jump To Tag.”

Select Line Selects the entire line in which the cursor is currently placed.

Select Paragraph
Selects an entire paragraph of text. This occurs wherever the cursor is
placed when the “Select Paragraph” command is invoked.

Get Selection Info
Shows you the line number, character number, and column number of
your text selection.

Search Back Searches backward in the file from the cursor’s location.

Search and Replace
Searches for and replaces character strings that you specify in a dialog
box.

Paste and Search
Replaces selected text with text in memory buffer, then searches forward
for the character string you specify.

Set Mark Sets a mark at the location of your cursor. This mark is indicated in blue
in the scroll bar to the right of your text.

Delete Mark  Deletes the mark you set with “Set Mark.”

279



B: NEdit and jot

Jump to Mark Moves your cursor to the mark you set with “Set Mark.”

Jump to Tag  Brings up your tags file, indicating the source code for the function you
specify. This feature is for people who use the IRIX ctags command to
create a tags file; jot can use the information in that file to access
procedure names in C or C++ programs.

The jot Long Menu Options Commands
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The jot long menu option adds eight Options menu choices: “Search Reopen List,”
“Electric C Mode,” “Define Macro,” “Perform Macro,” “Save Macros,” “Filter,” “Shell
Command,” and “Short Menus.”

Search Reopen List
When this feature is turned on, the “Search” mechanism searches for
specified character strings in all the files in your current Reopen list.

Electric C Mode
Helps you type C or C++ source code by making some adjustments to
your current jot session. These are the basic Electric C Mode
characteristics:

* Tab size is set to four spaces.
¢ “Wordwrap Lines” is turned off.
* “Automatic Indent” is turned on.

* Parentheses, brackets, and quotes are automatically matched on the
next line.

¢ Every comma that you type is automatically followed by a space.

¢ The definition of what makes up a word is slightly altered to meet
C and C++ programming needs. For example, the underscore
character is part of a word in Electric C Mode.

Define Macro Programs any user-specified sequence of keystrokes into the F1 through
F12 keys. You choose which “F” key to define from the “Define Macro”
rollover menu. After you choose the key, type in the definition you want.
Then, go back to the Options menu and select “End Macro Definition.”

Perform Macro
Performs the macro of your choice, which you select from the “Perform
Macro” rollover menu.
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Save Macros  Saves all your current defined macros to your ~/.jotmacs file. Every time
you open jot, the .jotmacs file is read.

Filter Allows you to apply an IRIX command to a selected section of text. For
example, you could use “Filter” to apply the sort command to a text
list. The sorted list will then be stored in your “Cut” buffer. To replace
the old list with the sorted list, use the “Paste” command.

Shell Command
Allows you to apply an IRIX command to a selection of text, which is
printed out in your console window. The original text selection stays the
same, but the console printout of your selected text reflects the
command you entered.

Short Menus  Changes jot’s menus to the shortened versions, which leave out the
more advanced commands.
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Standard Desktop Keyboard Accelerators

Table C-1 lists standard keyboard accelerators for the desktop applications. Note that

certain commands are not relevant for certain applications

Table C-1 Standard Desktop Keyboard Accelerators
Command Keyboard Accelerator
“New” Ctrl +n

“Open” Ctrl + o

“Close” Ctrl +w

“Save” Ctrl +s

“Print” Ctrl +p

“Quit/Exit”  Ctrl +q

“Cut” Ctrl + x

“Copy” Ctrl + ¢

“Paste” Ctrl +v

“Undo” Ctrl + z

“Select All”  Ctrl+a

Tip: For an HTML-based, illustrated version of other desktop hints and shortcuts, choose
Help > Hints and Shortcuts from the Toolchest.
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4Dwm
The name of the default Window Manager. See also Window Manager.

account
See login account.

active window

The only window that recognizes input (activity) from the keyboard and mouse; only
one window is active at a time. The active window is the one whose window border is
highlighted.

Administrator

The person who can use the most privileged account, root. This person must have their
own personal login account for daily use, but, when routine maintenence needs to be

performed or there are serious system problems to correct, the person logs in to the root
account to change system information using the graphical tools or using the IRIX shell.

The Administrator has all the capabilities of a privileged user, plus the capability to
change information in the root account (such as the password) and to log in to an IRIX
shell as root.

ASCII text

An ASCII file contains text only. When you save a file as ASCII text, you save only the
characters, not the size, the font, the style, the color, or the format.

autologin
To be automatically logged in to the system each time it is powered up.

automount

An NFS utility that lets you share directories with other systems as if the directory
resided on your own disk. When automount is turned on, you can drag a directory icon
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from the Shared Resources area of another system’s System Manager window onto your
own desktop.

back up

To copy a certain set of files and directories from your hard disk to a tape or other storage
media.

backup tape

A tape that contains a copy of a set of files and directories that are on your hard disk. A
full backup tape contains a copy of all files and directories, including IRIX, that are on
your hard disk.

baud rate

The speed (calculated as bits per second) at which the system sends information to a
serial device, such as a modem or a terminal.

borderless window

A window with no title bar or borders.

business card

When you double-click a person’s icon in the desktop, you see a business card that
displays public information about the person. The information on the business card is
drawn from the person’s User Information window in the Users and Groups tool.

business card information

Business card information appears in the top portion of a person’s User Information
window in the Users and Groups tool; it includes a picture of the person and contact
information about the person. Usually this information is the same for every account that
belongs to a particular person.

button

On a mouse, a button is a switch that you press with a finger. In a window on your screen,
a button is a labeled rectangle that you click using the cursor and mouse.

CD-ROM disk (CD)

A flat metallic-coated plastic disk that contains information that you can view and copy
onto your own hard disk; you cannot change or add to its information. CD-ROM is short
for compact-disk: read-only memory.
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centralized network

A network where a central server controls services and information; the server is
maintained by one or more individuals called network administrators. On a centralized
network that uses NIS, this server is called the NIS master, and all other systems on the
network are called NIS clients. See also network administrator, NIS, NIS client, NIS domain,
and NIS master.

choose

To press the left mouse button to bring up a menu, move the cursor to highlight the
command that you want to run, then release the button.

click
To hold the mouse still, then press and immediately release a mouse button.

command line option

Options that let you specify how you want to run an IRIX command. See the man page
of a command for a list of the available command line options.

configuration file

A system file that you change to customize the way your system behaves. Such files are
sometimes referred to as customization files.

confidence test

A test that you run to make sure a particular device (such as the keyboard, mouse, or a
drive) is set up and working properly.

console

The window that appears as a stowed icon each time you log in; IRIX reports status and
error messages to this window.

CPU

The CPU (Central Processing Unit) is the chip that proccesses data. Depending on the
type and version of a CPU, the system will run at different speeds.

current working directory

The directory within the file system in which you are currently located when you are
working in a shell window.
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cursor

The small red arrow on the screen that echoes the movements of the mouse. It changes
shape depending on its location on the screen.

daisy-chain
A series of SCSI devices that are connected to each other, with one device connected to
the SCSI port on a system and the final device terminated.

DAT

Digital Audio Tape; a magnetic tape from which you can read and to which you can copy
audio and digital information.

default printer

The printer to which the system directs a print request if you do not specify a printer
when you make the request. You set the default printer using the Print Manager.

defaults

A set of behaviors that Silicon Graphics specifies on every system. You can later change
these specifications, which range from how your screen looks to what type of drive you
want to use to install new software. For example, when you run IRIS Showcase, the
Master gizmo opens by default. You can change the default settings using the Preferences
gizmo.

desk

The screen background and the collection of windows that appears on top of it. You can
create multiple desks and switch between them. When you switch from one desk to
another, the screen changes, almost as if you had several different monitors.

desktop

The word desktop often refers to the screen background, but it can also refer to the entire
IRIX Interactive Desktop environment, which includes all the graphical interfaces that

make up your basic software environment. The desktop is similar to an actual office desk.
For example, on your desk, you might have a phone, a container of pens and pencils, and
anumber of folders or notebooks. Other tools and files are stashed away in desk drawers.

By default, a number of items appear on the background, including: the Toolchest, a
folder icon representing your home directory, a dumpster icon, and an icon for each
peripheral you have installed. You can place other icons on the desktop so that you can
access them more easily.
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directory

On the desktop, directories are represented by folder icons. When you open a directory,
it displays the files, folders, and applications that the directory contains. Directory
windows are called Icon Views.

disk directory

A directory that represents an entire disk or a partition of a disk. When you open a disk
directory, you view the contents of the disk.

disk use
The percentage of space on your disk that contains information.

distributed network

A network where there is no automated central control of services or information. Each
system’s administrator must work with the network administrator to keep each system’s
network information up to date.

domain

A group of hosts on a network whose hostnames have the same suffix. See also NIS
domain.

domain name

The common suffix found in all hostnames that are in the same domain on a network. See
also NIS domain.

double-click

To hold the mouse still, then press and release it twice, very rapidly. When you
double-click an icon it opens into a window; when you double-click the Window menu
button, the window closes.

drag
To press and hold down a mouse button, then move the mouse.

drive

A hardware device that lets you access information on various forms of media, such as
hard, floppy, and CD-ROM disks, and magnetic tapes.
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drop pocket

A drop pocket is the small blue square into which you can drop icons. You can drag a
folder icon and place it into the drop pocket on a Directory View window. The window
displays the contents of that folder.

You can also drag a file or application icon and place it in the drop pocket on a Directory
View window. The window displays the contents of the directory in which that icon is
stored.

As a final example, you can drag an IRIS Showcase icon and drop it into a drop pocket
on the Search tool to specify the type of files you want to find—in this case, IRIS
Showcase files.

dumpster

A temporary holding place for icons that you remove using the "Remove" command. To
retrieve files from the dumpster, double-click the dumpster icon; to empty the dumpster,
choose "Empty Dumpster" from the Desktop toolchest.

electronic mail address

Your login name plus location information so you can receive electronic mail. The
address is usually assigned by the network administrator.

field
An area in a window in which you can type text.

file
A container in which you store information such as text, programs, or images you create
using an application.

file hierarchy
See file system.

file system

A hierarchy of directories and files. Directories contain other directories and files; files
cannot contain directories. The root (/) directory is at the top of the hierarchy. See also
pathname.

form

A window that contains buttons that you must click and / or editable fields that you must
fill in.
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global desk

The desk to place windows on if you want them to automatically appear on all of your
desks.

group

A collection of login names. Members of a group can make file permissions apply to all
other members of a group. You create and modify groups using the Users and Groups
tool.

guide
In the Desktop documentation, the word "guide" usually refers to an Interactive Guide
(like a "wizard"), which is a program that steps you through a task.

home directory

A directory in which you create and store your work. Usually, the home directory is
named / usr/ peopl e/ <l ogi nname>, where loginname is the name of your login
account. A folder icon for your home directory appears on the desktop by default.

host
Any system connected to the same local network.

hostname

The name that uniquely identifies each host (system) on the local network.

icon
A small picture that represents a stowed or closed file, directory, application, or IRIX
process.

Icon View

The window you see when you open a folder (also called a directory) icon. It displays the
files, folders, and applications that the directory contains. See Figure 1-1 for a picture of
an Icon View. You can also type an http or FTP site name into an Icon View to see the
contents of a Web or FTP site (see “Accessing Files Using FTP in an Icon View Window”
and “Accessing Files on the Web Using an Icon View Window”).

input focus

Only one window at a time recognizes mouse movement and typing. The window that
does is said to have the input focus.
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inst
The software tool that you use to install system software, software options, and
maintenance releases that come from Silicon Graphics.

IP address
The number that uniquely identifies each system on the network.

IRIS
Any graphics workstation manufactured by Silicon Graphics, Inc.

IRIX
The Silicon Graphics version of the UNIX operating system. See also system software.

IRIX processes

Tasks that IRIX carries out to keep the system running correctly or to complete an explicit
command. Each process has a unique process ID number.

Kb (Kilobyte)

A standard unit for measuring the information storage capacity of disks and memory
(RAM and ROM); 1024 bytes make one Kilobyte.

launch icon

An arrow-shaped icon that appears in the right margin of the IRIS InSight viewer and the
Help viewer. Double-click this icon to run an application.

link
A pointer to a file or directory that exists in a different location in the file system. When

you make a link to a file, you are not creating another instance of the file; you are creating
another location from which you can access the original file.

local workstation, drive, disk, file system, or printer

The physical workstation whose keyboard and mouse you are using, all hardware that is
connected to that workstation, and all software that resides on that hardware or its
removable media.

log in
To give the system your login name so you can start a session on the IRIS workstation.
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log out
To end a session on the IRIS.

login account

A collection of information about a person who can log in to the system. The information
includes the person’s full name, login name, contact information, and the name of a
home directory in which the person can store directories and files. Also called user
account.

login name

The name you use to identify yourself to the system. You type it to log in to the system,
and the system uses it to label files that belong to you. If your system is on a network, the
network administrator usually must approve of the name to make sure it is unique. Also
called user name.

login screen

The window that you see after powering on the system, before you can access files and
directories. The window contains one icon for each login account on the system.

Mb (Megabyte)

A standard unit for measuring the information storage capacity of disks and memory
(RAM and ROM); 1024 kilobytes make one megabyte.

menu

A list of operations or commands that the IRIS can carry out on various objects on the
screen.

menu button

A button that reveals a pop-up menu. Place the cursor over the button; then press the left
mouse button.

minimize

Minimizing a window is a handy way to keep multiple applications running without
having a lot of windows open, or just to move a window temporarily out of the way so
you can access another window. Access the menu for minimizing a window by clicking
the upper left corner of a window. It temporarily turns a window into a small square icon
so that it uses very little screen space. It's like instantly packing an application into a tiny
box and putting it out of the way, but it doesn't close down the application. The current
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state of the application remains unchanged while the application window is minimized.
To restore a minimized window to its original size, click on it.

mount point

The directory on your workstation from which you access information that is stored on
a local or remote disk resource.

mount

To make a file system that is stored on a local or remote disk resource accessible from a
specific directory on your workstation.

mouse

A hardware device that you use to communicate with windows and icons. You move the
mouse to move the cursor on the screen, and you press its buttons to initiate operations.
An optical mouse must always be on the mouse pad for the IRIS to interpret its
movements; a mechanical mouse works on any clean, flat surface.

mouse pad

For an optical mouse, this is the rectangular, metallic surface that reads the movements
of the mouse. For a mechanical mouse, this is a clean, soft rectangular surface that makes
the mouse’s trackball roll efficiently.

multi-tasking system

A system that can run several processes (such as running applications, printing files, and
updating files) simultaneously.

multiuser system

A system that several users can work on simultaneously and maintain private files.

NFS

A networking software option that lets you access files and directories that reside on the
disks of other workstations as if they resided on a local disk in your own workstation.
NFS stands for Network File System.

network

A group of computers and other devices (such as printers) that can all communicate with
each other electronically to transfer and share information.
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Network Access account

A person who has a Network Access account on a system can log in to the system only
when the network and the optional NIS software are running properly. The information
in a Network Access account is entered by the network administrator on the NIS master
system. Privileged Users on other systems on the network cannot change any business

card information about a Network Access account.

network administrator

The network administrator is the person who maintains a network of systems. If the
network runs the optional NIS software, the network administrator maintains the master
database of login account information.

Network File System

A networking software option. It lets you access files and directories that reside on the
disks of other workstations as if they resided on a local disk in your own workstation.

NIS

A networking software option that lets you control network information and services
from a central server called the NIS master. NIS stands for Network Information Service.
See also centralized network, NIS client, NIS domain, and NIS master.

NIS client

Any system on a centralized network that runs NIS other than the NIS master. The NIS
client receives services and information from the NIS master.

NIS domain name

The unique name of a network (or sub-network) that runs NIS.

NIS master

The server that stores the complete database of information about all the hosts (systems)
and users on a centralized NIS network. The NIS master periodically updates host
information on all other systems on the network (NIS clients); its user information is
always available to every host. The network administrator is responsible for setting up,
maintaining, and troubleshooting the NIS master.

notifier

A form that appears when the system requires you to confirm an operation that you just
requested, or when an error occurs.
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open
To double-click an icon, or to select an icon, then choose “Open” from a menu in order to
display a window that contains the information that the icon represents.

open in place

When double-clicking a directory folder icon in a Icon View window, it opens in the
current Icon View window rather than in a new window. The "open in place" behavior
occurs only when it has been selected by choosing Desktop > Customize > Icon Views
from the Toolchest, or Options > Default Layout... in the Icon View window, or when you
hold down the Al t key while double-clicking.

owner

The user who created a particular file or directory and can specify which other users of
the system can access the file.

parent directory

A relative term that refers to a directory that contains another directory. If directory A
contains directory B, then A is the parent directory of B.

password
A combination of letters and /or numbers that only you know; it is an optional element

of your login account. If you specify a password for your account, you must type it after
you type your login name before the system lets you access files and directories.

path

A list of directories the system searches when trying to find a file or run a program. You
can add directories to and delete directories from your path. For instructions, see
"Adding Directories to Your Path."

path finder

The area of a window that contains the drop pocket, the pathname field, the path bar, and
the recycle button (these features are shown in Figure 1-1). You use these fixtures to move
from one directory to another.

pathname

The list of directories that leads you to a specific file or directory in the file system. For
example: / usr/ peopl e/ j ane/ t est . resul t s is a pathname. Note that directories
contain other directories and files. The r oot (/) directory is the original directory, in
which all other directories reside.
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peripheral

A hardware device that adds more functionality to the basic workstation, such as a tape
drive. See also external devices and internal drives.

permission

The information attached to each directory and file that specifies which users can access
it and to what degree. See also “Understanding and Changing Permissions.”

permissions mask

A system setting that specifies the default permissions that the system assigns to newly
created files and directories. The owners of those files and directories can later change the
permissions.

Printer Manager

A tool that you use to set up printer software and monitor jobs that you send to the
printer. You access it through either the System toolchest or the System Manager.

Privileged User

A person whose standard login account includes administrative privileges. When a
Privileged User logs in, he can change his personal work area, and can use the graphical
administration tools to change or customize the entire system (for example, add a disk,
create a login account, or install system software). There can be more than one Privileged
User on the same system.

pop
Windows on the screen can overlap each other. You can pop a window so it appears on
top of other windows.

port
An outlet to which you attach cable connectors.

power cable
The cable that connects the workstation to a grounded electrical outlet.

power down

To turn off the power switches on the workstation chassis and the monitor.
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power up
To turn on the power switches on the workstation chassis and the monitor.

PROM monitor

The interface that you use to communicate with the system after it is powered up, but
before it is booted up and running IRIX.

prompt
A character or word that the system displays in an IRIX shell that indicates that the

system is ready to accept commands. The default prompt for regular user accounts is %
the default prompt for the root account is #.

queue
A list of print jobs waiting to be printed on a particular printer.

quit
To stop running an application.

reference

On the IRIX Interactive Desktop, the word reference refers to a reference icon, which is
an icon that is pointer to a file or directory that exists in a different location in the file
system. When you make a reference icon for a file, you are not creating another instance
of the file; you are creating another location from which you can access the original file.
Reference icons are distinguished by an italicized icon label.

remote

The word remote, used in reference to a workstation ("host"), drive, disk, file system, or
printer, refers to something that you can access across a network; something that is not
physically connected to your workstation, except by a network.

reset button

A physical button on the workstation that you press to cut off, then immediately restore
power to the workstation. You should never press this button while IRIX is running,
unless all attempts to shut down the system using software fail. See also shut down.

restore (files)

To copy files that once resided on your hard disk from another disk or a tape back onto
your hard disk.
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root account

The standard IRIX login account reserved for use by the system administrator. This
account’s home directory is the root (/) directory of the filesystem; the user of the root
account has full access to the entire filesystem (that is, can change and delete any file or
directory). The user of this account is sometimes referred to as the superuser.

root (/) directory
The directory at the top of the file system hierarchy.

SCSI address

A number that uniquely identifies a SCSI device to a system. No two SCSI devices that
are physically connected to the same workstation can have the same SCSI address.

SCSI cable

A cable that connects a SCSI device to a SCSI port on a workstation.

SCSI device

A hardware device that uses the Small Computer System Interface (SCSI) protocol to
communicate with the system. Hard disk, floppy disk, CD-ROM, and tape drives are all
SCSI devices.

select

To position the cursor over an icon then click the (left) mouse button. Once an icon is
selected, it is the object of whatever operation you select from a menu.

serial device

Any hardware device that requires a serial cable connection to communicate with the
workstation.

serial port

An outlet on the workstation to which you connect external serial devices.

server

A system that other systems on the network access to use its disk space, software, or
services.

shared

The word shared can refer to either a directory, media device, or printer, and means that
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the item is made available for users from other systems on your network to use over the
network. For example, if Jan has marked a directory shared, and John has a system on
the same network, he can open that directory on his own system. Similarly, if she has
marked her CD-ROM drive shared, he could use her CD-ROM drive from his own
system.

shelf

The shelf is an Options feature of Icon Views, a place for you to put icons that you need to
use frequently while working in a particular directory. For example, if the directory
contains many files, you might want to place the files you use most frequently on the
shelf. Or, if the directory contains many color Showcase slides, you might want to place
the icon for a color printer onto the shelf.

shell

A window into which you type IRIX commands. To open a shell from the Toolchest,
choose Desktop > Open Unix Shell.

shell script
A program that issues and interprets a sequence of IRIX commands.

shuffle

To change the order in which windows are stacked on the screen.

shut down

To safely close all files, log out, and bring the workstation to a state where you can safely
power it down. You choose “Shut Down System” from the System toolchest menu to do
this.

software option

Any software product that you buy from Silicon Graphics, other than the standard
system software that comes on your system disk.

superuser

An alternate name for the user of the root login account. See also system administrator.

system
All the hardware and software that makes up the computer.
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system disk

The physical disk that contains the standard IRIX operating system software—the
software that makes your workstation run.

system software

The standard IRIX operating system software and Silicon Graphics tools that come on the
system disk and on the tape or CD-ROM that you use in the event of a system crash.

TCP/IP
The standard networking software that is included in the system software.

UNIX

A multiuser, multi-tasking operating system from AT&T upon which the Silicon
Graphics IRIX operating system is based.

user account

A collection of information about a person who can log in to the system. The information
includes the person’s full name, login name, contact information, and the name of a
home directory in which the person can store directories and files. Also called login
account.

User

Any person who has a standard account on the system. When a user logs in, she can only
alter the data in her own user account—her own "room" on the system.

unmount

To make a file system that is accessible from a specific directory on your system
unavailable.

user ID
A number that uniquely identifies a user to the system.

WebJumper
WebJumper is a tool that lets you create icons that “jump” you to your favorite Web sites.

wildcard

A character, usually an asterisk (*), that you use alone to specify all files and directories
that are available, or with a few other letters to specify a group of files and directories that
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have a common element in their names. For example, to specify all files and directories
that begin with the letters “ch,” you would type: ch*

window

A portion of the screen that you can manipulate that contains text or graphics.

window manager

The system program that draws and controls windows. It lets you create and manipulate
windows—move them, resize them, and close them.
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A

access privileges, 106

default settings, 151

defined, 106
activating screen savers, 135
” Add to Global” command, 93, 218
additional fonts, 55
”An Icon” command, 196
appearance of moving windows, 144
applications

available on remote systems, 22

finding available, 19

installing, 19

removing, 24

running, 20

running automatically, 145

specifying command line options for, 21
”Arrange” command

"by Date”, 207

"by Name”, 207

"by Size”, 207

"by Type”, 207
arranging icons, 32, 33, 34, 199, 200, 207, 208, 223,

225, 226, 227, 230, 234, 235, 236

arranging windows, 99
”as Columns” command, 208, 227, 236
"as Gallery” command, 209, 227, 236
”as Icons” command, 208, 226, 235
"as List” command, 208, 227, 235
ASCII files, printing, 54, 66
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” Audio Control” command, 192
audio, volume of, 192
.auxchestrc file, 159

B

background
changing pattern for, 124
making solid, 124

background. See desktop.
borders on windows, 187

"by Date” command, 226, 234
“"by Name” command, 225, 234
"by Size” command, 226, 234
"by Type” command, 226, 234

C

cancelling print requests, 53
changing
background pattern, 124
default permission settings, 151
desks moving
between desks, 89
languages, 146
size of windows, 101
toolchest contents, 157
.chestrc file, 160

click speed, 138
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closing windows, 104 copying windows on, 90

columns, arranging icons in, 34 creating new, 88, 216

deleting, 92,217

displayed in Desks Overview window, 213
global desk, 213,214,218

moving windows between, 89

command line options, 21, 221
control panels, 191
”Copy Selected” command, 216

copying rearranging, 95
desks, 216 removing desks, 92, 217
files to other systems, 116 removing windows from a desk, 218
icons, 193, 205, 232 removing windows from global desk, 94
windows, 90 renaming, 92,216
copyright information, 198 resizing display of, 98,217
creating switching between, 89
desks”New Desk” command, 88 the global desk, 93
cursor speed, 137 "Desks Overview” command, 191
”Customize” Command/ 191 Desks Overview WindOW, 212
customizing and window names, 96

background pattern, 124 desk display area, 213, 214

mouse and cursor speed, 137 DQSk menu on, 215
print jobs, 54, 59 displaying the menubar, 214

Search tool, 86,224 hiding the menubar, 214
keyboard shortcuts for, 220
”Overview” menu on, 214
D quitting, 215
rearranging desks in, 95
resizing, 96, 98

default permission settings, 151
Window menu on, 217

default printer, 73

. desktop
Delet.e Selected” command, 217 changing the background, 124
deleting defined, 29

applications, 24

disabling icons on, 155
desks, 92,217

making solid, 124

files, 42 placing icons on, 29
deleting files, 153 printer icons on, 56
Desk menu, 215 saving layout of, 145
desks, 212,216 size of icons on, 148
and the Desks Overview command, 191 desktop help, 198
arranging windows into, 99 "Desktop Help” command, 198
changing display of, 97 Desktop Settings Control Pane, 154

copying desks, 216
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Desktop Settings Control Panel, 148, 151, 153, 154,

155
Desktop toolchest, 190
directories
copying to other systems, 118
creating new, 47, 194, 204
determining ownership of, 107
finding, 85
home directory, 190
in your search path, 156
opening, 43
renaming, 47
sharing with other users, 107
Directory View windows
copying files between, 111
Display as Icons button, 199, 223, 230
Display in Columns button, 200, 223, 230
Display Shelf Button, 200
keyboard shortcuts for, 210
List Button, 199, 223, 230
on other systems, 22
opening, 43
Preview Images button, 200, 223, 230
Selected menu on, 205
shelf, 203
thumbwheel on, 200, 223, 230
toolbar on, 199

disabling the desktop, 155
disks

copying from floppy, 40

copying to floppy, 39
"Display Icon Name” command, 215
"Display No Names” command, 215
”Display Window Name” command, 215
dot (.) files, 35,209
double-click speed, 138
dragging and dropping icons, 188, 201
drop pocket, 46, 188, 201
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dumpster, 153, 192
files in, 42

E

”"Empty Dumpster” command, 42, 192
enlarging windows, 187

error messages
file overwrite message, 154
printing errors, 73
status panel for, 154

EZsetup account, 16

F

files
copying files from floppy, 40
copying files to floppy disk, 39
determining ownership of, 107
finding, 78, 80, 81, 195, 196, 233
finding certain types, 83
naming, 47, 50
on remote systems, 84
opening, 48
printing, 57,193, 206, 233
removing, 42, 153, 193, 206, 233
renaming, 47
saving, 49
viewing hidden, 35
”Find an Icon” command, 78, 195, 233
Find toolchest, 196
finding
application icons, 19
directories, 85
files, 78, 80, 81
large files, 82
types of files, 83
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floppy disks
copying files from, 40
copying files to, 39
fonts, additional, 55
ftp command, 115

G

”Get Info” command, 194, 207, 233

global desk, 93,213,214, 218
removing windows from, 94

”Goto Selected” command, 216
group, 106
guest account, 16

H

Help toolchest, 197

hidden files, 35

"Hidden Files” command, 209

”Hide Global Desk/Show Global Desk” command,
214

"Hide Menubar/Show Menubar” command, 214

“"Home Directory” command, 190

horizontal toolchest layout, 141

Icon Catalog, 19, 24, 229
adding icons to, 30
adding pages to, 231
closing, 232
creating new collections, 31, 231
keyboard shortcuts for, 236
page display area on, 229
removing pages from, 31, 231

306

renaming pages in, 231
turning pages, 231
turning pages in, 32, 231

icons
accessing easily, 28
accessing from multiple places, 41
and the Icon Catalog, 24
arranging, 207, 225, 226
collections of, 24, 231
copying, 193, 205, 232
displaying in columns, 34
finding, 78, 80, 81, 195, 196, 233
group icons, 24
linked copies of, 41, 205
listing, 33
naming, 47, 50
on a shelf, 28
on desktop, 29
printer icons, 52
removing, 42,193, 206, 233
renaming, 47
resizing, 33, 148, 200, 223, 230
sorting, 32
storing on Icon Catalog pages, 30

image files

previewing, 200, 209, 223, 227, 230, 236

printer settings for, 65

printing, 54
Impressario, 55
InSight, 198
installing applications, 19
interactive window placement, 144
international settings, 146

IRIX commands
and command line options, 21,221

K

keyboard settings, 140
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keyboard shortcuts
for Desks Overview window, 220
for Directory View windows, 210
for Icon Catalog, 236
for Search tool, 228

L

languages, keyboard layouts for, 146
large files, finding, 82
Launch window, 21, 221
layout, saving desktop, 145
left-handed mouse, 138
“Legal Notice” command, 198
linked copies, 41,205
”List All...” command, 91, 217
listing icons, 33, 199, 208, 223, 227, 230, 235
listing windows, 91,217, 219
locking screen savers, 135
“Log Out” command, 192
logging in

to remote systems, 119, 120
logging out, 192
login accounts, 16

creating, 16
"Lower” command, 219
lowering windows, 103, 219

M

"Make Copy” command, 193, 205, 232
“Make Linked Copy” command, 41, 205
makeDotDesktop window, 241

making copies of windows, 90

man pages, 198
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”"Man Pages” Command, 198

Maximize button, 187

maximizing windows, 187

”"Minimize All” command, 218

Minimize button, 187

"Minimize” command, 218

minimizing windows, 95,102, 143, 187, 218
monitor, and screen savers, 134

mouse setting

for left-handed use, 138
mouse settings, 137

click and double-click speed, 138
moving

icons

onto the desktop, 37
icons between systems, 37
windows between desks, 89

N

naming
desks, 92,216
guidelines for, 47, 50

networks
copying files between, 111
printers available on, 56
searching across, 84

"New” command, 224

"New Desk” command, 216

new directories, creating, 47, 194, 204
”"New Directory” command, 47, 194, 204
”"New Page” command, 231

nodesktop file, 155
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o default settings, 151
defined, 106
“Online Books” command, 198 ”Permissions” command, 206
online documentation, 198 popping windows, 103, 218
online help, 198 PostScript files, printing, 54, 64
opaque windows, 144 powering off the system, 12
”Open Icon” command, 20, 193, 205, 232 previewing images, 200, 209, 223, 227, 230, 236
opening ”Print” command, 58, 193, 206, 233
applications, 20 Print Panel, 59
directories, 43

files, 48 Printer Manager, starting, 52

remote directories, 111
order of desks, 95
organizing windows, 99

printers
checking queue for, 53
choosing default, 73
dropping icons on, 58

OutofBox account, 16 icons for, 52, 56
"Overview” menu, 214 job status, 52
owner of files, 107 queue for, 52

searching network for, 56
status of, 68

P testing, 72
printing
"Page Down” command, 225, 231 ASCII files, 54
Page menu, 224 banner pages, 61
"Page Up” command, 225, 231 cancellipg requests, 53,70
customized settings, 54, 59
pages files, 57, 193, 206, 233

in Icon Catalog, 31, 32, 229

in Search tool, 222

removing from Icon Catalog, 31, 231
removing from Search tool, 225
renaming in Icon Catalog, 231
renaming in Search tool, 224
turning Icon Catalog pages, 32

image files, 54
multiple copies, 61
PostScript files, 54
text files, 54
troubleshooting, 73

pushing windows, 103, 219

passwords, and locking screen savers, 135

path bar, 46, 188, 202 Q

path, adding directories to, 156

pathname field, 188, 201 ”Quit” command, 225, 232

permission settings, 206 ”Quit” command, Desks Overview window, 215

and file ownership, 106
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R

"Raise” command, 218
raising windows, 103, 218
rcp command, 117
rearranging desks, 95
recycle button, 46, 189, 203
red outline of moving windows, 144
release notes, 198
"Release Notes” command, 198
remote directories, opening, 22,111
”Remote Directory” command, 22
remote systems
and the rsh command, 119
and the telnet command, 120
applications on, 22
copying files between, 111
copying files to and from, 116
finding files on, 84
logging in to, 119
printers on, 56
"Remove” command, 42,193, 206, 225, 231, 233
"Remove from Desk” command, 218
removing
applications, 24
desks, 92,217
files, 42,153, 193, 206, 233
Icon Catalog pages, 31, 231
icons, 42,193, 206, 233
Search tool pages, 225
windows from global desk, 94
“"Rename” command, 224, 231
"Rename Selected” command, 216

renaming
desks, 92,216
Icon Catalog pages, 231
icons, 47
Search tool pages, 224

007-1342-170

resizing
Desks Overview window, 96, 98

display area in Desks Overview window, 98, 217

icons, 33,148, 200, 223, 230
windows, 101

"Restore All” command, 218
"Restore” command, 218
results of a search, 222
rlogin command, 119

rlogin command, 23

root account, 16

rsh command, 119

running applications, 20

S

sash, 203
saving
custom searches, 86
files, 49
”Scaling” command, 217
scanners, support for, 55

screen savers
choosing, 134
when to activate, 135

scroll bars, 188, 202

Search tool, 222
adding pages to, 224
closing, 225
custom searches, 86, 224
keyboard shortcuts for, 228
Page menu on, 224
pages in, 222
removing pages in, 225
renaming pages in, 224
results area, 222
turning pages in, 225
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searching stowing windows, 95,102, 143, 187, 218
across networks, 84 switching between desks, 216
by file type, 83
default search path, 156
for files, 78, 80, 81
for large files, 82

”System Shutdown” command, 12
System toolchest, 197
system.c hestrc file, 157

security
and locking screen savers, 135
and login accounts, 16
Selected menu, 205
Selected toolchest, 192

T

telnet command, 120
text files, printing, 54

session management, 145 title bar, 186
.sgisession file, 157 7to Grid” command, 226
sharing directories, 107 toolbar, on Directory View windows, 199
shelf toolchests
def1r'1ed,' 28, 200, 203 changing orientation of, 141
placing icons on, 28 Desktop toolchest, 190
shell windows, 192 Find toolchest, 196
shortcuts Help toolchest, 197
for Desks Overview window, 220 modifying, 157
for Directory View windows, 210 Selected toolchest, 192
for Icon Catalog, 236 System toolchest, 197
for Search tool, 228 transferring directories, 118
“Show Query” command, 227 transferring files, 116
“Show Snapshots/Hide Snapshots” Command, 214 trash icon. See dumpster.
shutting down, 12 troubleshooting
size opening remote directories, 113
finding large files, 82 print problems, 73
of Desks Overview window, 98 turning off desktop icons, 155

of icons, 148, 200, 223, 230

- turning off the system, 12
of windows, 101

turning on screen savers, 135
software

copyright notice, 198
installing, 19 U

sorting icons, 32

sounds ”Unix Shell” command, 192
volume of, 192

starting, applications, 20
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Vv

vertical toolchest layout, 141
viewing directories, 43
volume, 192

W

Window menu, 217
Window Menu button, 187
Window Settings control panel, 141, 143, 144, 145

windows
anatomy of, 185
appearance while moving, 144
arranging in desks, 88, 99
border surrounding, 187
closing, 104
copying, 90
displaying names of, 96, 215
drop pockets on, 188, 201
listing all open windows, 91, 217, 219
lowering, 103, 219
Minimize button on, 187
minimizing, 95, 102, 218
moving between desks, 89
path bar on some windows, 188, 202
pathname field on some windows, 188, 201
placing automatically, 144
placing on all desks, 93,218
raising, 103,218
recycle button on, 189, 203
removing from a desk, 218
resizing, 101
scroll bars on, 188, 202
title bar on, 186
Window Menu button on, 187
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zooming icons, 33, 200, 223, 230

311






